This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 830748 - T520 blank screen on boot (intel/nvidia optimus, intel configured for panel)
T520 blank screen on boot (intel/nvidia optimus, intel configured for panel)
Status: CLOSED DUPLICATE of bug 835648
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.3
Unspecified Unspecified
high Severity urgent
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 06:35 EDT by Tomas Pelka
Modified: 2014-09-13 14:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 13:49:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages (78.97 KB, text/plain)
2012-06-11 06:35 EDT, Tomas Pelka
no flags Details
xorg log (48.40 KB, text/plain)
2012-06-11 06:36 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2012-06-11 06:35:36 EDT
Created attachment 590894 [details]
messages

Description of problem:
NVS 4200M (Lenovo T520) wont boot, just a black screen with cursor (not blinking) available. Logs attached

Version-Release number of selected component (if applicable):
kernel-2.6.32-269.el6
xorg-x11-drv-nouveau-0.0.16-13.20110719gitde9d1ba.el6

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
no screen

Expected results:
should work as expected

Additional info:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [Quadro NVS 4200M] [10de:1057] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device [17aa:21d1]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f0000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at d0000000 (64-bit, prefetchable) [size=32M]
	Region 5: I/O ports at 4000 [size=128]
	Expansion ROM at f1000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Not Supported, TimeoutDis+
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
		LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB
	Capabilities: [b4] Vendor Specific Information <?>
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb
Comment 1 Tomas Pelka 2012-06-11 06:36:53 EDT
Created attachment 590895 [details]
xorg log
Comment 2 Ben Skeggs 2012-06-13 08:30:34 EDT
This is likely to be an Intel driver bug.  From your logs the machine is configured in "NVIDIA Optimus" mode, which means the internal panel is driven by the Intel GPU.

You can force the NVIDIA GPU to be used by selecting "Discrete Graphics" in the BIOS setup to test Nouveau.  However, this bug should stay around for Intel fixes.
Comment 3 Martin 2012-06-13 10:00:00 EDT
I can reproduce this bug with "Discrete Graphics" in the BIOS setup on T520, when Intel is disabled.
Comment 4 Ben Skeggs 2012-06-14 07:07:40 EDT
(In reply to comment #3)
> I can reproduce this bug with "Discrete Graphics" in the BIOS setup on T520,
> when Intel is disabled.

I'm sorry, but that'd be a different bug.  Or indeed something else completely unrelated to video drivers.  The original report was for Intel-mode, and it didn't work there.

If it is a video driver issue and also doesn't work in NVIDIA mode then it deserves a new report, with supporting log files.
Comment 5 Tomas Pelka 2012-06-21 06:16:22 EDT
Hi Ben,

are you really sure it is Intel's issue? We are booting NV only and kernel stucked on "ACPI: WMI: mapper load" so is it before "kernel: [drm] Initialized drm 1.1.0 20060810". Kernel is totaly frozen, no panic simply nothing.

So it seems to us as a nouveau problem more than Intel one.

Do we have more debugging options? 

Thanks 
Tom


See messages with optimus (I think it is relevant to nouveau even if it with optimus, we are not able to get the log with nouveau only):
==========================
Jun 11 11:01:39 localhost kernel: nouveau 0000:01:00.0: power state changed by ACPI to D0
Jun 11 11:01:39 localhost kernel: nouveau 0000:01:00.0: power state changed by ACPI to D0
Jun 11 11:01:39 localhost kernel: nouveau 0000:01:00.0: enabling device (0000 -> 0003)
Jun 11 11:01:39 localhost kernel: nouveau 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: Detected an NVd0 generation card (0x0d9170a1)
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: acceleration disabled by default, pass noaccel=0 to force enable
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PRAMIN
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PROM
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PCIROM
Jun 11 11:01:39 localhost kernel: nouveau 0000:01:00.0: Invalid ROM contents
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Jun 11 11:01:39 localhost kernel: [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from ACPI
Comment 6 Ben Skeggs 2012-06-21 20:32:03 EDT
The kernel log linked from the first comment shows what appears to be a successful boot in Optimus mode, where nouveau hasn't detected any displays (which is correct, since the panel is driven by the intel gpu in this case).  If you're seeing a blank screen there, then the intel driver hasn't done its job correctly.

It's possible there's more than one issue here I guess, but it's hard to say.

What happens if you boot in Optimus mode and add "nouveau.modeset=0" to your boot options?
Comment 7 Martin 2012-06-26 13:49:59 EDT
Optimus and Intel only modes are booting fine (no blank screen). Created new bugreport without confusing Optimus logs.

*** This bug has been marked as a duplicate of bug 835648 ***

Note You need to log in before you can comment on or make changes to this bug.