Bug 830762 - lucene ships POMs with uninitialized version properties
Summary: lucene ships POMs with uninitialized version properties
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lucene
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krzysztof Daniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-11 11:16 UTC by Michel Alexandre Salim
Modified: 2014-01-13 00:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-01 08:39:10 UTC
Type: Bug


Attachments (Terms of Use)
POM file for clucy (2.01 KB, text/xml)
2012-06-11 11:16 UTC, Michel Alexandre Salim
no flags Details
Patch to lucene spec to fix @version@ instantiation (1.49 KB, patch)
2012-06-11 11:38 UTC, Michel Alexandre Salim
no flags Details | Diff

Description Michel Alexandre Salim 2012-06-11 11:16:45 UTC
Created attachment 590902 [details]
POM file for clucy

Description of problem:
The latest Lucene RPM ships with POMs that have unitialized version properties, thus causing mvn-rpmpackage to fail when building a package that uses Lucene as a dependency.

Version-Release number of selected component (if applicable):
lucene-2.9.4-8.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. grep "<version>@version@</version>" *lucene*.pom | wc -l
2. Attempt to build clucy (https://github.com/weavejester/clucy) using the attached POM file

  
Actual results:
1. => 59
2. => fails with

[ERROR] Failed to execute goal on project clucy: Could not resolve dependencies 
for project clucy:clucy:jar:0.3.0: The following artifacts could not be resolved
: org.apache.lucene:lucene-highlighter:jar:latest, org.apache.lucene:lucene-memo
ry:jar:@version@: The repository system is offline but the artifact org.apache.l
ucene:lucene-highlighter:jar:latest is not available in the local repository. ->
 [Help 1]


Expected results:
1. => 0
2. => succeeds

Additional info:

Comment 1 Michel Alexandre Salim 2012-06-11 11:38:07 UTC
Created attachment 590906 [details]
Patch to lucene spec to fix @version@ instantiation

Patch added that fixes the issue. Please review; I can commit and do updates if you want.

Comment 2 Michel Alexandre Salim 2012-06-11 11:41:42 UTC
Note: build is still failing:


[ERROR] Failed to execute goal on project clucy: Could not resolve dependencies for project clucy:clucy:jar:0.3.0: The following artifacts could not be resolved: org.apache.lucene:lucene-highlighter:jar:2.9.4, org.apache.lucene:lucene-memory:jar:2.9.4: The repository system is offline but the artifact org.apache.lucene:lucene-highlighter:jar:2.9.4 is not available in the local repository. -> [Help 1]

let me check the way lucene registers its POMs as well, something might be wrong

Comment 3 Michel Alexandre Salim 2012-06-11 11:44:02 UTC
OK, the problem was really that I needed to depend on lucene-contrib -- the @version@ issue is just an annoyance as mvn-rpmbuild really ignores versions. But it's still nice to have a fix, regardless. Build now succeeds.

Comment 4 Krzysztof Daniel 2013-03-01 08:39:10 UTC
Patch release into rawhide. Verified by unpacking built rpms and ensuring 
 find . -name *.pom -exec grep -H @version@ {} \;
 returned no results.
 
 Thanks for the patch, it's really appreciated!


Note You need to log in before you can comment on or make changes to this bug.