Bug 830777 - Review Request: clucy - Clojure interface to Lucene
Review Request: clucy - Clojure interface to Lucene
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 830714 830784
  Show dependency treegraph
 
Reported: 2012-06-11 07:52 EDT by Michel Alexandre Salim
Modified: 2012-07-12 14:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 14:55:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mail: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2012-06-11 07:52:15 EDT
Spec URL: http://salimma.fedorapeople.org/specs/clojure/clucy.spec
SRPM URL: http://salimma.fedorapeople.org/specs/clojure/clucy-0.3.0-1.fc17.src.rpm
Description:
Clucy is a Clojure interface to Lucene.

Fedora Account System Username: salimma
Comment 1 Michel Alexandre Salim 2012-06-11 12:18:50 EDT
Spec URL: http://salimma.fedorapeople.org/specs/clojure/clucy.spec
SRPM URL: http://salimma.fedorapeople.org/specs/clojure/clucy-0.3.0-2.fc17.src.rpm

Source-only Leiningen libraries cannot be built using Maven - switching clucy to a scriptlet that builds the JAR manually, borrowed from upstream's Debian branch
Comment 2 kushaldas@gmail.com 2012-06-17 07:00:48 EDT
Taking this review.
Comment 3 kushaldas@gmail.com 2012-06-19 06:53:02 EDT
Package Review
==============

Key:
- = N/A
x = Pass
! = Fail
? = Not evaluated



==== Generic ====
[x]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[-]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Buildroot is not present
     Note: Unless packager wants to package for EPEL5 this is fine
[x]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: MUST Sources contain only permissible code or content.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
     Note: Note: defattr macros not found. They would be needed for EPEL5
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[!]: MUST Spec file lacks Packager, Vendor, PreReq tags.
     Note: Found : Vendor: weavejester
     We will call it as 'upstream' before comitting.
[x]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf would be needed if support for EPEL5 is required
[-]: MUST Large documentation files are in a -doc subpackage, if required.
[x]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[x]: MUST License field in the package spec file matches the actual license.
[x]: MUST Package consistently uses macros (instead of hard-coded directory
     names).
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST Package does not generate any conflict.
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint output is silent.
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: MUST Package contains a SysV-style init script if in need of one.
[x]: MUST File names are valid UTF-8.
[-]: MUST Useful -debuginfo package or justification otherwise.
[x]: SHOULD Reviewer should test that the package builds in mock.
[-]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: SHOULD Package functions as described.
     Tested with Leiningen 1.7.1
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[x]: SHOULD Scriptlets must be sane, if used.
[x]: SHOULD SourceX is a working URL.
[-]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[!]: SHOULD %check is present and all tests pass.
     But we'll need to wait until Leiningen before we can run tests easily
[x]: SHOULD Packages should try to preserve timestamps of original installed
     files.
[x]: SHOULD Spec use %global instead of %define.

Issues:
     
[!]: MUST Spec file lacks Packager, Vendor, PreReq tags.
     Note: Found : Vendor: weavejester
     We will call it as 'upstream' before comitting.

Review APPROVED.
Comment 4 Michel Alexandre Salim 2012-06-28 12:36:02 EDT
Thanks!

New Package SCM Request
=======================
Package Name: clucy
Short Description: Clojure interface to Lucene
Owners: salimma
Branches: f16 f17
InitialCC:
Comment 5 Jon Ciesla 2012-06-28 12:45:57 EDT
Git done (by process-git-requests).
Comment 6 Fedora Update System 2012-07-01 00:01:36 EDT
clucy-0.3.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/clucy-0.3.0-2.fc17
Comment 7 Fedora Update System 2012-07-01 00:01:46 EDT
clucy-0.3.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/clucy-0.3.0-2.fc16
Comment 8 Fedora Update System 2012-07-02 18:25:54 EDT
clucy-0.3.0-2.fc17 has been pushed to the Fedora 17 testing repository.
Comment 9 Fedora Update System 2012-07-12 14:55:09 EDT
clucy-0.3.0-2.fc17 has been pushed to the Fedora 17 stable repository.

Note You need to log in before you can comment on or make changes to this bug.