Bug 830783 - RHN Push hangs at: Computing checksum and package info. This may take some time ...
RHN Push hangs at: Computing checksum and package info. This may take some ti...
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-06-11 08:11 EDT by Martin Juhl
Modified: 2012-11-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 05:48:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Juhl 2012-06-11 08:11:40 EDT
Description of problem:
When trying to push a package by rhnpush, the process just hangs and can't be interrupted. 


Version-Release number of selected component (if applicable):
rhnpush-5.5.42-1.el6.noarch

spacewalk-jpp-workaround-1.0.1-1.el6.noarch
spacewalk-admin-1.7.4-1.el6.noarch
spacewalk-certs-tools-1.7.3-1.el6.noarch
spacewalk-backend-tools-1.7.38-1.el6.noarch
spacewalk-java-1.7.54-1.el6.noarch
spacewalk-selinux-1.7.2-1.el6.noarch
spacewalk-base-minimal-1.7.28-1.el6.noarch
spacewalk-java-postgresql-1.7.54-1.el6.noarch
spacewalk-backend-sql-postgresql-1.7.38-1.el6.noarch
spacewalk-backend-1.7.38-1.el6.noarch
spacewalk-backend-xml-export-libs-1.7.38-1.el6.noarch
spacewalk-backend-iss-export-1.7.38-1.el6.noarch
spacewalk-backend-applet-1.7.38-1.el6.noarch
spacewalk-taskomatic-1.7.54-1.el6.noarch
spacewalk-setup-jabberd-1.6.5-1.el6.noarch
spacewalk-search-1.7.3-1.el6.noarch
spacewalk-client-repo-1.7-5.el6.noarch
spacewalk-doc-indexes-1.1.1-1.el6.noarch
spacewalk-monitoring-selinux-1.7.2-1.el6.noarch
spacewalk-pxt-1.7.28-1.el6.noarch
spacewalk-config-1.7.3-1.el6.noarch
spacewalk-java-lib-1.7.54-1.el6.noarch
spacewalk-backend-sql-1.7.38-1.el6.noarch
spacewalk-backend-xmlrpc-1.7.38-1.el6.noarch
spacewalk-backend-config-files-1.7.38-1.el6.noarch
spacewalk-backend-package-push-server-1.7.38-1.el6.noarch
spacewalk-html-1.7.28-1.el6.noarch
spacewalk-schema-1.7.55-1.el6.noarch
spacewalk-common-1.7.3-1.el6.noarch
spacewalk-monitoring-1.4.1-1.el6.noarch
spacewalk-base-1.7.28-1.el6.noarch
spacewalk-java-config-1.7.54-1.el6.noarch
spacewalk-backend-libs-1.7.38-1.el6.noarch
spacewalk-backend-server-1.7.38-1.el6.noarch
spacewalk-backend-app-1.7.38-1.el6.noarch
spacewalk-backend-config-files-tool-1.7.38-1.el6.noarch
spacewalk-backend-iss-1.7.38-1.el6.noarch
spacewalk-sniglets-1.7.28-1.el6.noarch
spacewalk-setup-1.7.10-1.el6.noarch
spacewalk-postgresql-1.7.3-1.el6.noarch
spacewalk-branding-1.7.1-1.el6.noarch
spacewalk-backend-config-files-common-1.7.38-1.el6.noarch
spacewalk-backend-xp-1.7.38-1.el6.noarch
spacewalk-grail-1.7.28-1.el6.noarch
spacewalk-repo-1.7-5.el6.noarch
spacewalk-slf4j-1.6.1-1.el6.noarch


How reproducible:
Every time..


Steps to Reproduce:
1. rhnpush <some.rpm>

  
Actual results:
rhnpush -vvvvvvvvvvvvvv <some.rpm> 
Connecting to https://localhost/APP
url is https://localhost/PACKAGE-PUSH
Result codes: 200 OK
Computing checksum and package info. This may take some time ...

<HANGS>

Expected results:
Package should be pushed...

Additional info:
Comment 1 Martin Juhl 2012-06-14 06:28:50 EDT
More info:

This is also affecting spacewalk-repo-sync, which also hangs on checksumming...

I also tried updating to nightly... Same problem...

I think the problem is somewhere in rhnpush/spacewalk-repo-sync..

If I use an old rhnpush (0.4.5-2.el6), then it works..

But the currently installed version (5.5.44-1.el6) doesn't....
Comment 2 Martin Juhl 2012-06-14 07:43:10 EDT
I have traced this problem down to:

/usr/share/rhn/rhnpush/rhnpush.py

If this file is replaced from the old version, it works...

There are not that many differences between the new and old file.. so i'll try to do some more investigation into this issue...

Any inputs??
Comment 3 Martin Juhl 2012-06-14 10:12:58 EDT
It's around line 450-550 in rhnpush.py....
Comment 4 Martin Juhl 2012-06-14 10:23:15 EDT
traced on...

it's this line:

res, h = _rpmts.hdrFromFdno(self, fd)


at /usr/lib64/python2.6/site-packages/rpm/transaction.py line 147...

Can anyone tell me what this line does????
Comment 5 Martin Juhl 2012-06-21 05:26:51 EDT
I have now also tried upgrading to nightly builds, and the problem still remains....
Comment 6 Martin Juhl 2012-06-22 05:47:59 EDT
Apparently something was broken in the rhnpush database...

running:

rm -rf /var/cache/rhn/rhnpush-rpmdb

Fixed the problem....

Note You need to log in before you can comment on or make changes to this bug.