Bug 830810 - The search in LibreOffice help systen doesn't work (missing dependency on lucene-contrib)
The search in LibreOffice help systen doesn't work (missing dependency on luc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 09:02 EDT by Eugene Saenko
Modified: 2012-06-27 23:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-3.5.4.2-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:44:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (177.10 KB, image/png)
2012-06-11 10:48 EDT, Eugene Saenko
no flags Details
trace on 32-bit system (35.68 MB, text/plain)
2012-06-18 13:22 EDT, Eugene Saenko
no flags Details

  None (edit)
Description Eugene Saenko 2012-06-11 09:02:29 EDT
Description of problem:
The search in help system for any text in help system of LibreOffice brings up the same result: "No topics found."


Version-Release number of selected component (if applicable):
LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)

How reproducible:


Steps to Reproduce:
1. Start LibreOffice Writer.
2. Select LibreOffice Help in menu.
3. Go to tab Find.
4. Type "select" inthe field "Search term" and press the button "Find".
  
Actual results:
"No topics found."


Expected results:
List of topics, containing the word "select".


Additional info:
In vanilla LibreOffice all works as expected.
Comment 1 Caolan McNamara 2012-06-11 10:34:10 EDT
I launch writer, go to help, go to "find" and type "select" in there and I get a huge list of pages.

Is this a language issue, i.e. what's the output of

locale

?
Comment 2 Eugene Saenko 2012-06-11 10:48:36 EDT
Created attachment 590959 [details]
screenshot
Comment 3 Eugene Saenko 2012-06-11 10:52:00 EDT
$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

The behaviour is identical wether I select English(US) or Russian interface language.
Comment 4 Eugene Saenko 2012-06-11 10:58:30 EDT
When I start LO from consile I see:
[ses@ses-new ~]$ libreoffice --writer

(process:2381): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table != NULL' failed
Comment 5 Caolan McNamara 2012-06-11 11:13:48 EDT
can't see how that glib assert would affect help, which works here (x86_64) in both English and Russian with a search term of select.

If you put your mouse over e.g. the "Bold" icon do you get the floating tooltip that describes it as a "Bold" feature ? (this stuff is connected to help, that's why I ask)
Comment 6 Eugene Saenko 2012-06-11 11:20:50 EDT
Yes I have this tooltip.

But my system is not x86_64 but i386.
Comment 7 Vasiliy Glazov 2012-06-18 07:19:47 EDT
I can confirm bug on x86_64.
Comment 8 Caolan McNamara 2012-06-18 11:04:04 EDT
"works for me"(tm).

Can you guys try this...

yum -y install strace
strace -f /usr/lib64/libreoffice/program/soffice.bin > ~/strace.log 2>&1
make the "no search term dialog" appear and then attach the ~/strace.log to this bug
Comment 9 Eugene Saenko 2012-06-18 13:22:38 EDT
Created attachment 592705 [details]
trace on 32-bit system
Comment 10 Eugene Saenko 2012-06-18 13:39:43 EDT
As my system is 32-bit the command line is like:
strace -f /usr/lib/libreoffice/program/soffice.bin > ~/strace.log 2>&1
Comment 11 Caolan McNamara 2012-06-18 13:57:15 EDT
CJKAnalyzer.class", 0xbf8f41a0) = -1 ENOENT (No such file or directory)

*groan*, I bet its a missing dependency on lucene-contrib :-(.

so try yum -y install lucene-contrib and see if that fixes it. If it does then I'll do an update to add that missing dependency.
Comment 12 Eugene Saenko 2012-06-18 14:11:57 EDT
After install lucene-contrib all plays OK :)
Thank you!
Comment 13 Caolan McNamara 2012-06-18 15:00:03 EDT
will be fixed in >= libreoffice-3.5.4.2-4.fc17
Comment 14 Fedora Update System 2012-06-19 03:00:01 EDT
libreoffice-3.5.4.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.4.2-4.fc17
Comment 15 Fedora Update System 2012-06-19 20:25:16 EDT
Package libreoffice-3.5.4.2-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.4.2-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9664/libreoffice-3.5.4.2-4.fc17
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-06-27 23:44:31 EDT
libreoffice-3.5.4.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.