Bug 830838 - freenx-server uses authorized_keys2 instead of authorized_keys
freenx-server uses authorized_keys2 instead of authorized_keys
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 09:51 EDT by Andy Wang
Modified: 2012-06-25 20:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:46:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Wang 2012-06-11 09:51:17 EDT
Description of problem:
freenx-serve ruses authorized_keys2 file:
$ rpm -q freenx-server -l | grep aut
/var/lib/nxserver/home/.ssh/authorized_keys2
/var/lib/nxserver/home/.ssh/authorized_keys2.disabled

however sshd is configured to use authorized_keys by default now

Version-Release number of selected component (if applicable):

freenx-server-0.7.3-25.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to connect to freenx server
  
Actual results:
authentication failure

Expected results:
success

Additional info:
workaround is pretty simple.  symlink authorized_keys2 (or it's target /etc/nxserver/server.id_dsa.pub.key) to authorized_keys
Comment 1 Ville Skyttä 2012-06-17 06:48:25 EDT
Thanks for the report; I'm going to do a complete migration on package upgrade instead of using a symlink - it doesn't seem likely to me that authorized_keys2 support is coming back, and authorized_keys has been supported since forever.
Comment 2 Fedora Update System 2012-06-17 07:16:37 EDT
freenx-server-0.7.3-27.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freenx-server-0.7.3-27.fc17
Comment 3 Fedora Update System 2012-06-17 18:27:00 EDT
Package freenx-server-0.7.3-27.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freenx-server-0.7.3-27.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9595/freenx-server-0.7.3-27.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-06-25 20:46:42 EDT
freenx-server-0.7.3-27.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.