Bug 830886 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'write' accesses on the directory /home/tneuber/.nv/GLCache/ec6f932fae7d95e478bbdf2897444f22.
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'wr...
Status: CLOSED DUPLICATE of bug 830885
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5c5249d06f1965ac51420d52c17...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 11:02 EDT by Thomas Neuber
Modified: 2012-06-11 11:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 11:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Neuber 2012-06-11 11:02:29 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Mo 11 Jun 2012 17:02:14 CEST

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'write' accesses on the directory /home/tneuber/.nv/GLCache/ec6f932fae7d95e478bbdf2897444f22.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If sie denken, dass gst-plugin-scanner standardmässig erlaubt sein sollte, write Zugriff auf ec6f932fae7d95e478bbdf2897444f22 directory zu erhalten.
:Then sie sollten dies als Fehler melden.
:Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
:Do
:zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/tneuber/.nv/GLCache/ec6f932fae7d95e478bbdf28
:                              97444f22 [ dir ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           gstreamer-0.10.36-1.fc17.x86_64
:                              gstreamer-0.10.36-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon
:                              May 21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mo 11 Jun 2012 16:59:50 CEST
:Last Seen                     Mo 11 Jun 2012 16:59:50 CEST
:Local ID                      a2bfd780-fe6b-41b1-8810-7bf969bda4ad
:
:Raw Audit Messages
:type=AVC msg=audit(1339426790.555:103): avc:  denied  { write } for  pid=2778 comm="gst-plugin-scan" name="ec6f932fae7d95e478bbdf2897444f22" dev="dm-9" ino=3152459 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1339426790.555:103): arch=x86_64 syscall=unlink success=no exit=EISDIR a0=7fff9444b830 a1=0 a2=13 a3=7fff9444b570 items=0 ppid=2777 pid=2778 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=gst-plugin-scan exe=/usr/libexec/gstreamer-0.10/gst-plugin-scanner subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gst-plugin-scan,thumb_t,user_home_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-11 11:31:37 EDT

*** This bug has been marked as a duplicate of bug 830885 ***

Note You need to log in before you can comment on or make changes to this bug.