Bug 830894 - totem doesn't recognize webm length
totem doesn't recognize webm length
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gstreamer1 (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 11:15 EDT by Vladimir Benes
Modified: 2014-06-18 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: totem-3.6.3-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:31:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample screen cast from gnome shell (1.62 MB, video/webm)
2012-06-11 11:18 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-06-11 11:15:44 EDT
Description of problem:
when I play webm file totem says it's 6 secs long but when it comes to 5 or so it prolongs to 8 and so on and on

Version-Release number of selected component (if applicable):
totem-3.4.2-1

How reproducible:
100%

Steps to Reproduce:
1.grab attached webm file (from screencast function)
2.play it in totem

  
Actual results:
you cannot see it's length

Expected results:
you should see it's length

Additional info:
Comment 1 Vladimir Benes 2012-06-11 11:18:43 EDT
Created attachment 590969 [details]
sample screen cast from gnome shell
Comment 2 Bastien Nocera 2012-10-26 02:46:37 EDT
Works for me in Fedora 18 with Totem 3.6.
Comment 3 Vladimir Benes 2012-10-26 03:29:32 EDT
(In reply to comment #2)
> Works for me in Fedora 18 with Totem 3.6.

for me not.. try to record screencast and then play it.. I still see 0:05/0:00 or similar
Comment 4 Bastien Nocera 2012-10-26 03:35:23 EDT
I see that it's 2 seconds long in Totem, and:
$ gst-discoverer-1.0 trash:///Screencast%20from%2006-11-2012%2003:57:08%20PM.webm 
Analyzing trash:///Screencast%20from%2006-11-2012%2003:57:08%20PM.webm
Done discovering trash:///Screencast%20from%2006-11-2012%2003:57:08%20PM.webm

Topology:
  container: WebM
    video: VP8

Properties:
  Duration: 0:00:01.874000000
  Seekable: yes
  Tags: 
      CODEC de vídeo: VP8 video
      formato do contêiner: Matroska

So all is fine from my side. Reassigning to GStreamer if there's something else there.
Comment 7 Matthias Clasen 2012-11-20 09:58:10 EST
Fixed upstream after 3.6.2 
http://git.gnome.org/browse/gnome-shell/commit/?h=gnome-3-6&id=a2b8b969bd15c73e7f6f398138dbf7a8375f5aef

we will pick the fix up with an eventual 3.6.3 release
Comment 8 Vera Budikova 2013-12-13 08:22:43 EST
Verification:
1. Make a screencast by pressing Ctrl+Shift+Alt+R.
2. Play recorded webm file in Totem - totem-3.8.2-1.el7.x86_64
3. Check if time and duration of created webm file are shown in Totem correctly.

Actual results:
Time and duration are shown in Totem correctly.
Comment 9 Ludek Smid 2014-06-13 05:31:19 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.