Bug 830903 - Create a basic HTML file with a list of clickable links so that the GSA can crawl the URL's on RHN package information
Create a basic HTML file with a list of clickable links so that the GSA can c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
MR41 (AMS)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Paterczyk
David Spalding
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 11:36 EDT by Nicky
Modified: 2015-01-19 19:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 16:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicky 2012-06-11 11:36:18 EDT
Description of problem & request:
There is currently no list from which you can browse RHN package information at the moment.  Need to create a basic HTML file with a list of clickable links so that the GSA can crawl the URL's. Post Phoenix release, accessing package information can be accomplished only by a proprietary search process.  We suspect this will be the first thing that customers complain about after RHN
Phoenix goes to production.


Steps to Reproduce:
1.  see the catalogue of package information available at:  https://rhn.redhat.com/rhn/channels/software/Search.do  
  
Actual results: 
There is currently no list from which you can browse. You can only
access package information by a proprietary search process.

Expected results:
need a basic HTML file with a list of clickable links. If there's a lost of links that might need to be split among a few pages (with links between them).  Doesn't have to be pretty since only the GSA will use it to capture links to crawl.

Additional info:
Contact Mike Amburn for further details
Comment 1 Nicky 2012-06-11 14:51:03 EDT
US21450 added to AMS backlog.

(Note:  Mike created the following bugs which will reformat the titles so that the search is more effective.  I'm listing them in here as there is a connection between this BZ & those)

Update package screen titles:
https://bugzilla.redhat.com/show_bug.cgi?id=830921

Update channel screen titles:
https://bugzilla.redhat.com/show_bug.cgi?id=830924

Update channel index screen titles:
https://bugzilla.redhat.com/show_bug.cgi?id=830928

Update download index screen titles:
https://bugzilla.redhat.com/show_bug.cgi?id=830929

Update relevant errata screen title: *
https://bugzilla.redhat.com/show_bug.cgi?id=830930

* lowest priority
Comment 2 Marek Paterczyk 2012-07-03 12:44:11 EDT
Deployed on am-rhn1: https://am-rhn1.devlab.phx1.redhat.com/rhn/gsa/PackageList.do
Comment 3 David Spalding 2012-07-04 12:50:00 EDT
Page lists package OK. Is available to an entitled user (e.g. rhn-it-dspaldin) and
a new, un-entitled user (e.g. dspaldin0704a). Is not available to an anonymous 
user, not logged in. 

Login via UGC is req'd. 

GSA service does not seem to be working in the am-rhn1 environment, so I couldn't
evaluate the search results and applicability. This bug doesn't elucidate that,
but it would be nice to see the end user experience.
Comment 4 David Spalding 2012-07-04 12:54:29 EDT
US 21450 in AMS sprint MR41Sprint2. 

https://rally1.rallydev.com/#/624643017ud/detail/userstory/6691784346
Comment 5 Nicky 2012-07-09 10:54:47 EDT
Sent Bartek this information.
Comment 6 David Spalding 2012-08-08 23:36:47 EDT
Tests good in Stage:

https://rhn.code.stage.redhat.com/rhn/gsa/PackageList.do
Comment 7 David Spalding 2012-08-15 16:40:43 EDT
MR41 release pushed to Production 14 August 2012.
Comment 8 David Spalding 2012-08-29 12:40:01 EDT
Retested in QA for R12 UAT.
Comment 9 David Spalding 2012-09-14 10:51:52 EDT
Relevant test cases:

https://tcms.engineering.redhat.com/run/45604/

Note You need to log in before you can comment on or make changes to this bug.