Bug 830907 - [RFE] support arbitrary guest resolution
[RFE] support arbitrary guest resolution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.1.0
Assigned To: Alon Levy
Desktop QE
: FutureFeature
: 754106 (view as bug list)
Depends On:
Blocks: 856305
  Show dependency treegraph
 
Reported: 2012-06-11 11:47 EDT by Marc-Andre Lureau
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:16:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2012-06-11 11:47:56 EDT
When resizing a spice client window, we adjust the Windows display resolution to do a best match, to avoid black-borders or scaling. The current driver supports only a limited set of resolutions.

By adding arbitrary resolution, we can adjust guest display to fit exactly to the client window, for any size.
Comment 1 Marc-Andre Lureau 2012-06-11 11:50:04 EDT
The patches are already merged in upstream.
Comment 4 Alon Levy 2012-10-17 13:38:46 EDT
*** Bug 754106 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2012-12-04 13:16:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1503.html

Note You need to log in before you can comment on or make changes to this bug.