Bug 83092 - Printer Configuration fails to detect Windows XP printer
Printer Configuration fails to detect Windows XP printer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-30 00:40 EST by Bill Glover
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 11:15:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Glover 2003-01-30 00:40:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Using GUI Printer Config, Windows XP printer share does not show or connect.

Windows XP PC on local network, sharing HP 870cse printer. Win98SE PC sharing
HP3820 on same network.

phoebe 0.93 with up2date updates as of 1-29-03
redhat-config-printer-0.6.37-1   redhat-config-printer-gui-0.6.37-1

Tried to install these updates
redhat-config-printer-0.6.42-1.i386.rpm
redhat-config-printer-gui-0.6.42-1.i368.rpm

would not install even with rpm -Uvh --nodeps (filename)

Version-Release number of selected component (if applicable):
phoebe 0.93 with up2date updates as of 1-29-03
redhat-config-printer-0.6.37-1   
redhat-config-printer-gui-0.6.37-1


How reproducible:
Always

Steps to Reproduce:
1. open Printer Config GUI.
2. select "new"
3. Add new queue > forward
4. Fill in name and description
5. Select "Networked Windows (SMB)
6. Windows XP printer share does not show.
7. Manually trying to enter data does not work

Actual Results:  Cannot connect to Windows XP with HP870cse printer.
Win98SE with HP 3820 printer on same net connects and works OK.

Expected Results:  Windows XP printer share should show in the "queue type"
dialog box like the Win98SE printer does. Proceeding .. by giving hostname and
user info still does not connect to printer. Tried various combination of
user/passwd. Workgroup is "fishes". 

Additional info:

Printer Configuration detects and handles a Win98SE HP3820 on the same network.
Win98SE machines detects and works properly with Windows XP HP870cse printer.

Docs and HELP file gives no clue what is wrong.

smb file shares with same Windows XP box work fine.
Comment 1 Tim Waugh 2003-01-30 04:21:51 EST
What exactly are the error messages you get when trying to upgrade to the newest
redhat-config-printer-* packages?
Comment 2 Bill Glover 2003-01-30 10:31:19 EST
error was ... segment fault

After the intitial update try, segement fault did not show again.
Second try nothing, rpm just sat there for 10 minutes, no cpu cycles being used.

Next I pulled the originals out of the system and tried again. Still nothing.

In both trys after the first one, the rpm installer just locked up, process
had to be killed to stop it.

Only took a few tries at updating, then I quit trying to update config-printer
and filed a report. Need more tests. let me know.

bill
Comment 3 Tim Waugh 2003-01-30 10:33:36 EST
rm -f /var/lib/rpm/__db*

..and try updating again.
Comment 4 Bill Glover 2003-01-30 10:49:47 EST
ran commands

rm -f /var/lib/rpm/__db*
rpm -Uvh redhat-config-printer-0.6.42-1.i386.rpm

Segementation fault. same as before.

bill
Comment 5 Tim Waugh 2003-01-30 10:58:34 EST
Please report that as a separate bug against the 'rpm' component.

Meanwhile, can you try this?:

rpm2cpio redhat-config-printer-0.6.42-1.i386.rpm | (cd /; cpio -idv)
rpm2cpio redhat-config-printer-gui-0.6.42-1.i386.rpm | (cd /; cpio -idv)

(It unpacks the files into the right places without updating the RPM database.)
Comment 6 Bill Glover 2003-01-30 11:20:35 EST
rpm2cpio redhat-config-printer-0.6.42-1.i386.rpm | (cd /; cpio -idv)

produces a whole lot of string of this .... different files but all the same
./etc/alchemist/namespace/printconf
cpio: ./etc/alchemist/namespace/printconf/local.adl not created: newer or same
age version exists
./etc/alchemist/namespace/printconf/local.adl
cpio: ./etc/alchemist/namespace/printconf/rpm.adl not created: newer or same age
version exists
./etc/alchemist/namespace/printconf/rpm.adl

then I ran ...
[root@localhost printer]# rpm -qa | grep printer
redhat-config-printer-gui-0.6.37-1
redhat-switch-printer-0.5.15-1
redhat-switch-printer-gnome-0.5.15-1
redhat-config-printer-0.6.37-1

rpm database hosed??? what next??? I will just leave things alone.
Comment 7 Tim Waugh 2003-01-30 11:24:32 EST
Did you do redhat-config-printer-gui-0.6.42-1.i386.rpm as well?

Did you try printing?

If you just leave everything alone I can't find out if the printing problem is
fixed.

(Since this is just a beta, you could consider re-installing in order to get the
RPM database back to a pristine state and help me with the printing problem.)
Comment 8 Bill Glover 2003-01-30 11:32:22 EST
Didn't mean to imply not willing to help more. Just didn't want to change anything 
so we could try and track this one down.

Yes tried both. results similar. no error messages and operations did complete

back to original problem. network printer on WondowsXP box is still no-show in 
"queue type" dialog when selecting "networked windows (SMB)". Same as original
bug report states.

Win98SE box is fine in same dialog.

bill
Comment 9 Tim Waugh 2003-01-30 11:37:09 EST
Okay, it's a different problem than any of the ones fixed since Phoebe2 then. 
What's the name and IP address of the XP box, and what do these commands say?:

nmblookup '*'
nmblookup -A {ip address}
smbclient -L {ip address}
Comment 10 Bill Glover 2003-01-30 11:46:53 EST
nmblookup '*'
querying * on 192.168.1.255
192.168.1.101 *<00>
192.168.1.104 *<00>

nmblookup -A {ip address}
Looking up status of 0.0.0.0
        LOCALHOST       <00> -         B <ACTIVE>
        LOCALHOST       <03> -         B <ACTIVE>
        LOCALHOST       <20> -         B <ACTIVE>
        FISHES # MYGROU <00> - <GROUP> B <ACTIVE>
        FISHES # MYGROU <1e> - <GROUP> B <ACTIVE>
 
Looking up status of 0.0.0.0
        LOCALHOST       <00> -         B <ACTIVE>
        LOCALHOST       <03> -         B <ACTIVE>
        LOCALHOST       <20> -         B <ACTIVE>
        FISHES # MYGROU <00> - <GROUP> B <ACTIVE>
        FISHES # MYGROU <1e> - <GROUP> B <ACTIVE>

smbclient -L {ip address}
added interface ip=192.168.1.101 bcast=192.168.1.255 nmask=255.255.255.0
Connection to {ip failed


Comment 11 Bill Glover 2003-01-30 11:48:52 EST
DHCP network.

Windows XP box hostname is "Blacktip". 
Win98SE box name is "minnow". 
Workgroup is "fishes"
Comment 12 Tim Waugh 2003-01-30 11:50:28 EST
Fill in the IP address of the XP box instead of '{ip address}'.  Like nmblookup
-A 192.168.1.104 (whichever IP address blacktip is).
Comment 13 Bill Glover 2003-01-30 12:17:11 EST
ooops ... trying to do too many things at once

Blacktip is IP 192.168.1.100

 nmblookup "*"
querying * on 192.168.1.255
192.168.1.101 *<00>
192.168.1.104 *<00>


 nmblookup -A 192.168.1.100
Looking up status of 192.168.1.100
        BLACKTIP        <00> -         M <ACTIVE>
        FISHES          <00> - <GROUP> M <ACTIVE>
        BLACKTIP        <20> -         M <ACTIVE>
        FISHES          <1e> - <GROUP> M <ACTIVE>
        FISHES          <1d> -         M <ACTIVE>
        ..__MSBROWSE__. <01> - <GROUP> M <ACTIVE>

 smbclient -L 192.168.1.100
added interface ip=192.168.1.101 bcast=192.168.1.255 nmask=255.255.255.0
session request to 192.168.1.100 failed (Called name not present)
session request to 192 failed (Called name not present)
Password:
Domain=[FISHES] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
 
        Sharename      Type      Comment
        ---------      ----      -------
        Scratch (E)    Disk
        CD Drive (F)   Disk
        IPC$           IPC       Remote IPC
        print$         Disk      Printer Drivers
        Documents      Disk
        downloads      Disk
        Music          Disk
        Printer2       Printer   Print to this device to send a fax.
        Printer        Printer   Print to this device to send a photo quality fax.
        870cse         Printer   HP Deskjet 870cse
 
        Server               Comment
        ---------            -------
        BLACKTIP             Blacktip
 
        Workgroup            Master
        ---------            -------
        FISHES               BLACKTIP

typed in root passwd for blacktip
 
bill

Comment 14 Tim Waugh 2003-01-30 12:21:17 EST
So blacktip doesn't respond to broadcast queries, so yes you'll have to tell the
config tool the details using the 'specify' dialog; but I see you tried that,
and that also failed.  So..

Please do this, and tell me what it says:

nmblookup -S blacktip
Comment 15 Bill Glover 2003-01-30 12:30:49 EST
affirmatuve on inputting data manually.

 nmblookup -S blacktip
querying blacktip on 192.168.1.255
192.168.1.100 blacktip<00>
Looking up status of 192.168.1.100
        BLACKTIP        <00> -         M <ACTIVE>
        FISHES          <00> - <GROUP> M <ACTIVE>
        BLACKTIP        <20> -         M <ACTIVE>
        FISHES          <1e> - <GROUP> M <ACTIVE>
        FISHES          <1d> -         M <ACTIVE>
        ..__MSBROWSE__. <01> - <GROUP> M <ACTIVE>

It appears MS is making Windows XP shares working with samba as difficult as
possible.

bill
Comment 16 Tim Waugh 2003-01-30 12:35:28 EST
Which is the printer you're trying to use, and what type of authentication does
it need (do you need a password? a user name?).
Comment 17 Bill Glover 2003-01-30 13:02:53 EST
        870cse         Printer   HP Deskjet 870cse
 
this is the only real printer, the others are services for fax printing using
the 870cse.

the printer is set as just a share. There is no authenication required. This is
XP Home edition.

I tried all the Blacktip account names including "guest" to try and manually log
on to the 
printer. None worked.

In nautilus the fishes workgroup comes up when using smb:///. click on
workgroup, Blacktip shows, I give owner and owner password and all shares are
rw. so Blacktip file shares work OK.

bill
Comment 18 Tim Waugh 2003-01-30 13:07:24 EST
Please try this:

smbclient //blacktip/870cse -N -P -C quit && echo success

What happens? (If that works, then I'd like to know exactly what goes wrong when
you use the 'specify' dialog in the printer config tool).
Comment 19 Bill Glover 2003-01-30 13:21:41 EST
smbclient //blacktip/870cse -N -P -C quit && echo success

This does not work ... 
//blacktip/870cse: invalid option -- C

removing the -- C
 smbclient //blacktip/870cse -N -P quit && echo success
added interface ip=192.168.1.101 bcast=192.168.1.255 nmask=255.255.255.0
Got a positive name query response from 192.168.1.100 ( 192.168.1.100 )
Domain=[FISHES] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
smb: \>
smb: \>q
success.

small c is I think what you wanted???
smbclient //blacktip/870cse -N -P -c quit && echo success
added interface ip=192.168.1.101 bcast=192.168.1.255 nmask=255.255.255.0
Got a positive name query response from 192.168.1.100 ( 192.168.1.100 )
Domain=[FISHES] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
success

I will do it again ... here goes ... all OK, but no Blacktip printer shows,
Win98 shows, 
LOCALHOST shows (no local printer).
When I use the manual entry "specify" I put in all the data, click OK and
nothing happens.
Only option is to put in the data again. Nothing good or bad seems to happen.
Just repeats.

bill

Comment 20 Tim Waugh 2003-01-30 13:50:28 EST
Oops, yes, small c is what I meant.  Thanks.

When you put in 'all the data', which exact fields do you put things in, and
what do you put in them?
Comment 21 Bill Glover 2003-01-30 14:28:49 EST
First I went and tried to specify the host/printer. still no go.

then I tried something else ... rebooted the phoebe beta system.

Get to the "queue type" dialog no Blacktip host shows.

Enter first test for data ...
Workgroup: fishes
Server: Blacktip
Share 870cse
User Name: guest
Password:<none>

This time Blacktip 870cse share connects after entering the same data as before.
The re-boot is the difference. So something got straightened out when re-booted?
Now it all seems to be working. Test page prints.

Before re-boot, the GUI looped on all names and guest. Only a cancel, which
killed the process
got you out of it.

so the fix is ... the latest config-printer manualy loaded and re-boot after
load. Still need to be able to rpm load config-printer. I did not change Windows
XP while testing. I filed a bug on the segment fault.

Tim, you might want to add a doc paragraph about Windows XP needing manual
specify??? If this in fact proves to be the case with FCS. Otherwise users may
dead end at no show of Windows XP printer. You are targeted the windows user
after all.

I am happy ...

bill

Comment 22 Tim Waugh 2003-01-30 17:24:03 EST
It's mysterious that you had to reboot.

I just re-read some of your earlier comments and I noticed the fact that
nautilus (smb:///) can browse to this machine okay.  So perhaps the fact that it
doesn't show up in the browse list in redhat-config-printer is easily fixable.

Can you please try out these commands for me?:

1. nmblookup -M -

   This will give two lines of output; in the second line, take the IP address
it gives and put it in place of 192.168.1.1 here:

2. nmblookup -R -U 192.168.1.1 '*'

   And here:

3. nmblookup -R -U 192.168.1.1 fishes

Thanks.
Comment 23 Bill Glover 2003-01-30 22:46:05 EST
Odd that re-boot worked, but something must have got tangled up when trying to
install config-printer.

My network looks like this ... 3 computers, 
1. phoebe, 
2. WinXP
3. WIN98
Linksys router => cable modem. Router is Linksys DHCP NAT router for LAN.

WinXp machine ...
WINs is disabled. Netbios setting is "default" ie ... 
"Use netbios settings from DHCP server. If static IP addresses are used or the
DHCP server does not provide netbios setting, enable netbios over TCP/IP."
LMHosts is enabled, by default.

[root@localhost samba]# nmblookup -M -
querying __MSBROWSE__ on 192.168.1.255
192.168.1.100 __MSBROWSE__<01>

[root@localhost samba]# nmblookup -R -U 192.168.1.100 '*'
querying * on 192.168.1.100
wins_srv_died(): Could not mark WINS server 192.168.1.100 down.
Address not found in server list.
name_query failed to find name *

[root@localhost samba]# nmblookup -R -U 192.168.1.100 fishes
querying fishes on 192.168.1.100
192.168.1.100 fishes<00>

my 2 cents ...
Since there is no WINs server in this type of LAN, you might need to use an
alternate method to discover and query machines for shares.

bill
Comment 24 Tim Waugh 2003-02-02 18:10:49 EST
How about 'smbclient -I 192.168.1.100 -N -L foo'?

I think this is too hard to fix for the final release though, since it involves
re-writing quite a lot of pysmb.py.
Comment 25 Bill Glover 2003-02-20 19:42:57 EST
I just setup phoebe 0.94 and all is well with printing. Great job.

bill
Comment 26 Tim Waugh 2003-02-21 03:59:33 EST
So it works for you now?  I didn't change anything, that I recall..
Comment 27 Bill Glover 2003-02-21 10:30:05 EST
It worked fine before. 

Just thought you might want to know all is well with the new beta.

bill 
Comment 28 Tim Waugh 2003-08-29 08:56:20 EDT
What is the status of this?  Is the original problem fixed?
Comment 29 Tim Waugh 2003-11-05 09:43:15 EST
*ping*
Comment 30 Bill Glover 2003-11-05 11:13:59 EST
Bug has been fixed
Comment 31 Tim Waugh 2003-11-05 11:15:37 EST
Great, thanks.

Note You need to log in before you can comment on or make changes to this bug.