Bug 830987 - RFE: aeolus image build option --template should take a URL to match conductor "From URL" option
RFE: aeolus image build option --template should take a URL to match conducto...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
0.3.1
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Maros Zatko
Rehana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 16:32 EDT by Vinny Valdez
Modified: 2012-12-04 10:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
CloudForms Cloud Engine command line interface now contains the ability to build templates from URL. Previously the command line tool would not accept a URL for the --template option. CloudForms Cloud Engine now accepts URLs for the --template option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vinny Valdez 2012-06-11 16:32:47 EDT
Description of problem:
In the 1.0 GA version of Cloud Engine, aeolus-image build requires a local TDL file. However, the Component Outline UI in Cloud Engine has the option for both pointing to a local file, or providing a URL. 

Version-Release number of selected component (if applicable):
rubygem-aeolus-cli-0.3.1-1.el6.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. Attempt to specify a URL for --template

e.g.:
# aeolus image build --target ec2,vsphere,rhevm --template http://cf-se.gsso.redhat.com/pub/templates/WebServer.xml --environment Hybrid
Error: Cannot find specified file
  
Actual results:
Unable to point to a URL from the aeolus CLI.

Expected results:
CLI should be consistent with the UI.

Additional info:
If the katello CLI was used to export the template to /var/www/html/pub (or similar) on System Engine, it is very convenient to point to that URL directly when building the image from the aeolus CLI.
Comment 1 Maros Zatko 2012-07-27 13:05:16 EDT
in aeolus-cli master

commit e0e2238dbf599821193f8dd1eaf803ab7ac9ec1f
Author: Maros Zatko <mzatko@redhat.com>
Date:   Wed Jul 18 18:32:18 2012 +0200

    BZ830987: new VCR cassette for test of template from URL

commit 428ae202ecd7a5718fee21d423589b2f435decd2
Author: Maros Zatko <mzatko@redhat.com>
Date:   Wed Jul 18 18:31:07 2012 +0200

    BZ830987: buildcmd_spec: test for template from URL + filepath joining fix

commit 16d32b9be0d1877d2b3ab955ef6bf5141b2d0d84
Author: Maros Zatko <mzatko@redhat.com>
Date:   Wed Jul 18 18:28:41 2012 +0200

    BZ830987: build_command: template can be read from URL
Comment 4 pushpesh sharma 2012-09-27 09:33:31 EDT
[root@dhcp201-113 ~]# aeolus image build --target ec2,vsphere,rhevm --template http://10.65.201.113/RHEL6.2_Template.xml --environment default
Image                                    Build                                    Target Image                             Target      Status       
------------------------------------     ------------------------------------     ------------------------------------     -------     --------     
bde1d528-08a8-11e2-85af-2c27d73906e5     1e4699dc-f8df-4953-88b0-a86738f2a59f     263c0863-f9e0-41c7-add3-7aa20d638f31     ec2         BUILDING     
bde1d528-08a8-11e2-85af-2c27d73906e5     1e4699dc-f8df-4953-88b0-a86738f2a59f     0612f97a-a260-4451-9376-fc399b3aa36e     vsphere     BUILDING     
bde1d528-08a8-11e2-85af-2c27d73906e5     1e4699dc-f8df-4953-88b0-a86738f2a59f     980692da-a129-462a-aa4b-a0c59268a7c5     rhevm       BUILDING  

Verified on:

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
Comment 6 errata-xmlrpc 2012-12-04 10:10:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.