Bug 830993 - Unable to set persistent minor number above 255
Unable to set persistent minor number above 255
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.8
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 17:03 EDT by David Wood
Modified: 2013-09-30 20:27 EDT (History)
13 users (show)

See Also:
Fixed In Version: lvm2-2.02.88-11.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 20:27:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Wood 2012-06-11 17:03:11 EDT
Description of problem:
Unable to set the minor number of an LV to someting above 255

Version-Release number of selected component (if applicable):
This happens in RHEL 5.7, 5.8, 6.2, and 6.3

How reproducible:
100%

Steps to Reproduce:
1. lvchange --persistent y --major 253 --minor 265 ANY_LV

  
Actual results:
Minor number outside range 0-255
  Invalid argument for --minor: 265
  Error during parsing of command line.

Expected results:
The persistent minor number should be set to 265

Additional info:
Comment 1 Peter Rajnoha 2012-06-12 07:44:03 EDT
Amazing nobody did hit this before! But yes, it's a bug (we still need to check for the kernel and metadata version though).
Comment 2 Peter Rajnoha 2012-08-06 12:13:54 EDT
New limit set to follow the kernel >= 2.6: 12 and 20 bits for major and minor number (4095 and 1048575).

http://git.fedorahosted.org/cgit/lvm2.git/commit/?id=6e55201144be3bcf82b6aafe7e9f7430318719d0
Comment 7 RHEL Product and Program Management 2013-04-04 08:29:36 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 Nenad Peric 2013-05-16 05:49:56 EDT
Tested and setting up a high-numbered minor works with lvm2-2.02.88-11.el5


(04:46:51) [root@r5-node02:~]$ lvchange --persistent y --major 252 --minor 300 test/majnor
Logical volume majnor will be deactivated temporarily. Continue? [y/n]: y
  Logical volume "majnor" changed
(04:47:16) [root@r5-node02:~]$ dmsetup ls
VolGroup00-LogVol01	(252, 1)
VolGroup00-LogVol00	(252, 0)
test-majnor	(252, 300)
Comment 11 errata-xmlrpc 2013-09-30 20:27:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1352.html

Note You need to log in before you can comment on or make changes to this bug.