This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 831019 - unable to pair with simple bluetooth serial module
unable to pair with simple bluetooth serial module
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 21:13 EDT by Tom Horsley
Modified: 2013-07-31 16:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 16:43:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2012-06-11 21:13:08 EDT
Description of problem:

I just got my clean install of fedora 17 running as my default boot and I
was trying to pair with a bluetooth device that supports RFCOMM, and the
bluetooth-wizard constantly failed when I tried to do the pairing.

So, I decided to try an end-run around the wizard and rsynced the
fedora 16 /var/lib/bluetooth directory to my fedora 17 /var/lib/bluetooth.

One reboot later, and I have no problem creating the rfcomm0 device
and opening it and talking serial, so there is apparently no problem
talking bluetooth, only a problem doing the initial pairing.

Where the bug actually is, I have no idea, but since bluetooth-wizard
is the user facing side where the bug is reported (constantly says
"failed to connect"), I figured I'd start out reporting the bug against
that.

Version-Release number of selected component (if applicable):
gnome-bluetooth-3.4.0-2.fc17.x86_64

How reproducible:

Tried several times to pair the device both as ordinary user and as root,
and it always failed to pair with no real useful information printed.
Sometimes the wizard would briefly flash some message like "type 314159"
into the device, but never long enough to actually even read the number,
then it would report failure.

Steps to Reproduce:
1.run bluetooth wizard
2.fail to pair device
3.
  
Actual results:
constant failure

Expected results:
paired device

Additional info:

Here's a grep for the device ID in the /var/lib/bluetooth/00:1C:F0:6C:4A:8E/
directory:

classes:00:12:01:07:00:65 0x000000
did:00:12:01:07:00:65 FFFF 0000 0000 0000
features:00:12:01:07:00:65 FFFF8FFE9BFF5983
lastseen:00:12:01:07:00:65 2012-06-08 00:22:02 GMT
lastused:00:12:01:07:00:65 2012-06-12 00:57:10 GMT
linkkeys:00:12:01:07:00:65 930C35A524A1016899710E973CEF607C 0 4
manufacturers:00:12:01:07:00:65 10 4 5941
names:00:12:01:07:00:65 H-C-2010-06-01
profiles:00:12:01:07:00:65 00001101-0000-1000-8000-00805f9b34fb
sdp:00:12:01:07:00:65#00010000 35390900000A000100000900013503191101090004350C350319010035051900030801090006350909656E09006A09010009010025054465762042
trusts:00:12:01:07:00:65 [all]
types:00:12:01:07:00:65 01

The device is one of these:

http://iteadstudio.com/product/arduino-bluetooth-shield-upgrade-to-v2-2/
Comment 1 Tom Horsley 2012-06-11 21:16:05 EDT
I'm talking bluetooth via a D-Link bluetooth dongle which lsusb shows
as:

Bus 002 Device 006: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Comment 2 Fedora End Of Life 2013-07-03 16:35:05 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2013-07-31 16:43:19 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.