Bug 831030 - Window size not saved -- starts maximized
Window size not saved -- starts maximized
Status: CLOSED DUPLICATE of bug 821589
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 23:15 EDT by Jeff Sheltren
Modified: 2012-08-01 10:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 10:24:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sheltren 2012-06-11 23:15:57 EDT
Description of problem:
When I resize a window to make it "large" but not maximized on the full screen (e.g. takes up all vertical space, and ~70% or more of horizontal space), that window size is not used the next time an application is opened; instead, the program starts with a maximized window.

Version-Release number of selected component (if applicable):
gnome-shell-3.4.1-5.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open a new application window (I can reproduce with at least: Chromium, Firefox, Gnome "Files" application).
2. Resize window to take up all vertical space on the screen and most of the horizontal space (roughly 1223 x 741 on my laptop screen with a total resolution of 1366 x 768)
3. Close application by clicking on the 'X' in the corner.
  
Actual results:
When application is opened the next time, the window opens up maximized.

Expected results:
Window should open up at the last-used size.

Additional info:
When windows are sized smaller (e.g. 1223 x 578), closed, and then opened again, they open up to the last-used size. I can consistently reproduce this bug on my laptop but cannot reproduce it on my desktop (1920 x 1080 resolution) -- both running F17 and latest updates.
Comment 1 Jeff Sheltren 2012-06-27 23:53:43 EDT
Any ideas on this? It's quite annoying to have to resize windows all the time.
Comment 2 Takehiko Abe 2012-07-31 21:55:59 EDT
I am afraid that this is actually a "feature" rather than a bug.

http://git.gnome.org/browse/mutter/commit/?id=f2f500836ef217bfbd7bbf5ad54c9248cbdb7925

: Windows that start up in a size that is almost as big as the workarea
: create extra work for the user (resizing or maximizing) so save the
: user's time by detecting such windows and automaximize them.

"save the user's time"!

I hope there will be an option to turn this off.
Comment 3 Takehiko Abe 2012-07-31 22:11:46 EDT
Ah, the bug is already filed agaist mutter:

Bug 821589 - Mutter second guessing explicitly set window size, maximises instead
Comment 4 Jeff Sheltren 2012-08-01 10:24:03 EDT
Thanks, I'm marking this as a duplicate of Bug 821589 since there's more info there on the cause.

*** This bug has been marked as a duplicate of bug 821589 ***

Note You need to log in before you can comment on or make changes to this bug.