Bug 831035 - RFE: On-Demand copy trans.
RFE: On-Demand copy trans.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic, Usability (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.7
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 00:44 EDT by Carlos Munoz
Modified: 2012-09-12 19:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120705-0026)
Doc Type: Bug Fix
Doc Text:
Cause Zanata was only able to run the translation copy mechanism on newly pushed documents and used a very conservative algorithm to find matches (same document name, same translation context and content). Consequence Project Maintainers were only able to invoke the translation copy functionality at the same time they were pushing documents. Also, this meant that maintainers were not able to reuse some potentially reusable translations (such as those that belong to documents that moved to a different directory). Change Implemented an option for Project Maintainers to invoke a translation copy from the GUI (project version page). Result Project maintainers are now able to invoke a translation copy at any time, with some customization options. Since the process is now applicable to already existing documents, Zanata makes sure that only a single Copy Trans is running at any given time for a project version, and will prevent any user from starting another copy trans if another is in progress. It will also show progress information for any ongoing translation copies for a project version. Also, project maintainers are now able to slightly customize the sensitivity of copy trans. The user can select which actions to take when a translation matches, but its document name or its context doesn't, entirely disregarding the translation, reusing it but marking it fuzzy, or ignoring the mismatch and reusing it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2012-06-12 00:44:33 EDT
Add on-demand copy trans for a project iteration. Only non-approved translations will be modified by this functionality.
Comment 1 Carlos Munoz 2012-06-12 03:04:12 EDT
Initial implementation.
See:
https://github.com/zanata/zanata/commit/f2d24015c532b1ef5af13f70a0db2cee68c56755
Comment 2 Carlos Munoz 2012-06-27 02:35:12 EDT
Added copy trans options and progress feedback for project maintainers. The project version page will show if there is currently a copy trans running for the select version, and will also show a progress bar, number of documents processed, estimated time remaining, and the user that started the copy trans.

Additionally, the user will be able to cancel the copy trans, and the system will now enforce that only a single copy trans should be running at any given time for a project version.
Comment 4 Carlos Munoz 2012-06-28 20:38:49 EDT
Testing Notes:
- Only a single copy trans should be available to run at any time for a project iteration. Zanata should prevent two copy trans from running simultaneously for the same version. 
- Multiple users should be able to see the progress of an ongoing copy trans. As soon as the copy trans finishes (and if the user has the appropriate permissions), they should see a button to start another copy trans.
Comment 5 Carlos Munoz 2012-06-28 20:38:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Zanata was only able to run the translation copy mechanism on newly pushed documents and used a very conservative algorithm to find matches (same document name, same translation context and content).

Consequence
Project Maintainers were only able to invoke the translation copy functionality at the same time they were pushing documents. Also, this meant that maintainers were not able to reuse some potentially reusable translations (such as those that belong to documents that moved to a different directory).

Change
Implemented an option for Project Maintainers to invoke a translation copy from the GUI (project version page).

Result
Project maintainers are now able to invoke a translation copy at any time, with some customization options. Since the process is now applicable to already existing documents, Zanata makes sure that only a single Copy Trans is running at any given time for a project version, and will prevent any user from starting another copy trans if another is in progress. It will also show progress information for any ongoing translation copies for a project version.

Also, project maintainers are now able to slightly customize the sensitivity of copy trans. The user can select which actions to take when a translation matches, but its document name or its context doesn't, entirely disregarding the translation, reusing it but marking it fuzzy, or ignoring the mismatch and reusing it.
Comment 6 Ding-Yi Chen 2012-07-04 21:39:44 EDT
VERIFIED with Zanata version 1.7-SNAPSHOT (20120705-0026)

Note You need to log in before you can comment on or make changes to this bug.