Bug 831043 - [abrt] yum-3.4.3-27.fc18: yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot access repository dir /var/tmp/yum-vadik-U2Y4uK/i386/18/rawhide
[abrt] yum-3.4.3-27.fc18: yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot a...
Status: CLOSED DUPLICATE of bug 830523
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:0562213c911e87dfb74cf878f11...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 01:01 EDT by Vadim Rutkovsky
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-12 02:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2012-06-12 01:01:33 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available yelp
comment:        Crashes on bash completion of any package
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.5.0-0.rc2.git0.1.fc18.i686
time:           Tue 12 Jun 2012 08:00:06 AM FET
uid:            1000
username:       vadik

backtrace:
:yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot access repository dir /var/tmp/yum-vadik-U2Y4uK/i386/18/rawhide
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 88, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 82, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2676, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 777, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 300, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 125, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 81, in retrieveAllMD
:    if repo._async and repo._commonLoadRepoXML(repo):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1315, in _commonLoadRepoXML
:    local  = self.cachedir + '/repomd.xml'
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 682, in <lambda>
:    cachedir = property(lambda self: self._dirGetAttr('cachedir'))
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 665, in _dirGetAttr
:    self.dirSetup()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 644, in dirSetup
:    self._dirSetupMkdir_p(dir)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 614, in _dirSetupMkdir_p
:    raise Errors.RepoError, "Cannot access repository dir %s" % dpath
:RepoError: Cannot access repository dir /var/tmp/yum-vadik-U2Y4uK/i386/18/rawhide
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x9e81d8c>
:dpath: '/var/tmp/yum-vadik-U2Y4uK/i386/18/rawhide'

smolt_data:
:
:
:General
:=================================
:UUID: a556ad30-b307-44ff-8d66-137add9d28fa
:OS: Fedora release 18 (Rawhide)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 4389.23
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Celeron(R) CPU          900  @ 2.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 1
:CPU Speed: 2194
:System Memory: 2960
:System Swap: 5720
:Vendor: Hewlett-Packard
:System:  F.08
:Form factor: Notebook
:Kernel: 3.5.0-0.rc2.git0.1.fc18.i686
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4156:5414) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(4332:33078:4156:5414) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10537:4156:5414) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4156:5414) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:10564:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(5348:17173:4156:5384) pci, None, NETWORK, BCM4312 802.11b/g LP-PHY
:(32902:10549:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9288:4156:5414) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10553:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4156:5414) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4156:5414) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10818:4156:5414) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4156:5414) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10568:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4156:5414) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10548:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10570:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(32902:10552:4156:5414) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda6 / ext4 4096 4096 1836527 361798 343393 466944 229236 229236
:
Comment 1 Zdeněk Pavlas 2012-06-12 02:47:28 EDT

*** This bug has been marked as a duplicate of bug 830523 ***

Note You need to log in before you can comment on or make changes to this bug.