Bug 831131 - Outputs of config --remove should be the same whether default value exist or not
Outputs of config --remove should be the same whether default value exist or not
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide (Show other bugs)
6.3
Unspecified Unspecified
medium Severity urgent
: rc
: ---
Assigned To: Deon Ballard
ecs-bugs
: Documentation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-06-12 05:32 EDT by yu zheng
Modified: 2012-06-26 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2012-06-12 05:32:53 EDT
Description of problem:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/rhsm-config-cmd.html

In section 4.15.2. Using the config Command:

1.Following connection settings should be changed.
server.proxy => server.proxy_hostname
rhsm.certFrequency => rhsmcertd.certfrequency

2.Whether the value for the paramete has a default or not, the prompt info after removing the param is always "You have removed the value in section x for parameter x. The default value for x.x will now be used".

# subscription-manager config --remove=rhsmcertd.certfrequency
                                       ^^^^^^^^^^^^^^^^^^^^^^^defult value is 240
You have removed the value for section rhsmcertd and name certfrequency.
The default value for certfrequency will now be used.

# subscription-manager config --remove=server.proxy_hostname
                                       ^^^^^^^^^^^^^^^^^^^^^^^have no defult
You have removed the value for section server and name proxy_hostname.
The default value for proxy_hostname will now be used.
Comment 3 Keqin Hong 2012-06-26 01:18:19 EDT
"server.proxy" should be "server.proxy_hostname" on http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/rhsm-config-cmd.html
Comment 4 Deon Ballard 2012-06-26 10:16:16 EDT
I actually have fixed this in the version of the file for the Subscription Management Guide. Since this chapter is going away in RHEL 6.4 and getting approval for an update to the Deployment Guide would be difficult, I am closing teh Deployment Guide bug as "wontfix."

But it really is fixed in the subscription docs.

Note You need to log in before you can comment on or make changes to this bug.