Bug 831136 - kernel 3.4 and possible bug with passing PCI devices in D3
kernel 3.4 and possible bug with passing PCI devices in D3
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 05:38 EDT by Gianluca Cecchi
Modified: 2012-08-03 17:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 17:38:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.8.log when successfully run optirun command with kernel 3.3.7 (17.78 KB, text/plain)
2012-06-12 05:39 EDT, Gianluca Cecchi
no flags Details
Xorg.8.log when unsuccessfully run optirun command with kernel 3.4.0 (10.10 KB, text/plain)
2012-06-12 05:40 EDT, Gianluca Cecchi
no flags Details
dmesg output (71.84 KB, text/plain)
2012-06-12 05:42 EDT, Gianluca Cecchi
no flags Details

  None (edit)
Description Gianluca Cecchi 2012-06-12 05:38:19 EDT
Description of problem:
With latest kernel 3.4.0-1.fc17.x86_64 I'm unabel to use optirun any long

Version-Release number of selected component (if applicable):
3.4.0-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. start system with kernel 3.4.0-1.fc17.x86_64
2. configure dkms, bbswitch, bumblebee and virtualgl
3. run command "sudo optirun glxgears"
  
Actual results:
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] failed to open device

[ERROR]Aborting because fallback start is disabled.


Expected results:
X window with glxgears runnign and good performances due to using nouveau kernel module

Additional info:
Booting with kernel 3.3.7-1 it is ok.
I'm going to attach Xorg.8.log for both kernels.
Searching through forums it seems there could be a general bug in kernel 3.4 related to passing PCI devices in D3 state and that this is the one affecting me.
Comment 1 Gianluca Cecchi 2012-06-12 05:39:39 EDT
Created attachment 591152 [details]
Xorg.8.log when successfully run optirun command with kernel 3.3.7
Comment 2 Gianluca Cecchi 2012-06-12 05:40:17 EDT
Created attachment 591153 [details]
Xorg.8.log when unsuccessfully run optirun command with kernel 3.4.0
Comment 3 Gianluca Cecchi 2012-06-12 05:42:29 EDT
Created attachment 591154 [details]
dmesg output

My system is an Asus U36SD laptop with nVidia GeForce GT 520M discrete gpu.
$ lsmod|egrep “nouve|i915″
i915 472032 3
nouveau 799637 0
mxm_wmi 12823 1 nouveau
wmi 18697 3 mxm_wmi,nouveau,asus_wmi
video 18935 2 i915,nouveau
i2c_algo_bit 13257 2 i915,nouveau
drm_kms_helper 40411 2 i915,nouveau
ttm 79760 1 nouveau
drm 244591 6 ttm,i915,drm_kms_helper,nouveau
i2c_core 38028 7 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,nouveau,videodev
Comment 4 Dušan 2012-06-12 08:30:57 EDT
Same situation here.

My Hardware:

nVidia GT540M:
01:00.0 VGA compatible controller: nVidia Corporation GF106 [GeForce GT 555M SDDR3] (rev ff)

Fedora 17 32bit.

Kernel 3.3.7-1 works OK.
Comment 5 Gianluca Cecchi 2012-06-12 10:45:47 EDT
Apart from inability to use nvidia adapter for particular tasks (windows vm with remote-viewer, wine, ecc) this decreases my battery life by about 90 minutes as I'm unable to offline it ....
Comment 6 Gianluca Cecchi 2012-06-19 04:08:27 EDT
Problem still persists with kernel 3.4.2-4.fc17.x86_64 got from updates channel
Comment 7 Gianluca Cecchi 2012-06-20 19:08:41 EDT
Possible bug related:
https://bugs.freedesktop.org/show_bug.cgi?id=51157
pointing to
https://bugzilla.kernel.org/show_bug.cgi?id=43168

Gianluca
Comment 8 Gianluca Cecchi 2012-06-21 10:16:10 EDT
Or perhaps this one?
https://bugzilla.kernel.org/show_bug.cgi?id=43228

But it should be fixed in final 3.4, so I don't know...
Comment 9 Gianluca Cecchi 2012-06-22 05:55:52 EDT
Trying to debug with bumblebee guys it seems I could have a problem with kernel 3.4 referring to this kernel bug:
https://bugzilla.kernel.org/show_bug.cgi?id=43063
Comment 10 Gianluca Cecchi 2012-06-22 05:57:20 EDT
It continues also with 3.4.3-1.fc17.x86_64
Comment 11 Gianluca Cecchi 2012-07-09 05:10:02 EDT
It is the same with kernel-3.4.4-5.fc17.x86_64
Anyone looking at this? I'm available for further debug if needed..
I'm yet forced to boot in 3.3.7 kernel...
Comment 12 Josh Boyer 2012-07-09 08:47:34 EDT
(In reply to comment #11)
> It is the same with kernel-3.4.4-5.fc17.x86_64
> Anyone looking at this? I'm available for further debug if needed..
> I'm yet forced to boot in 3.3.7 kernel...

You might want to pursue this issue with the upstream kernel community.  At the moment, nobody is looking into this.
Comment 13 Gianluca Cecchi 2012-07-09 09:16:29 EDT
Already done:
https://bugzilla.kernel.org/show_bug.cgi?id=43063
Hoping that perhaps someone being at the same time both an upstream kernel and fedora kernel maintainer could have time to go deeper inside.

It seems actually that Ben Skeggs at
https://bugs.freedesktop.org/show_bug.cgi?id=51157
points to another upstream kernel bug I already posted:
https://bugzilla.kernel.org/show_bug.cgi?id=43168

But that bug should be corrected in kernel-3.4.4-5.fc17.x86_64 as for its changelog

...
* Tue Jul 03 2012 Josh Boyer <jwboyer@redhat.com>
- Allow ACPI backlight to still work if _DOS isn't present (rhbz 834910)
...

Actually in my case it doesn't seem so..
Thanks anyway
Comment 14 Gianluca Cecchi 2012-08-03 17:38:28 EDT
Finally 3.5.0-2.fc17.x86_64 is the first kernel after kernel-3.3.7-1.fc17.x86_64 where I can use my Nvidia and run command "sudo optirun glxgears" without errors.
Discrete card correctly disabled after optirun exits.

Thanks (possibly due to upstream changes in 3.5...)
Comment 15 Gianluca Cecchi 2012-08-03 17:39:39 EDT
Put closed upstream as motivation... donna if it is correct.
Feel free to change ...

Note You need to log in before you can comment on or make changes to this bug.