This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 83114 - system won't boot with nosysinfo kernel parameter
system won't boot with nosysinfo kernel parameter
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 79578 84225
  Show dependency treegraph
 
Reported: 2003-01-30 08:54 EST by Michael Young
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 06:28:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-01-30 08:54:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020921
Netscape/7.0

Description of problem:
The release notes for phoebe2 say you can turn off NPTL thread support by
booting the kernel with the nosysinfo parameter. However if you try it, the
system hangs during the boot after the "freeing unused kernel memory" line. I
can reproduce this with the -2.21, -2.25, and -2.27 kernels.
Maybe this is because some program (maybe init) needs NPTL, but if you are going
to advertise it as an option, the system should at least boot.

How reproducible:
Always

Steps to Reproduce:
1.boot with the nosysinfo parameter.
Comment 1 Matt Wilson 2003-02-14 00:35:30 EST
still present in 2.4.20-2.48

init   R
[<c010ac72>] do_IRQ [kernel] 0xa2 (0xc1925fa0))
[<c01171e0>] do_page_fault [kernel] 0x0 (0xc1925fb0))
[<c0109628>] error_code [kernel] 0x34 (0xc1925fb8))
Comment 2 Roland McGrath 2003-02-14 02:27:33 EST
The bug is that nosysinfo disables the magic page without disabling
the AT_SYSINFO auxv element that causes libc to use the magic page.
So init crashes on its first glibc system call.

I have a kernel patch that fixes nosysinfo to disable AT_SYSINFO as well,
so it boots.  That patch should get merged in Real Soon Now.
Comment 3 Arjan van de Ven 2003-02-14 04:48:05 EST
will remove nosysinfo
Comment 4 Ingo Molnar 2003-02-14 06:28:04 EST
fix is in CVS, should show up in next rawhide.

Note You need to log in before you can comment on or make changes to this bug.