Bug 831143 - ISE (or unchanged entitlements) when changing channel entitlements in the list of 500 displayed channels
ISE (or unchanged entitlements) when changing channel entitlements in the lis...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
: Patch, Triaged
Depends On:
Blocks: sat541-triage 831145
  Show dependency treegraph
 
Reported: 2012-06-12 05:53 EDT by Jiří Mikulka
Modified: 2014-10-06 09:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 831145 (view as bug list)
Environment:
Last Closed: 2013-01-22 12:06:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 293663 None None None Never

  None (edit)
Description Jiří Mikulka 2012-06-12 05:53:16 EDT
Description of problem:
In WebUI one is unable to change count of channel entitlements for an organization when 500 channels is displayed (only in this case)! It results in ISE + traceback in /var/log/tomcat6/catalina.out and channel entitlements remain unchanged.

Version-Release number of selected component (if applicable):
Satellite 5.4.1

How reproducible:
always

Steps to Reproduce:
1. in WebUI - admin tab, select some organization, then click Subscriptions, Software Channel Entitlements
2. display 500 channels per page
3. change regular/flex entitlements of some channel and click Update Organization
4. ISE (or unchanged entitlements) should appear
  
Actual results:
ISE (or unchanged entitlements) appear + traceback in /var/log/tomcat6/catalina.out:

[TP-Processor7] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
java.lang.IllegalStateException: Parameter count exceeded allowed maximum: 512
	at org.apache.tomcat.util.http.Parameters.addParam(Parameters.java:335)
	at org.apache.tomcat.util.http.Parameters.processParameters(Parameters.java:456)
	at org.apache.tomcat.util.http.Parameters.processParameters(Parameters.java:365)
	at org.apache.catalina.connector.Request.parseParameters(Request.java:2593)
	at org.apache.catalina.connector.Request.getParameter(Request.java:1064)
	at org.apache.catalina.connector.RequestFacade.getParameter(RequestFacade.java:355)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.addParameterizedMessages(EnvironmentFilter.java:112)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:105)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:736)


Expected results:
channel entitlements are set correctly

Additional info:
Comment 1 Jiří Mikulka 2012-06-20 08:36:17 EDT
*** Bug 831145 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Lestach 2012-08-15 08:33:50 EDT
This BZ is tracked against 541. The fix is present in upstream, more details in Bug 831145
Comment 7 Tomas Lestach 2013-01-14 04:30:52 EST
This issue was resolved in Satellite 5.5 within Bug 831145 and most probably won't be resolved in Satellite 5.4.

For GSS the recommended fix is to add
-Dorg.apache.tomcat.util.http.Parameters.MAX_COUNT=1024
to
JAVA_OPTS
in
/etc/tomcat[56]/tomcat[56].conf file.

E.g.
--- /etc/tomcat6/tomcat6.conf   2013-01-14 04:26:42.784348877 -0500
+++ /etc/tomcat6/tomcat6.conf   2013-01-14 04:27:07.004348794 -0500
@@ -53,6 +53,6 @@
 # put your own definitions here
 # (i.e. LD_LIBRARY_PATH for some jdbc drivers)
 
-JAVA_OPTS="$JAVA_OPTS -ea -Xms256m -Xmx256m -Djava.awt.headless=true -Dorg.xml.sax.driver=org.apache.xerces.parsers.SAXParser -XX:MaxNewSize=256 -XX:-UseConcMarkSweepGC"
+JAVA_OPTS="$JAVA_OPTS -ea -Xms256m -Xmx256m -Djava.awt.headless=true -Dorg.xml.sax.driver=org.apache.xerces.parsers.SAXParser -Dorg.apache.tomcat.util.http.Parameters.MAX_COUNT=1024 -XX:MaxNewSize=256 -XX:-UseConcMarkSweepGC"
 LD_LIBRARY_PATH=/usr/lib/oracle/10.2.0.4/client64/lib:/usr/lib/oracle/10.2.0.4/client/lib
 _HACK_AROUND_PARSEOPTIONS=1 ; . $CATALINA_HOME/bin/setenv.sh


Restart of RHN Satellite/tomcat is required.

Note You need to log in before you can comment on or make changes to this bug.