Bug 831163 - [rhevm-log-collector] - TEXT - Incorrect message for any incorrect syntax
[rhevm-log-collector] - TEXT - Incorrect message for any incorrect syntax
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Keith Robertson
Ilanit Stein
integration
:
: 832789 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 07:20 EDT by David Botzer
Modified: 2016-07-03 21:34 EDT (History)
10 users (show)

See Also:
Fixed In Version: si11
Doc Type: Bug Fix
Doc Text:
The log collector did not have the gettext library imported causing many exceptions to be bypassed and resulting in the log collector exiting ungracefully. Now, the log collector imports the gettext library and exits gracefully.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:19:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2012-06-12 07:20:47 EDT
Description of problem:
I get the following ERROR message, for any incorrect command syntax: user,password etc..
ERROR: _get_hypervisors_from_api: global name '_' is not defined

Version-Release number of selected component (if applicable):
rhevm 3.1, si4

How reproducible:
always

Steps to Reproduce:
1.Run LC command with incorrect password
rhevm-log-collector -u admin@internal -p 12xx -d DCsi4_3-0 list
 

Actual results:
incorrect message
ERROR: _get_hypervisors_from_api: global name '_' is not defined

Expected results:
Should display a correct for and different message for any mistake
user - incorrect user name
psw  - incorrect password
host - cannot find host/ip

Additional info:
I get the same message when trying to connect with LC while jboss is stopped
Comment 1 David Botzer 2012-06-12 09:43:28 EDT
In the same case when jbossas is down there are two possible scenarios here:
1) JBoss is UP and there are no hypervisors.
2) JBoss is down and the tool can't figure out how many hypervisors there are. 

Just need to determine a proper general message
Comment 2 Keith Robertson 2012-06-28 22:18:50 EDT
*** Bug 832789 has been marked as a duplicate of this bug. ***
Comment 3 Keith Robertson 2012-06-28 22:24:17 EDT
Upstream fix is here:  http://gerrit.ovirt.org/5785
Comment 5 Ilanit Stein 2012-08-30 03:44:31 EDT
Tested on SI15.1 and found same error still exist:

[root@lilach-rhel ~]# rhevm-log-collector -u admin@internal -p 12xx -d DCsi4_3-0 list
INFO: /tmp/logcollector does not exist.  It will be created.
ERROR: _get_hypervisors_from_api: global name '_' is not defined
INFO: No hypervisors were found, therefore no hypervisor data will be listed.
Comment 7 errata-xmlrpc 2012-12-04 13:19:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1530.html

Note You need to log in before you can comment on or make changes to this bug.