Bug 831213 - Invalid checksums in Maven repository
Invalid checksums in Maven repository
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Maven (Show other bugs)
2.0.0.ER7,2.0.0.ER8
Unspecified Unspecified
urgent Severity urgent
: ---
: 2.0.0.ER8
Assigned To: Marek Novotny
Karel Piwko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 09:55 EDT by Karel Piwko
Modified: 2012-06-13 04:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 04:05:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed log (152.21 KB, text/plain)
2012-06-12 09:57 EDT, Karel Piwko
no flags Details

  None (edit)
Description Karel Piwko 2012-06-12 09:55:52 EDT
Description of problem:

Unsigned variant of Maven repository contains a lot of broken md5 and sha1 checksums.

This is likely due to unsigning the artifacts and not correcting the checksums.

Additional info:

Occurs since ER7. Seems that unsigning script at

The unsign script is included in EAP 6.0.0 CR 1 distribution on candidate [1].
It originally comes from script dir in maven-repository-testsuite git repo [2].

[1] http://download.devel.redhat.com/devel/candidates/JBEAP/JBEAP-6.0.0-CR1/
[2] http://git.app.eng.bos.redhat.com/?p=jboss-eap/maven-repository-testsuite.git;a=tree;f=src/scripts

works correctly, so engineering have something mangled up.
Comment 1 Karel Piwko 2012-06-12 09:57:15 EDT
Created attachment 591196 [details]
Detailed log

Added a log with all files with wrong checksums.
Comment 2 Marek Novotny 2012-06-12 10:12:13 EDT
I have asked rel-eng for respin with recalculated checksums
Comment 3 Karel Piwko 2012-06-13 04:05:46 EDT
Verified in checksums are correct in ER8a, thus closing as CURRENT_RELEASE.

Note You need to log in before you can comment on or make changes to this bug.