Bug 831234 - yum-rhn-plugin: serverURL failover noworks
yum-rhn-plugin: serverURL failover noworks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Herr
Pavel Studeník
: Regression
Depends On: 706148
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-06-12 10:23 EDT by Martin Korbel
Modified: 2013-02-21 05:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:07:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2012-06-12 10:23:27 EDT
Description of problem:
The yum-rhn-plugin doesn't use the second serverURL directive, when the first faild (only RHEL 6).

Version-Release number of selected component (if applicable):
yum-rhn-plugin-0.9.1-40.el6.noarch
rhn-client-tools-1.0.0-87.el6.noarch
rhnlib-2.5.22-12.el6.noarch

How reproducible:
100%

Steps to Reproduce:
Install and register RHEL 6 Client to Satellite. Edit serverURL directive in /etc/sysconfig/rhn/up2date file, add nonexists server (www.xyz.com) before the correct satellite.
On RHEL 5 the yum-rhn-plugin uses the second directive (correct satellite), but on RHEL 6 doesn't.

1. install and register client RHEL 6
2. edit /etc/sysconfig/rhn/up2date > serverURL=http://www.xyz.com/XMLRPC;https://<fqdn-satellite>/XMLRPC;
3. try install some package
  
Actual results:
Package doesn't found

Expected results:
Package found and installed

Additional info:
only RHEL6! 
RHEL5 is OK.
Comment 3 Miroslav Suchý 2012-06-12 10:35:28 EDT
This has been solved in rhel5 in bug 706148.
Comment 10 errata-xmlrpc 2013-02-21 05:07:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0389.html

Note You need to log in before you can comment on or make changes to this bug.