Bug 83125 - noprobe is broken in installer (nopcmica is a bit wonky too)
noprobe is broken in installer (nopcmica is a bit wonky too)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-30 10:46 EST by Telsa Gwynne
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2003-01-30 10:46:33 EST
Description of problem:

I needed to try noprobe in gin gin beta 4. Either I minsunderstand it or it is
broken.

How reproducible: always

Steps to Reproduce:
1. Need an old Sony Vaio such as PCG-SR1K (SR5K in US) with external CD ROM drive
2. linux ide1=0x180,0x386 (other options here if necessary like 'text') noprobe
3. continue through keyboard and language selection
    
Actual results:

Get a message about not finding a driver and needing a driver disc. 
Apparently it is loading the cardbus drivers despite the noprobe option.

The same happens with nopcmica: is this a separate bug?

Expected results:

It doesn't probe and hence doesn't load cardbus drivers and works.

Additional info:

A workaround is to add pci=off into the line of options. 

The ide1 option was possibly not necessary. It was the first thing
I tried when "linux text" didn't get further than "where are the
drivers?" because once upon a time it used to be necessary.
It was not necessary in subsequent releases to that. I just added
it as a first port of call and forgot to try without it.
Comment 1 Jeremy Katz 2003-01-30 22:59:30 EST
noprobe has always probed pcmcia controllers and I'm probably going to leave it
like that.  nopcmcia seems to work here, though.  You actually get messages on
tty4 about yenta_socket loading if you boot with 'linux nopcmcia'?
Comment 2 Bill Nottingham 2003-01-30 23:05:48 EST
'nopcmcia', not 'nopcmica'.
Comment 3 Telsa Gwynne 2003-01-31 04:36:31 EST
jkatz: yes

bill: typo :) 
Comment 4 Jeremy Katz 2003-02-05 15:22:13 EST
Okay, I see why.  Added some filtering for after our probe in CVS.  Workaround
in beta4 is a combination of both noprobe and nopcmcia.
Comment 5 Brent Fox 2003-05-25 10:53:08 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.