Bug 831251 - junit4 doesn't build/no longer exists - required by maven-surefire-provider-junit4
junit4 doesn't build/no longer exists - required by maven-surefire-provider-j...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Mach
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 10:57 EDT by Bill Nottingham
Modified: 2014-03-16 23:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 07:47:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-06-12 10:57:42 EDT
Description of problem:

junit4 currently has a broken build dependency on java-1.6.0-openjdk.
junit4 no longer exists in Fedora.

It looks like the choices are either:

1) fix junit4, keep it in RHEL, rebuild it
2) Drop maven-surefire-provider-junit4 and the build dep in pmd

Other ideas welcome. Please fix this as soon as possible.

Version-Release number of selected component (if applicable):

latest RHEL 7 nightly
Comment 1 Alexander Kurtakov 2012-06-12 12:40:18 EDT
Please do not assign these RHEL 7 bugs to me. They should go to Stano and his team. I don't know what handles the default assignee now bugzilla of pkgwrangler but whatever it is it needs to be fixed to represent the current state of affairs.
Comment 2 Stanislav Ochotnicky 2012-06-12 12:51:24 EDT
The issue is that junit now provides junit4. I will be fixed by updating to new version of junit and then dropping junit4. I'll do it later on
Comment 3 Stanislav Ochotnicky 2012-06-20 08:30:15 EDT
OK, so right now it boils down to: block junit4 in repositories, remove rhel-7 branch. junit now provides junit4
Comment 4 Bill Nottingham 2012-06-20 12:10:34 EDT
Moving to releng to take care of the request in comment #3.

Note You need to log in before you can comment on or make changes to this bug.