Bug 83126 - .OLD backup files cause subsequent ifcfg alias files to not be run
.OLD backup files cause subsequent ifcfg alias files to not be run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2003-01-30 10:46 EST by Erik Aase-Remedios
Modified: 2014-03-16 22:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: 8.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 07:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik Aase-Remedios 2003-01-30 10:46:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
When there are .OLD backup files which contain the same information then the
script will error on the first such alias.
This causes any later aliases to not be loaded.


Version-Release number of selected component (if applicable):
# rpm -q initscripts 
initscripts-6.95-1

How reproducible:
Always

Steps to Reproduce:
1. have more than one alias, e.g. ifcfg-eth0:0 and ifcfg-eth0:1
2. copy ifcfg-eth0:0 to ifcfg-eth0:0.OLD
3. run ./ifup-aliases eth0



Actual Results:  observe the error and notice that ifcfg-eth0:1 never was run.

./ifup-aliases: line 3: devseen_0.OLD=ifcfg-eth0:0.OLD: command not found
error in ifcfg-eth0:0.OLD: already seen ipaddr 216.27.158.98 in ifcfg-eth0:0



Expected Results:  possibly that configuration should be skipped without
stopping the whole process.
possibly a more complex backup exclusion is needed.


Additional info:

I knew that my second alias was properly configured, could not figure out why it
wouldn't load after reboot.
Comment 1 Bill Nottingham 2003-09-03 21:53:59 EDT
I don't believe .OLD is a normal editor backup file... that's why it's read.
Comment 2 Erik Aase-Remedios 2003-09-04 09:06:08 EDT
Two reasons why I believe this needs to be fixed:
1- the network configuration should be loaded even if there are errors in one of
the files, the subsequent files should be read.

2- This is not caused by a normal editor.  It is caused by RedHat's upgrade process.
Note a few other ocurrances of this problem:
http://groups.google.com/groups?q=+ifcfg-eth0.OLD

Redhat's network configuration utilities should not create these files, but if
they do, ifup-aliases should continue working.

This bug was not about the creation of the files or even the exitance of such
files, but that fact that ifup-aliases would cease working upon the first error
it encountered.
I believe that it should report the error and continue to load the other valid
aliases.
Comment 3 Bill Nottingham 2003-09-04 12:49:27 EDT
Looking at current redhat-config-network code, I don't see it creating .OLD; but
you're right, it shouldn't bail completely. 
Comment 4 Miloslav Trmač 2006-02-07 07:37:39 EST
initscripts-8.26-1 were fixed to ignore incorrectly named files, and to continue
on errors in alias files.

Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.