Bug 831275 - autofs-5.0.6-5.fc16.x86_64 fails to unmount CIFS share after timeout - goes into infinite loop
autofs-5.0.6-5.fc16.x86_64 fails to unmount CIFS share after timeout - goes i...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 12:06 EDT by Jerry
Modified: 2013-02-13 09:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 09:50:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry 2012-06-12 12:06:15 EDT
Description of problem:
Automount fails to unmount CIFS share after the timeout period.


Version-Release number of selected component (if applicable):
autofs-5.0.6-5.fc16.x86_64


How reproducible:
It fails every time.


Steps to Reproduce:
1. Access share -- ls /jose/samba
2. Wait 10 seconds
3. Check to see if share is mounted
4. Check /var/log/messages for errors
  
Actual results:
Automount fails to unmount the share.

Expected results:
The share should be unmounted after the timeout period.

Additional info:
[root@sirius ~]# rpm -qa | grep autofs
autofs-5.0.6-5.fc16.x86_64

[root@sirius ~]# more /etc/auto.master
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
#/misc  /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
#
#/net   -hosts
#
# Include /etc/auto.master.d/*.autofs
#
+dir:/etc/auto.master.d
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
#+auto.master
# /mnt/jose -- share on Rigel
/jose   /etc/auto.jose --timeout=3

[root@sirius ~]# more /etc/auto.jose
# jose -- CIFS share on Rigel
samba  -fstype=cifs,rw,noperm,user=jose,pass=password ://rigel/samba

[root@sirius ~]#tail -100 /var/log/messages
Jun 11 23:15:19 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:19 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:19 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:19 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:19 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:20 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:20 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:20 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:20 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:20 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:21 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:21 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:21 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:21 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:21 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:22 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:22 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:22 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:22 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:22 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:23 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:23 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:23 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:23 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:23 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:24 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:24 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:24 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:24 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:24 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:25 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:25 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:25 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:25 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:25 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Jun 11 23:15:26 sirius automount[4324]: st_expire: state 1 path /jose
Jun 11 23:15:26 sirius automount[4324]: expire_proc: exp_proc = 140617099437824 path /jose
Jun 11 23:15:26 sirius automount[4324]: expire_cleanup: got thid 140617099437824 path /jose stat 0
Jun 11 23:15:26 sirius automount[4324]: expire_cleanup: sigchld: exp 140617099437824 finished, switching from 2 to 1
Jun 11 23:15:26 sirius automount[4324]: st_ready: st_ready(): state = 2 path /jose
Comment 1 Ian Kent 2012-06-12 20:56:59 EDT
Some more information would be useful.

If you attempt to umount the mount manually, does that work OK?
Does the same thing happen with other types of mount, such as NFS?
What kernel version are you using?
Comment 2 Jerry 2012-06-13 00:55:35 EDT
I can umount the mount manually and that works fine.  I don't have any other types of file systems to experiment with.  I have tried kernel 3.3.7-1 and kernel 3.3.2-1.
Comment 3 Ian Kent 2012-06-13 01:25:28 EDT
(In reply to comment #2)
> I can umount the mount manually and that works fine.  I don't have any other
> types of file systems to experiment with.  I have tried kernel 3.3.7-1 and
> kernel 3.3.2-1.

I had a similar problem recently myself.

After a yum update suddenly mounts stopped expiring.

I looked high and low and couldn't find what was causing it.

It seemsed to be independent of autofs and kernel version.
I couldn't find any user space functionality that would
cause the elevated reference count the way it appeared in
the kernel (preventing mounts from expiring). It was really
frustrating.

Then, as mysteriously as it appeared, it went away after a
yum update.

So I'll do a yum update and see if the problem returns.

Other than that there isn't much we can do but start by
investigating debug logs, but we can get to that after
I update my system.
Comment 4 Jerry 2012-06-13 21:28:25 EDT
I just set up an NFS share on an ancient Ubuntu machine and was able to mount the share, but it also failed to umount the share after the timeout period.  Again, I was able to umount the NFS share manually.
Comment 5 Jerry 2012-06-14 17:21:02 EDT
I have a feeling that one or more of the packages in this transaction is the culprit, as I have been having problems with network mounts ever since (CIFS mounts becoming stale and locking up processes after the Windows machine has been powered off for a period and then powered back on with no file access during the down period -- this worked before 95% of the time).  Attached is the output of yum history info.

I had never tried automount before the upgrade shown below so I can't say for certain that it caused the problem, but I suspect there is some relation.

I hope that this information helps to clarify the problem, and that it isn't just white noise.  :)

[root@sirius ~]# yum history info 22
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Transaction ID : 22
Begin time     : Thu Jun  7 14:46:03 2012
Begin rpmdb    : 1414:a2e6713b48b744f1d7db94d7ee47152abf776dc0
End time       :            14:51:25 2012 (5 minutes)
End rpmdb      : 1437:8cdc2442ecd2e28cd39f9b5e413ff5f0ddca5359
User           : mythtv <mythtv>
Return-Code    : Success
Command Line   : update
Transaction performed with:
    Installed     rpm-4.9.1.3-1.fc16.x86_64                     @updates
Loading mirror speeds from cached hostfile
 * fedora: mirror.cogentco.com
 * rpmfusion-free: mirror.us.leaseweb.net
 * rpmfusion-free-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
 * updates: mirror.cogentco.com
    Updated       yum-3.4.3-23.fc16.noarch                      ?
    Installed     yum-plugin-fastestmirror-1.1.31-2.fc16.noarch @fedora
    Installed     yum-presto-0.7.1-1.fc16.noarch                @koji-override-0/$releasever
Packages Altered:
    Updated     NetworkManager-1:0.9.4-2.git20120403.fc16.x86_64         @updates
    Update                     1:0.9.4-6.git20120521.fc16.x86_64         @updates
    Updated     NetworkManager-glib-1:0.9.4-2.git20120403.fc16.x86_64    @updates
    Update                          1:0.9.4-6.git20120521.fc16.x86_64    @updates
    Updated     NetworkManager-gnome-1:0.9.4-2.git20120403.fc16.x86_64   @updates
    Update                           1:0.9.4-6.git20120521.fc16.x86_64   @updates
    Updated     NetworkManager-gtk-1:0.9.4-2.git20120403.fc16.x86_64     @updates
    Update                         1:0.9.4-6.git20120521.fc16.x86_64     @updates
    Updated     PackageKit-0.6.22-1.fc16.x86_64                          @updates
    Update                 0.6.22-2.fc16.x86_64                          @updates
    Updated     PackageKit-device-rebind-0.6.22-1.fc16.x86_64            @updates
    Update                               0.6.22-2.fc16.x86_64            @updates
    Updated     PackageKit-glib-0.6.22-1.fc16.x86_64                     @updates
    Update                      0.6.22-2.fc16.x86_64                     @updates
    Updated     PackageKit-yum-0.6.22-1.fc16.x86_64                      @updates
    Update                     0.6.22-2.fc16.x86_64                      @updates
    Updated     PackageKit-yum-plugin-0.6.22-1.fc16.x86_64               @updates
    Update                            0.6.22-2.fc16.x86_64               @updates
    Updated     abrt-2.0.7-2.fc16.x86_64                                 ?
    Update           2.0.7-3.fc16.x86_64                                 @updates
    Updated     abrt-addon-ccpp-2.0.7-2.fc16.x86_64                      ?
    Update                      2.0.7-3.fc16.x86_64                      @updates
    Updated     abrt-addon-kerneloops-2.0.7-2.fc16.x86_64                ?
    Update                            2.0.7-3.fc16.x86_64                @updates
    Updated     abrt-addon-python-2.0.7-2.fc16.x86_64                    ?
    Update                        2.0.7-3.fc16.x86_64                    @updates
    Updated     abrt-addon-vmcore-2.0.7-2.fc16.x86_64                    ?
    Update                        2.0.7-3.fc16.x86_64                    @updates
    Updated     abrt-desktop-2.0.7-2.fc16.x86_64                         ?
    Update                   2.0.7-3.fc16.x86_64                         @updates
    Updated     abrt-gui-2.0.7-2.fc16.x86_64                             ?
    Update               2.0.7-3.fc16.x86_64                             @updates
    Updated     abrt-libs-2.0.7-2.fc16.x86_64                            ?
    Update                2.0.7-3.fc16.x86_64                            @updates
    Updated     abrt-retrace-client-2.0.7-2.fc16.x86_64                  ?
    Update                          2.0.7-3.fc16.x86_64                  @updates
    Updated     accountsservice-0.6.15-2.fc16.x86_64                     ?
    Update                      0.6.15-3.fc16.x86_64                     @updates
    Updated     accountsservice-libs-0.6.15-2.fc16.x86_64                ?
    Update                           0.6.15-3.fc16.x86_64                @updates
    Updated     at-3.1.13-5.fc16.x86_64                                  ?
    Update         3.1.13-6.fc16.x86_64                                  @updates
    Dep-Install avahi-compat-libdns_sd-0.6.30-4.fc16.x86_64              @fedora
    Updated     bash-4.2.24-1.fc16.x86_64                                ?
    Update           4.2.28-1.fc16.x86_64                                @updates
    Updated     bind-libs-32:9.8.2-0.4.rc2.fc16.x86_64                   @updates
    Update                32:9.8.3-1.fc16.x86_64                         @updates
    Updated     bind-libs-lite-32:9.8.2-0.4.rc2.fc16.x86_64              @updates
    Update                     32:9.8.3-1.fc16.x86_64                    @updates
    Updated     bind-license-32:9.8.2-0.4.rc2.fc16.noarch                @updates
    Update                   32:9.8.3-1.fc16.noarch                      @updates
    Updated     bind-utils-32:9.8.2-0.4.rc2.fc16.x86_64                  @updates
    Update                 32:9.8.3-1.fc16.x86_64                        @updates
    Updated     cifs-utils-5.3-2.fc16.x86_64                             ?
    Update                 5.4-1.fc16.x86_64                             @updates
    Updated     cloog-ppl-0.15.9-3.fc15.x86_64                           @?fedora
    Update                0.15.11-1.fc16.x86_64                          @updates
    Updated     clutter-1.8.4-1.fc16.x86_64                              ?
    Update              1.8.4-2.fc16.x86_64                              @updates
    Updated     colord-0.1.15-2.fc16.x86_64                              ?
    Update             0.1.18-2.fc16.x86_64                              @updates
    Updated     cups-1:1.5.2-8.1.fc16.x86_64                             @updates
    Update           1:1.5.2-9.fc16.x86_64                               @updates
    Updated     cups-libs-1:1.5.2-8.1.fc16.x86_64                        @updates
    Update                1:1.5.2-9.fc16.x86_64                          @updates
    Updated     dhclient-12:4.2.3-6.P2.fc16.x86_64                       ?
    Update               12:4.2.3-8.P2.fc16.x86_64                       @updates
    Updated     dhcp-common-12:4.2.3-6.P2.fc16.x86_64                    ?
    Update                  12:4.2.3-8.P2.fc16.x86_64                    @updates
    Updated     dhcp-libs-12:4.2.3-6.P2.fc16.x86_64                      ?
    Update                12:4.2.3-8.P2.fc16.x86_64                      @updates
    Updated     dvd+rw-tools-7.1-5.fc14.x86_64                           @?fedora
    Update                   7.1-9.fc16.x86_64                           @updates
    Updated     expat-2.0.1-11.fc15.x86_64                               @?fedora
    Update            2.1.0-1.fc16.x86_64                                @updates
    Updated     ffmpeg-0.8.10-1.fc16.x86_64                              ?
    Update             0.8.11-1.fc16.x86_64                              @rpmfusion-free-updates
    Updated     ffmpeg-libs-0.8.10-1.fc16.x86_64                         ?
    Update                  0.8.11-1.fc16.x86_64                         @rpmfusion-free-updates
    Updated     fftw-libs-3.3-3.fc16.x86_64                              @?fedora
    Obsoleting  fftw-libs-3.3.1-2.fc16.x86_64                            @updates
    Dep-Install fftw-libs-double-3.3.1-2.fc16.x86_64                     @updates
    Dep-Install fftw-libs-long-3.3.1-2.fc16.x86_64                       @updates
    Dep-Install fftw-libs-quad-3.3.1-2.fc16.x86_64                       @updates
    Dep-Install fftw-libs-single-3.3.1-2.fc16.x86_64                     @updates
    Obsoleted   fftw-libs-threads-3.3-3.fc16.x86_64                      @?fedora
    Updated     firefox-11.0-1.fc16.x86_64                               ?
    Update              12.0-1.fc16.x86_64                               @updates
    Updated     flac-1.2.1-6.fc12.x86_64                                 @?fedora
    Update           1.2.1-8.fc16.x86_64                                 @updates
    Updated     garcon-0.1.9-2.fc16.x86_64                               @?fedora
    Update             0.1.9-4.fc16.x86_64                               @updates
    Updated     glib2-2.30.2-1.fc16.x86_64                               ?
    Update            2.30.3-1.fc16.x86_64                               @updates
    Updated     glibc-2.14.90-24.fc16.6.x86_64                           ?
    Update            2.14.90-24.fc16.7.x86_64                           @updates
    Updated     glibc-common-2.14.90-24.fc16.6.x86_64                    ?
    Update                   2.14.90-24.fc16.7.x86_64                    @updates
    Updated     glibc-devel-2.14.90-24.fc16.6.x86_64                     ?
    Update                  2.14.90-24.fc16.7.x86_64                     @updates
    Updated     glibc-headers-2.14.90-24.fc16.6.x86_64                   ?
    Update                    2.14.90-24.fc16.7.x86_64                   @updates
    Updated     gnome-color-manager-3.2.3-1.fc16.x86_64                  ?
    Update                          3.2.3-2.fc16.x86_64                  @updates
    Updated     gnome-settings-daemon-3.2.2-2.fc16.x86_64                ?
    Update                            3.2.3-1.fc16.x86_64                @updates
    Updated     grub2-1:1.99-13.fc16.2.x86_64                            ?
    Update            1:1.99-13.fc16.3.x86_64                            @updates
    Updated     ibus-1.4.1-1.fc16.x86_64                                 ?
    Update           1.4.1-2.fc16.x86_64                                 @updates
    Updated     ibus-gtk2-1.4.1-1.fc16.x86_64                            ?
    Update                1.4.1-2.fc16.x86_64                            @updates
    Updated     ibus-gtk3-1.4.1-1.fc16.x86_64                            ?
    Update                1.4.1-2.fc16.x86_64                            @updates
    Updated     ibus-hangul-1.4.0-5.fc16.x86_64                          @updates
    Update                  1.4.1-2.fc16.x86_64                          @updates
    Updated     ibus-libs-1.4.1-1.fc16.x86_64                            ?
    Update                1.4.1-2.fc16.x86_64                            @updates
    Updated     ibus-pinyin-1.4.0-12.fc16.x86_64                         ?
    Update                  1.4.0-16.fc16.x86_64                         @updates
    Updated     ibus-pinyin-db-android-1.4.0-12.fc16.noarch              ?
    Update                             1.4.0-16.fc16.noarch              @updates
    Updated     im-chooser-1.5.2.1-1.fc16.x86_64                         ?
    Update                 1.5.2.2-1.fc16.x86_64                         @updates
    Updated     im-chooser-common-1.5.2.1-1.fc16.x86_64                  ?
    Update                        1.5.2.2-1.fc16.x86_64                  @updates
    Updated     imsettings-1.2.8.1-1.fc16.x86_64                         ?
    Update                 1.2.9-1.fc16.x86_64                           @updates
    Updated     imsettings-gnome-1.2.8.1-1.fc16.x86_64                   ?
    Update                       1.2.9-1.fc16.x86_64                     @updates
    Updated     imsettings-libs-1.2.8.1-1.fc16.x86_64                    ?
    Update                      1.2.9-1.fc16.x86_64                      @updates
    Updated     imsettings-xfce-1.2.8.1-1.fc16.x86_64                    ?
    Update                      1.2.9-1.fc16.x86_64                      @updates
    Erase       kernel-3.3.1-3.fc16.x86_64                               @updates
    Install     kernel-3.3.7-1.fc16.x86_64                               @updates
    Updated     kernel-headers-3.3.2-1.fc16.x86_64                       @updates
    Update                     3.3.7-1.fc16.x86_64                       @updates
    Updated     kmod-nvidia-1:295.40-2.fc16.1.x86_64                     @rpmfusion-nonfree-updates
    Update                  1:295.53-1.fc16.1.x86_64                     @rpmfusion-nonfree-updates
    Erase       kmod-nvidia-3.3.1-3.fc16.x86_64-1:295.33-2.fc16.3.x86_64 @rpmfusion-nonfree-updates
    Dep-Install kmod-nvidia-3.3.7-1.fc16.x86_64-1:295.53-1.fc16.1.x86_64 @rpmfusion-nonfree-updates
    Updated     lftp-4.3.3-1.fc16.x86_64                                 ?
    Update           4.3.6-1.fc16.x86_64                                 @updates
    Updated     libblkid-2.20.1-2.2.fc16.x86_64                          ?
    Update               2.20.1-2.3.fc16.x86_64                          @updates
    Updated     libburn-1.1.8-1.fc16.x86_64                              ?
    Update              1.2.2-1.fc16.x86_64                              @updates
    Updated     libdc1394-2.1.2-3.fc12.x86_64                            @?fedora
    Update                2.1.4-2.fc16.x86_64                            @updates
    Updated     libdrm-2.4.30-1.fc16.x86_64                              ?
    Update             2.4.33-1.fc16.x86_64                              @updates
    Updated     liberation-fonts-common-1.07.2-2.fc16.noarch             ?
    Update                              1.07.2-4.fc16.noarch             @updates
    Updated     liberation-mono-fonts-1.07.2-2.fc16.noarch               ?
    Update                            1.07.2-4.fc16.noarch               @updates
    Updated     liberation-sans-fonts-1.07.2-2.fc16.noarch               ?
    Update                            1.07.2-4.fc16.noarch               @updates
    Updated     liberation-serif-fonts-1.07.2-2.fc16.noarch              ?
    Update                             1.07.2-4.fc16.noarch              @updates
    Updated     libipa_hbac-1.8.1-7.fc16.x86_64                          ?
    Update                  1.8.3-11.fc16.x86_64                         @updates
    Updated     libisofs-1.1.6-1.fc16.x86_64                             @?fedora
    Update               1.2.2-1.fc16.x86_64                             @updates
    Updated     libmount-2.20.1-2.2.fc16.x86_64                          ?
    Update               2.20.1-2.3.fc16.x86_64                          @updates
    Updated     libogg-2:1.2.2-3.fc15.x86_64                             @?fedora
    Update             2:1.3.0-1.fc16.x86_64                             @updates
    Updated     libpinyin-0.5.91-3.fc16.x86_64                           ?
    Update                0.5.92-1.fc16.x86_64                           @updates
    Updated     libpinyin-data-0.5.91-3.fc16.x86_64                      ?
    Update                     0.5.92-1.fc16.x86_64                      @updates
    Updated     libpng-2:1.2.48-1.fc16.x86_64                            ?
    Update             2:1.2.49-1.fc16.x86_64                            @updates
    Updated     libsmbclient-1:3.6.4-82.fc16.x86_64                      @updates
    Update                   1:3.6.5-85.fc16.x86_64                      @updates
    Updated     libuuid-2.20.1-2.2.fc16.x86_64                           ?
    Update              2.20.1-2.3.fc16.x86_64                           @updates
    Updated     libwbclient-1:3.6.4-82.fc16.x86_64                       @updates
    Update                  1:3.6.5-85.fc16.x86_64                       @updates
    Updated     liferea-1:1.8.0-1.fc16.x86_64                            ?
    Update              1:1.8.5-1.fc16.x86_64                            @updates
    Updated     logwatch-7.4.0-6.20110328svn50.fc16.noarch               @updates
    Update               7.4.0-12.20120229svn100.fc16.noarch             @updates
    Updated     lohit-devanagari-fonts-2.5.1-2.fc16.noarch               ?
    Update                             2.5.1-3.fc16.noarch               @updates
    Updated     man-db-2.6.0.2-2.fc16.x86_64                             @?fedora
    Update             2.6.0.2-3.fc16.x86_64                             @updates
    Updated     mdadm-3.2.3-6.fc16.x86_64                                ?
    Update            3.2.5-1.fc16.x86_64                                @updates
    Updated     mencoder-1.0-0.130.20110925svn.fc16.x86_64               ?
    Update               1.0-0.131.20110925svn.fc16.x86_64               @rpmfusion-free-updates
    Updated     microcode_ctl-1:1.17-20.fc16.x86_64                      ?
    Update                    1:1.17-24.fc16.x86_64                      @updates
    Updated     midori-0.4.3-1.fc16.x86_64                               ?
    Update             0.4.6-1.fc16.x86_64                               @updates
    Updated     mplayer-1.0-0.130.20110925svn.fc16.x86_64                ?
    Update              1.0-0.131.20110925svn.fc16.x86_64                @rpmfusion-free-updates
    Updated     mplayer-common-1.0-0.130.20110925svn.fc16.x86_64         ?
    Update                     1.0-0.131.20110925svn.fc16.x86_64         @rpmfusion-free-updates
    Updated     mysql-5.5.22-1.fc16.x86_64                               @updates
    Update            5.5.23-1.fc16.x86_64                               @updates
    Updated     mysql-devel-5.5.22-1.fc16.x86_64                         @updates
    Update                  5.5.23-1.fc16.x86_64                         @updates
    Updated     mysql-libs-5.5.22-1.fc16.x86_64                          @updates
    Update                 5.5.23-1.fc16.x86_64                          @updates
    Updated     mysql-server-5.5.22-1.fc16.x86_64                        @updates
    Update                   5.5.23-1.fc16.x86_64                        @updates
    Updated     mytharchive-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythbrowser-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythgallery-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythgame-0.24.2-1.fc16.x86_64                            ?
    Update               0.25-6.fc16.x86_64                              @rpmfusion-free-updates
    Updated     mythmusic-0.24.2-1.fc16.x86_64                           ?
    Update                0.25-6.fc16.x86_64                             @rpmfusion-free-updates
    Updated     mythnetvision-0.24.2-1.fc16.x86_64                       ?
    Update                    0.25-6.fc16.x86_64                         @rpmfusion-free-updates
    Updated     mythnews-0.24.2-1.fc16.x86_64                            ?
    Update               0.25-6.fc16.x86_64                              @rpmfusion-free-updates
    Updated     mythplugins-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythtv-0.24.2-1.fc16.x86_64                              ?
    Update             0.25-6.fc16.x86_64                                @rpmfusion-free-updates
    Updated     mythtv-backend-0.24.2-1.fc16.x86_64                      ?
    Update                     0.25-6.fc16.x86_64                        @rpmfusion-free-updates
    Updated     mythtv-base-themes-0.24.2-1.fc16.x86_64                  ?
    Update                         0.25-6.fc16.x86_64                    @rpmfusion-free-updates
    Updated     mythtv-common-0.24.2-1.fc16.x86_64                       ?
    Update                    0.25-6.fc16.x86_64                         @rpmfusion-free-updates
    Updated     mythtv-docs-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythtv-frontend-0.24.2-1.fc16.x86_64                     ?
    Obsoleting  mythtv-frontend-0.25-6.fc16.x86_64                       @rpmfusion-free-updates
    Updated     mythtv-libs-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythtv-setup-0.24.2-1.fc16.x86_64                        ?
    Update                   0.25-6.fc16.x86_64                          @rpmfusion-free-updates
    Obsoleted   mythvideo-0.24.2-1.fc16.x86_64                           ?
    Updated     mythweather-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Updated     mythweb-0.24.2-1.fc16.x86_64                             ?
    Update              0.25-6.fc16.x86_64                               @rpmfusion-free-updates
    Updated     mythzoneminder-0.24.2-1.fc16.x86_64                      ?
    Update                     0.25-6.fc16.x86_64                        @rpmfusion-free-updates
    Updated     nvidia-settings-1.0-16.fc16.x86_64                       @rpmfusion-nonfree-updates
    Update                      1.0-17.fc16.x86_64                       @rpmfusion-nonfree-updates
    Updated     nvidia-xconfig-1.0-14.fc16.x86_64                        @rpmfusion-nonfree-updates
    Update                     1.0-15.fc16.x86_64                        @rpmfusion-nonfree-updates
    Updated     obexd-0.42-1.fc16.x86_64                                 @?fedora
    Update            0.44-1.fc16.x86_64                                 @updates
    Updated     openssl-1.0.0h-1.fc16.x86_64                             @updates
    Update              1.0.0j-1.fc16.x86_64                             @updates
    Updated     openssl-devel-1.0.0h-1.fc16.x86_64                       @updates
    Update                    1.0.0j-1.fc16.x86_64                       @updates
    Updated     os-prober-1.48-2.fc16.x86_64                             ?
    Update                1.53-1.fc16.x86_64                             @updates
    Updated     pcre-8.12-7.fc16.x86_64                                  ?
    Update           8.12-9.fc16.x86_64                                  @updates
    Dep-Install perl-Archive-Zip-1.30-6.fc16.noarch                      @fedora
    Dep-Install perl-File-Slurp-9999.19-2.fc16.noarch                    @fedora
    Dep-Install perl-HTML-Form-6.00-5.fc16.noarch                        @fedora
    Dep-Install perl-HTTP-Cache-Transparent-1.0-10.fc16.noarch           @fedora
    Dep-Install perl-IO-Socket-INET6-2.67-1.fc16.noarch                  @fedora
    Dep-Install perl-IO-stringy-2.110-16.fc16.noarch                     @fedora
    Updated     perl-MythTV-0.24.2-1.fc16.x86_64                         ?
    Update                  0.25-6.fc16.x86_64                           @rpmfusion-free-updates
    Dep-Install perl-Parse-RecDescent-1.965001-4.fc16.noarch             @fedora
    Dep-Install perl-Tk-804.029-4.fc16.x86_64                            @updates
    Updated     perl-URI-1.58-2.fc16.noarch                              @?fedora
    Update               1.60-1.fc16.noarch                              @updates
    Dep-Install perl-WWW-Mechanize-1.68-2.fc16.noarch                    @fedora
    Dep-Install perl-XML-DOM-1.44-12.fc16.noarch                         @fedora
    Dep-Install perl-XML-LibXSLT-1.70-8.fc16.x86_64                      @fedora
    Dep-Install perl-XML-RegExp-0.03-11.fc16.noarch                      @fedora
    Dep-Install perl-XML-Twig-3.38-4.fc16.noarch                         @fedora
    Dep-Install perl-XML-Writer-0.606-9.fc16.noarch                      @fedora
    Dep-Install perl-XMLTV-0.5.61-1.fc16.noarch                          @rpmfusion-free
    Updated     php-5.3.10-1.fc16.x86_64                                 ?
    Update          5.3.13-1.fc16.x86_64                                 @updates
    Dep-Install php-MythTV-0.25-6.fc16.x86_64                            @rpmfusion-free-updates
    Updated     php-cli-5.3.10-1.fc16.x86_64                             ?
    Update              5.3.13-1.fc16.x86_64                             @updates
    Updated     php-common-5.3.10-1.fc16.x86_64                          ?
    Update                 5.3.13-1.fc16.x86_64                          @updates
    Updated     php-mysql-5.3.10-1.fc16.x86_64                           ?
    Update                5.3.13-1.fc16.x86_64                           @updates
    Updated     php-pdo-5.3.10-1.fc16.x86_64                             ?
    Update              5.3.13-1.fc16.x86_64                             @updates
    Updated     php-process-5.3.10-1.fc16.x86_64                         ?
    Update                  5.3.13-1.fc16.x86_64                         @updates
    Updated     pixman-0.22.2-1.fc16.x86_64                              @?fedora
    Update             0.24.4-1.fc16.x86_64                              @updates
    Dep-Install pmount-0.9.22-3.fc16.x86_64                              @fedora
    Updated     poppler-0.18.0-2.fc16.x86_64                             ?
    Update              0.18.0-3.fc16.x86_64                             @updates
    Updated     poppler-glib-0.18.0-2.fc16.x86_64                        ?
    Update                   0.18.0-3.fc16.x86_64                        @updates
    Updated     poppler-utils-0.18.0-2.fc16.x86_64                       ?
    Update                    0.18.0-3.fc16.x86_64                       @updates
    Updated     powertop-1.98-5.fc16.x86_64                              ?
    Update               1.98-9.fc16.x86_64                              @updates
    Dep-Install pygobject3-3.0.3-1.fc16.x86_64                           @updates
    Updated     python-2.7.2-5.2.fc16.x86_64                             @?fedora
    Update             2.7.3-3.fc16.x86_64                               @updates
    Updated     python-MythTV-0.24.2-1.fc16.x86_64                       ?
    Update                    0.25-6.fc16.x86_64                         @rpmfusion-free-updates
    Updated     python-devel-2.7.2-5.2.fc16.x86_64                       @?fedora
    Update                   2.7.3-3.fc16.x86_64                         @updates
    Updated     python-libs-2.7.2-5.2.fc16.x86_64                        @?fedora
    Update                  2.7.3-3.fc16.x86_64                          @updates
    Updated     qt-1:4.8.1-5.fc16.x86_64                                 @updates
    Update         1:4.8.2-2.fc16.x86_64                                 @updates
    Updated     qt-mysql-1:4.8.1-5.fc16.x86_64                           @updates
    Update               1:4.8.2-2.fc16.x86_64                           @updates
    Updated     qt-x11-1:4.8.1-5.fc16.x86_64                             @updates
    Update             1:4.8.2-2.fc16.x86_64                             @updates
    Updated     qtwebkit-2.2.1-2.fc16.x86_64                             ?
    Update               2.2.1-6.fc16.x86_64                             @updates
    Updated     rsyslog-5.8.7-1.fc16.x86_64                              ?
    Update              5.8.10-1.fc16.x86_64                             @updates
    Updated     ruby-libs-1.8.7.357-1.fc16.x86_64                        ?
    Update                1.8.7.358-1.fc16.x86_64                        @updates
    Updated     samba-winbind-clients-1:3.6.4-82.fc16.x86_64             @updates
    Update                            1:3.6.5-85.fc16.x86_64             @updates
    Updated     sane-backends-1.0.22-8.fc16.x86_64                       ?
    Update                    1.0.22-10.fc16.x86_64                      @updates
    Updated     sane-backends-drivers-cameras-1.0.22-8.fc16.x86_64       ?
    Update                                    1.0.22-10.fc16.x86_64      @updates
    Updated     sane-backends-libs-1.0.22-8.fc16.x86_64                  ?
    Update                         1.0.22-10.fc16.x86_64                 @updates
    Updated     selinux-policy-3.10.0-84.fc16.noarch                     @updates
    Update                     3.10.0-86.fc16.noarch                     @updates
    Updated     selinux-policy-targeted-3.10.0-84.fc16.noarch            @updates
    Update                              3.10.0-86.fc16.noarch            @updates
    Updated     setroubleshoot-3.1.3-1.fc16.x86_64                       ?
    Update                     3.1.11-1.fc16.x86_64                      @updates
    Updated     setroubleshoot-plugins-3.0.27-1.fc16.noarch              ?
    Update                             3.0.38-1.fc16.noarch              @updates
    Updated     setroubleshoot-server-3.1.3-1.fc16.x86_64                ?
    Update                            3.1.11-1.fc16.x86_64               @updates
    Updated     sssd-1.8.1-7.fc16.x86_64                                 ?
    Update           1.8.3-11.fc16.x86_64                                @updates
    Updated     sssd-client-1.8.1-7.fc16.x86_64                          ?
    Update                  1.8.3-11.fc16.x86_64                         @updates
    Updated     systemd-37-17.fc16.x86_64                                ?
    Update              37-25.fc16.x86_64                                @updates
    Updated     systemd-sysv-37-17.fc16.x86_64                           ?
    Update                   37-25.fc16.x86_64                           @updates
    Updated     systemd-units-37-17.fc16.x86_64                          ?
    Update                    37-25.fc16.x86_64                          @updates
    Updated     taglib-1.7.1-1.fc16.x86_64                               @updates
    Update             1.7.2-1.fc16.x86_64                               @updates
    Updated     usb_modeswitch-1.2.2-2.fc16.x86_64                       ?
    Update                     1.2.3-1.fc16.x86_64                       @updates
    Updated     usb_modeswitch-data-20111023-1.fc16.noarch               ?
    Update                          20120120-1.fc16.noarch               @updates
    Updated     util-linux-2.20.1-2.2.fc16.x86_64                        ?
    Update                 2.20.1-2.3.fc16.x86_64                        @updates
    Updated     vim-common-2:7.3.315-1.fc16.x86_64                       @?fedora
    Update                 2:7.3.515-1.fc16.x86_64                       @updates
    Updated     vim-enhanced-2:7.3.315-1.fc16.x86_64                     @?fedora
    Update                   2:7.3.515-1.fc16.x86_64                     @updates
    Updated     vim-filesystem-2:7.3.315-1.fc16.x86_64                   @?fedora
    Update                     2:7.3.515-1.fc16.x86_64                   @updates
    Updated     vim-minimal-2:7.3.315-1.fc16.x86_64                      @?fedora
    Update                  2:7.3.515-1.fc16.x86_64                      @updates
    Updated     xfce4-session-4.8.2-1.fc16.x86_64                        @?fedora
    Update                    4.8.3-1.fc16.x86_64                        @updates
    Updated     xfce4-session-engines-4.8.2-1.fc16.x86_64                @?fedora
    Update                            4.8.3-1.fc16.x86_64                @updates
    Updated     xfdesktop-4.8.3-1.fc16.x86_64                            @?fedora
    Update                4.8.3-3.fc16.x86_64                            @updates
    Dep-Install xmltv-0.5.61-1.fc16.noarch                               @rpmfusion-free
    Dep-Install xmltv-grabbers-0.5.61-1.fc16.noarch                      @rpmfusion-free
    Updated     xorg-x11-drv-intel-2.17.0-8.fc16.x86_64                  ?
    Update                         2.19.0-3.fc16.x86_64                  @updates
    Updated     xorg-x11-drv-nvidia-1:295.40-1.fc16.x86_64               @rpmfusion-nonfree-updates
    Update                          1:295.53-1.fc16.x86_64               @rpmfusion-nonfree-updates
    Updated     xorg-x11-drv-nvidia-libs-1:295.40-1.fc16.x86_64          @rpmfusion-nonfree-updates
    Update                               1:295.53-1.fc16.x86_64          @rpmfusion-nonfree-updates
    Updated     xorg-x11-server-Xephyr-1.11.4-2.fc16.x86_64              ?
    Update                             1.11.4-3.fc16.x86_64              @updates
    Updated     xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64                ?
    Update                           1.11.4-3.fc16.x86_64                @updates
    Updated     xorg-x11-server-common-1.11.4-2.fc16.x86_64              ?
    Update                             1.11.4-3.fc16.x86_64              @updates
    Updated     xscreensaver-1:5.15-3.fc16.x86_64                        ?
    Update                   1:5.15-6.fc16.x86_64                        @updates
    Updated     xscreensaver-base-1:5.15-3.fc16.x86_64                   ?
    Update                        1:5.15-6.fc16.x86_64                   @updates
    Updated     xscreensaver-extras-1:5.15-3.fc16.x86_64                 ?
    Update                          1:5.15-6.fc16.x86_64                 @updates
    Updated     xscreensaver-extras-base-1:5.15-3.fc16.x86_64            ?
    Update                               1:5.15-6.fc16.x86_64            @updates
    Updated     xscreensaver-gl-base-1:5.15-3.fc16.x86_64                ?
    Update                           1:5.15-6.fc16.x86_64                @updates
    Updated     xscreensaver-gl-extras-1:5.15-3.fc16.x86_64              ?
    Update                             1:5.15-6.fc16.x86_64              @updates
    Updated     xulrunner-11.0-3.fc16.x86_64                             ?
    Update                12.0-1.fc16.x86_64                             @updates
    Updated     ypbind-3:1.35-1.fc16.x86_64                              @updates
    Update             3:1.35-2.fc16.x86_64                              @updates
    Updated     yum-3.4.3-23.fc16.noarch                                 ?
    Update          3.4.3-24.fc16.noarch                                 @updates
Scriptlet output:
   1 SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.26, searching for an older version.
   2 SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.26:  No such file or directory
   3 load_policy:  Can't load policy:  No such file or directory
history info
[root@sirius ~]#
Comment 6 Ian Kent 2012-06-15 00:55:28 EDT
(In reply to comment #5)
> I have a feeling that one or more of the packages in this transaction is the
> culprit, as I have been having problems with network mounts ever since (CIFS
> mounts becoming stale and locking up processes after the Windows machine has
> been powered off for a period and then powered back on with no file access
> during the down period -- this worked before 95% of the time).  Attached is
> the output of yum history info.
> 
> I had never tried automount before the upgrade shown below so I can't say
> for certain that it caused the problem, but I suspect there is some relation.
> 
> I hope that this information helps to clarify the problem, and that it isn't
> just white noise.  :)
> 

I'll have a look through but it's pretty hard to know which
one it might be.

Another thing I found was that if I booted into run level 3
mounts would expire normally so I concluded it was related
to a GUI package. And it was independent of the file system
of the mount.

If you can get a chance to check and any of these things and
find they aren't true then we are looking for something
different in your case.

btw, I haven't had a chance to try a yum update yet. I'll
get to that soon as I can.
Comment 7 Jerry 2012-06-15 08:13:24 EDT
(In reply to comment #6)
> Another thing I found was that if I booted into run level 3
> mounts would expire normally so I concluded it was related
> to a GUI package. And it was independent of the file system
> of the mount.
> 

I just tried booting into run level 3 and the NFS and CIFS mounts did not expire. :(  I guess it's something else in my case.
Comment 8 Jerry 2012-06-16 12:33:27 EDT
Does this output help narrow down the issue?

[root@sirius ~]# yum deplist autofs
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
updates/metalink                                                                                                      |  16 kB     00:00
 * fedora: mirror.cogentco.com
 * rpmfusion-free: mirror.us.leaseweb.net
 * rpmfusion-free-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
 * updates: mirror.cogentco.com
rpmfusion-free-updates                                                                                                | 3.3 kB     00:00
rpmfusion-nonfree-updates                                                                                             | 3.3 kB     00:00
package: autofs.x86_64 1:5.0.6-5.fc16
  dependency: /bin/bash
   provider: bash.x86_64 4.2.28-1.fc16
  dependency: /bin/ps
   provider: procps.x86_64 3.2.8-24.20110302git.fc16
  dependency: /bin/sh
   provider: bash.x86_64 4.2.28-1.fc16
  dependency: /sbin/chkconfig
   provider: chkconfig.x86_64 1.3.59-1.fc16
  dependency: /sbin/service
   provider: initscripts.x86_64 9.34.2-1.fc16
  dependency: bash
   provider: bash.x86_64 4.2.28-1.fc16
  dependency: gawk
   provider: gawk.x86_64 4.0.0-1.fc16
  dependency: grep
   provider: grep.x86_64 2.9-3.fc16
  dependency: kernel >= 2.6.17
   provider: kernel-debug.x86_64 3.3.8-1.fc16
   provider: kernel.x86_64 3.3.8-1.fc16
  dependency: libc.so.6()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.14)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.3)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.3.2)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.3.4)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.4)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libc.so.6(GLIBC_2.7)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libcom_err.so.2()(64bit)
   provider: libcom_err.x86_64 1.41.14-2.fc15
  dependency: libdl.so.2()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libdl.so.2(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libgcc_s.so.1()(64bit)
   provider: libgcc.x86_64 4.6.3-2.fc16
  dependency: libgcc_s.so.1(GCC_3.0)(64bit)
   provider: libgcc.x86_64 4.6.3-2.fc16
  dependency: libgcc_s.so.1(GCC_3.3.1)(64bit)
   provider: libgcc.x86_64 4.6.3-2.fc16
  dependency: libhesiod.so.0()(64bit)
   provider: hesiod.x86_64 3.1.0-20.fc15
  dependency: libk5crypto.so.3()(64bit)
   provider: krb5-libs.x86_64 1.9.3-2.fc16
  dependency: libkrb5.so.3()(64bit)
   provider: krb5-libs.x86_64 1.9.3-2.fc16
  dependency: libkrb5.so.3(krb5_3_MIT)(64bit)
   provider: krb5-libs.x86_64 1.9.3-2.fc16
  dependency: liblber-2.4.so.2()(64bit)
   provider: openldap.x86_64 2.4.26-7.fc16
  dependency: libldap-2.4.so.2()(64bit)
   provider: openldap.x86_64 2.4.26-7.fc16
  dependency: libm.so.6()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libnsl.so.1()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libnsl.so.1(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libpthread.so.0()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libpthread.so.0(GLIBC_2.3.2)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libresolv.so.2()(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libresolv.so.2(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.14.90-24.fc16.7
  dependency: libsasl2.so.2()(64bit)
   provider: cyrus-sasl-lib.x86_64 2.1.23-27.fc16
  dependency: libtirpc.so.1()(64bit)
   provider: libtirpc.x86_64 0.2.2-1.1.fc16
  dependency: libxml2.so.2()(64bit)
   provider: libxml2.x86_64 2.7.8-6.fc16
  dependency: libxml2.so.2(LIBXML2_2.4.30)(64bit)
   provider: libxml2.x86_64 2.7.8-6.fc16
  dependency: libz.so.1()(64bit)
   provider: zlib.x86_64 1.2.5-6.fc16
  dependency: mktemp
   provider: coreutils.x86_64 8.12-7.fc16
  dependency: module-init-tools
   provider: module-init-tools.x86_64 3.16-5.fc16
  dependency: rtld(GNU_HASH)
   provider: glibc.x86_64 2.14.90-24.fc16.7
   provider: glibc.i686 2.14.90-24.fc16.7
  dependency: sed
   provider: sed.x86_64 4.2.1-7.fc16
  dependency: sh-utils
   provider: coreutils.x86_64 8.12-7.fc16
  dependency: textutils
   provider: coreutils.x86_64 8.12-7.fc16
[root@sirius ~]#
Comment 9 Ian Kent 2012-06-17 22:14:47 EDT
I've done a yum update and the problem has come back for me
also.

However, in runllevel 3 mounts do expire for me.

I'll go through the discovery process again, maybe some other
cause will occur to me during that process.
Comment 10 TAO Zhijiang 2012-07-10 05:10:14 EDT
Hello @IBM
Will you commit the test for this bug?
Comment 11 Ian Kent 2012-08-13 22:24:37 EDT

(In reply to comment #7)
> (In reply to comment #6)
> > Another thing I found was that if I booted into run level 3
> > mounts would expire normally so I concluded it was related
> > to a GUI package. And it was independent of the file system
> > of the mount.
> > 
> 
> I just tried booting into run level 3 and the NFS and CIFS mounts did not
> expire. :(  I guess it's something else in my case.

I finally discovered what was causing this on my system.
For me it's a side effect of systemd making the root file system
shared at boot.

The following assumes you are using systemd.

I don't know if you use anything that relies on the root file
system being marked as shared so take care if you try and test
this.

To check run "mount --make-private /", as root, and check if the
autofs expiry now works. I don't know yet if existing mounts will
then start to expire so do the check from a startup of autofs when
there aren't any automount managed mounts present.

To restore the system run "mount --make-shared /", as root.

Ian
Comment 12 Ian Kent 2012-08-14 03:42:45 EDT
(In reply to comment #11)
> 
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Another thing I found was that if I booted into run level 3
> > > mounts would expire normally so I concluded it was related
> > > to a GUI package. And it was independent of the file system
> > > of the mount.
> > > 
> > 
> > I just tried booting into run level 3 and the NFS and CIFS mounts did not
> > expire. :(  I guess it's something else in my case.
> 
> I finally discovered what was causing this on my system.
> For me it's a side effect of systemd making the root file system
> shared at boot.
> 
> The following assumes you are using systemd.
> 
> I don't know if you use anything that relies on the root file
> system being marked as shared so take care if you try and test
> this.
> 
> To check run "mount --make-private /", as root, and check if the
> autofs expiry now works. I don't know yet if existing mounts will
> then start to expire so do the check from a startup of autofs when
> there aren't any automount managed mounts present.
> 
> To restore the system run "mount --make-shared /", as root.

I see now that it is suffucient to mark the autofs mount point
as private ("mount --make-private <autofs mount point>") to
resolve the expire problem (assuming your problem is the same).
And I also see that marking marking the mount point shared again
doesn't cause the problem to return.
Comment 13 Jerry 2012-08-14 10:57:35 EDT
I upgraded this system to Fedora 17 and unfortunately I can't test this easily at the moment. :(
Comment 14 Fedora End Of Life 2013-01-16 08:54:49 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Fedora End Of Life 2013-02-13 09:50:38 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.