Bug 831304 - Need SELinux Documentation
Need SELinux Documentation
Status: CLOSED DEFERRED
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Divya
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 13:50 EDT by Bryan Bickford
Modified: 2013-12-16 06:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 06:09:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Bickford 2012-06-12 13:50:10 EDT
Description of problem:

There needs to be documentation telling users to run the following command on their brick directory during gluster setup:

semanage fcontext -a -t gluster_brick_t '/PATH/TO/BRICK(/.*)?'
restorecon -R -v /PATH/TO/BRICK

This will properly label their brick for SELinux. Because of the variable nature of the location of the brick directory, this is the best way to accomplish this.

Actual results:
Improper labelling of files in brick.

Expected results:
gluster_brick_t labelled files in brick.
Comment 2 Divya 2012-07-12 06:57:46 EDT
I will update the documentation on SELinux.
Comment 3 Scott Haines 2013-07-24 04:54:33 EDT
Per PM, moving to the backlog.
Comment 4 Anjana Suparna Sriram 2013-12-16 06:09:48 EST
This feature is not factored in any of the on-going releases, hence deferring this bug.

Note You need to log in before you can comment on or make changes to this bug.