Bug 831395 - httpd-devel multilib conflict
httpd-devel multilib conflict
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 18:41 EDT by Philippe Troin
Modified: 2012-06-15 06:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 06:13:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2012-06-12 18:41:17 EDT
# yum install httpd-devel-2.2.22-4.fc17.i686
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package httpd-devel.i686 0:2.2.22-4.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch         Version                  Repository      Size
================================================================================
Installing:
 httpd-devel         i686         2.2.22-4.fc17            fedora         147 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 147 k
Installed size: 527 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /etc/rpm/macros.httpd from install of httpd-devel-2.2.22-4.fc17.i686 conflicts with file from package httpd-devel-2.2.22-4.fc17.x86_64
  file /usr/include/httpd/.mmn from install of httpd-devel-2.2.22-4.fc17.i686 conflicts with file from package httpd-devel-2.2.22-4.fc17.x86_64

Error Summary
-------------

[2]    12081 exit 1     noglob yum install httpd-devel-2.2.22-4.fc17.i686
Comment 1 Joe Orton 2012-06-13 05:26:07 EDT
Yes, these packages conflict.
Comment 2 Philippe Troin 2012-06-14 11:40:16 EDT
From a yum/rpm point of view, they technically don't conflict with each other.
That's why yum happily tries to install them both, and fails.
Maybe this package should be marked as x86_64 only if it cannot be installed?
Comment 3 Joe Orton 2012-06-15 06:13:48 EDT
Good point.  This is a rel-eng issue so we don't need to track it in bugzilla - ticket filed here:

https://fedorahosted.org/rel-eng/ticket/5218

Note You need to log in before you can comment on or make changes to this bug.