Bug 831425 - libvirt-client multilib conflict
libvirt-client multilib conflict
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Krempa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 19:50 EDT by Philippe Troin
Modified: 2012-11-14 21:44 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 21:44:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2012-06-12 19:50:55 EDT
# yum install libvirt-devel
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Package libvirt-devel-0.9.11.3-1.fc17.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libvirt-devel.i686 0:0.9.11.3-1.fc17 will be installed
--> Processing Dependency: libvirt.so.0 for package: libvirt-devel-0.9.11.3-1.fc17.i686
--> Processing Dependency: libvirt-qemu.so.0 for package: libvirt-devel-0.9.11.3-1.fc17.i686
--> Running transaction check
---> Package libvirt-client.i686 0:0.9.11.3-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch        Version                  Repository     Size
================================================================================
Installing:
 libvirt-devel         i686        0.9.11.3-1.fc17          fedora        505 k
Installing for dependencies:
 libvirt-client        i686        0.9.11.3-1.fc17          fedora        3.4 M

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total size: 3.9 M
Installed size: 17 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/systemtap/tapset/libvirt_probes.stp from install of libvirt-client-0.9.11.3-1.fc17.i686 conflicts with file from package libvirt-client-0.9.11.3-1.fc17.x86_64

Error Summary
-------------

[2]    12615 exit 1     noglob yum install libvirt-devel
Comment 1 Daniel Berrange 2012-06-13 03:54:44 EDT
Looks like we need to move the tapset into an arch specific subdir. ie

 /usr/share/systemtap/tapset/x86_64/libvirt_probes.stp
 /usr/share/systemtap/tapset/i386/libvirt_probes.stp
Comment 2 Cole Robinson 2012-10-20 22:51:58 EDT
Patch sent upstream:

https://www.redhat.com/archives/libvir-list/2012-October/msg01122.html
Comment 3 Fedora Update System 2012-10-27 18:15:03 EDT
libvirt-0.9.11.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.7-1.fc17
Comment 4 Fedora Update System 2012-10-29 23:50:39 EDT
Package libvirt-0.9.11.7-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.9.11.7-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17206/libvirt-0.9.11.7-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-11-14 21:44:53 EST
libvirt-0.9.11.7-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.