Bug 831450 - [abrt] evolution-data-server-3.4.2-1.fc17: wait4msg: Process /usr/libexec/evolution-addressbook-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.4.2-1.fc17: wait4msg: Process /usr/libexec/evo...
Status: CLOSED DUPLICATE of bug 814341
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:2f800e85422ba366911683dd1b7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 22:25 EDT by Gabriel
Modified: 2012-06-15 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 10:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel 2012-06-12 22:25:48 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
comment:        Trying to connect to an LDAP server
crash_function: wait4msg
executable:     /usr/libexec/evolution-addressbook-factory
kernel:         3.4.0-1.fc17.x86_64
pid:            1493
pwd:            /
time:           Tue 12 Jun 2012 07:03:28 PM PDT
uid:            1000
username:       gbauman

backtrace:      Text file, 116401 bytes
dso_list:       Text file, 6477 bytes
maps:           Text file, 38161 bytes

build_ids:
:92a26ae19d0be2b5859c8b97e0dce6ff5b7b8b69
:99c23b21038c62b0628b93610fb54c5900c40ffd
:cbb8a8e0998ebc35f3394e942b5bf90d19d90fc5
:4afd03b8d09942cfb183912e59430ae056445499
:b6d75088f555d197be1476cb1c580640826ae029
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275
:f1c5764c91642a33bec2d4ba5adbefc196cc8d60
:07d2432f2cea31e902ec19ecdc72dde8df873864
:091927b7a315243a2ff0383dfca1fd2c665405bf
:fad2d57f73db1d2b51917a93ac42fb4e1308b141
:f393f76f64ec2ddc37f53de2ff1b5a89ac52aaca
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf
:a497cd9ac2be9958779ffb17869baa7062bf4466
:a2d5b50b07df0fb9c52fcc682c6121d3e7276249
:82d958b53396920e0134124256dd8d5f25a0cdc3
:f532ba569c939e0c79fbbc98001c04c19b8b4e9a
:decc9cfb2ab07670df29e06005d9dbcbb1591cad
:a48a153ef63aaf23e1349196f0ca185bcf42397e
:1a262290abc47e43b15d179c909c389831958b90
:31243d0d107bba586a96433c76c87a26db1e826c
:ee7538132f578365c0774ef7dc789d8cba51aff7
:516204cfc31148538d56b21e2f1b945ed50127d4
:4504beabd434c4e335d484b890a6adf1f8d995f6
:10db86ab9481dc0e2bd0f0c4c987e86a8a1d9a8b
:b11d5a1e33c5bda51db5ab08613f3789594adca7
:350920b52e92655cdb258fa5f96fe7004ad07a52
:5e2aa1c7d97cfbc9ae94ec85a2ea6738ce61cba0
:318ff47751c8144098e1808396ab73dd48c1e7b4
:f64b7319b84d426ed547084bdb2577f4f596c18f
:a6a0a700385259f7ea2c4650dcf23e8367a8ef67
:27edf75135cc9114aba2868d3b88d5812e50172f
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:87163e16f54ab421bb34433e983acb30eb0c109f
:57daf604bef735ab18319f0436edd52ce4488a17
:67792c148d2b8f13f6732c9367e926c26d7376c5
:0a4675974e100f890935b4bc8f68203d2daaba55
:cd6934c7ffdc10b4626f8a94336de83eb989545e
:63651cdc0224824a9c9324c77c3b5887378e871d
:835ece100ae7d8bb3c7f990b52f28ecdeb74975e
:4c9c864a7c7b7ed702088955821d58137803462d
:ad0818a36ea58b45bb6646a229105a54f86e25a0
:3d60535f052babb998bae4807bc992c5d15df5c4
:73777e822e00ca152ffca281ab0ace0cb498ec48
:85654856a54c352e8ade3bdff9283eabf8e5b9da
:c028bd4d4e5f5ae122f2300193d9a08f103da6f7
:822e9b3523e8312240f41a25722d539bc77ed436
:8f1c8e7a9290087a1de608de917e41455f885af0
:6ab895952a004df1b695352cbd034f80247cb5a2
:89adc24ad8265d0957719082a6e4f302ff0a9747
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:37347c1c8e4efbf98acb510e94aff8ec0b173c4c
:c8443041d6d93a13912e2279370611765a665ff8
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:5f038f3fb1b1571769e7c9b79e025fe328052950
:4d09d82785dab5f95c01b69bc0785145a5954d30
:7c35310fc506498c612d5d982ab03becc4b4817c
:d789c08e9d240290a0a39e4654150029e152929f
:f4f9ce91c43285df84177f9684a3e7f190a0aae1
:80dcf30321dbc04511d9cbf399a83b8f3dc75d5d
:929d271f51370434d6e9f63b74694fb424470462
:3808935f8105bd124594c36f68e7bf0139198f4e
:d804f8ee47797da9213a92f00cd095ecada8d79f
:44174defe79b7afeae13d84e8fd127af1fd1b939
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202
:365970e3dc0d6323d5b7de1f68bbdfc164ac5907
:e3f83e6ed76d65ff9d0d4aa5fcc7bf0c6bfaaadd
:aaa1236e690a9d2f230ade4b8d4387c22200ba9f
:5dd234206476b0387cd251598aa72a2c95c763c5
:0eeac854ab0b56d18d126ca7056136b4e63abed7
:f2fc77a5bfafe3a46270320891c53cad5cae6b8a
:46eb8c83b266e03b4d2d37c5ac56accdee78c113
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:6bded5b136657f424dbb3a0dc8fe6ee59168d622
:4555444390434459edd5379df593b6d7382f86be
:35b86da23e7052809fba3e3716f78557228b76aa
:2d920fc18d5d62c399484534249b104e12049777
:2473211681cce7ff66190eb4eb2f1ffc974606c1

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/gbauman/2

core_backtrace:
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275 0x10697 ldap_result libldap-2.4.so.2 -
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275 0x19308 ldap_sasl_bind_s libldap-2.4.so.2 -
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275 0x19af0 ldap_simple_bind_s libldap-2.4.so.2 -
:b11d5a1e33c5bda51db5ab08613f3789594adca7 0x19355 - libebookbackendldap.so -
:6ab895952a004df1b695352cbd034f80247cb5a2 0x20f68 - libedata-book-1.2.so.13 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6ab42 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6a345 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-UujecMrDOD,guid=44dbe7ef06e55e9b888329eb00000018
:XDG_RUNTIME_DIR=/run/user/gbauman
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:LC_MEASUREMENT=en_CA.utf8
:SSH_AUTH_SOCK=/run/user/gbauman/keyring-lBvpjf/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1152,unix/unix:/tmp/.ICE-unix/1152
:CLUTTER_VBLANK=true
:LC_MONETARY=en_CA.utf8
:LC_NUMERIC=en_CA.utf8
:LC_TIME=en_CA.utf8
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=gbauman
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/run/user/gbauman/keyring-lBvpjf/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-UujecMrDOD,guid=44dbe7ef06e55e9b888329eb00000018
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-gbauman-O2EyCz/database
:USER=gbauman
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1148
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/
:GNOME_KEYRING_CONTROL=/run/user/gbauman/keyring-lBvpjf
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=gbauman
:HOME=/home/gbauman

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 128010               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       128010               128010               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/dev/null
:2:/dev/null
:3:anon_inode:[eventfd]
:4:/dev/null
:5:anon_inode:[eventfd]
:6:socket:[21205]
:7:socket:[21206]
:8:anon_inode:[eventfd]
:9:/etc/hosts
:10:/home/gbauman/.local/share/evolution/addressbook/system/addressbook.db
:11:/home/gbauman/.local/share/evolution/addressbook/system/log.0000000001
:12:/home/gbauman/.local/share/evolution/addressbook/system/contacts.db
:13:anon_inode:[eventfd]
:14:/dev/urandom
:15:socket:[21961]
:16:socket:[603076]
:17:anon_inode:[eventfd]
:18:socket:[601726]

var_log_messages:
:Jun 12 19:03:28 monolith abrt[27865]: File '/usr/libexec/evolution-addressbook-factory.#prelink#.wS4PNK' seems to be deleted
:Jun 12 19:03:28 monolith abrt[27865]: File '/usr/libexec/evolution-addressbook-factory.#prelink#.wS4PNK' seems to be a prelink temporary file
:Jun 12 19:03:29 monolith abrt[27865]: Saved core dump of pid 1493 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-06-12-19:03:28-1493 (144850944 bytes)
Comment 1 Gabriel 2012-06-12 22:37:24 EDT
Trying to connect to an LDAP server

backtrace_rating: 4
Package: evolution-data-server-3.4.2-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Milan Crha 2012-06-13 05:18:04 EDT
Thanks for a bug report. There is missing the backtrace attachment, unfortunately, but the core bactrace suggests that this happened in sasl binding to LDAP server in openldap library.

Is it possible to connect to the server with ldapsearch command, please? I'm CC'ing openldap maintainer for help on the exact command structure.
Comment 3 Gabriel 2012-06-13 16:50:12 EDT
ldapsearch has no problems when not using SSL.

ldapsearch -h ldap.messagingengine.com -p 389 -D 'cn=me@fastmail.fm,dc=User' -b 'dc=AddressBook' -w 'mypassword' -x 'objectclass=*'

...returns my address book.

However, when using SASL:

ldapsearch -h ldap.messagingengine.com -p 636 -D 'cn=me@fastmail.fm,dc=User' -b 'dc=AddressBook' -w 'mypassword' -x -Z 'objectclass=*' 

ldap_start_tls: Can't contact LDAP server (-1)
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

Maybe I have the command syntax wrong? The LDAP server is up and running fine on port 636.
Comment 4 Jan Vcelak 2012-06-13 18:08:44 EDT
(In reply to comment #3)
> ldapsearch has no problems when not using SSL.
> 
> ldapsearch -h ldap.messagingengine.com -p 389 -D 'cn=me@fastmail.fm,dc=User'
> -b 'dc=AddressBook' -w 'mypassword' -x 'objectclass=*'
> 
> ...returns my address book.
> 
> However, when using SASL:
> 
> ldapsearch -h ldap.messagingengine.com -p 636 -D 'cn=me@fastmail.fm,dc=User'
> -b 'dc=AddressBook' -w 'mypassword' -x -Z 'objectclass=*' 

This is not SASL, you probably mean SSL.

-ZZ can be used to send StartTLS:

LDAPTLS_REQCERT=never ldapsearch -H ldap://ldap.messagingengine.com -D 'cn=me@fastmail.fm,dc=User' -b 'dc=AddressBook' -w 'mypassword' -x -ZZ 'objectclass=*'

Or use ldaps:// if the server listens on tcp/636:

LDAPTLS_REQCERT=never ldapsearch -H ldaps://ldap.messagingengine.com -D 'cn=me@fastmail.fm,dc=User' -b 'dc=AddressBook' -w 'mypassword' -x 'objectclass=*'

But ldaps:// cannot be used together with StartTLS (-ZZ).

The LDAPTLS_REQCERT=never environment variable makes the client ignore unknown certificate issuer or other SSL negotiation errors. If you want to specify CA certificate, set LDAPTLS_CACERT or LDAPTLS_CACERTDIR according to ldap.conf man page.

> ldap_start_tls: Can't contact LDAP server (-1)
> ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)
> Maybe I have the command syntax wrong? The LDAP server is up and running
> fine on port 636.

If something is failing, you can add -d1 (D one) to see more debug info data.
Comment 5 Milan Crha 2012-06-15 10:16:43 EDT
Thanks for the update, I found out (with help of your data) an issue with locking in the LDAP backend in evolution, which causes this crash. I'm moving this to upstream, through a similar bug report from Fedora.

*** This bug has been marked as a duplicate of bug 814341 ***

Note You need to log in before you can comment on or make changes to this bug.