Bug 831535 - Speedlink Black Widow USB joystick does not work
Speedlink Black Widow USB joystick does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 05:10 EDT by Dominik Pospisil
Modified: 2012-06-21 20:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 03:08:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsusb (54.17 KB, text/plain)
2012-06-19 03:42 EDT, Dominik Pospisil
no flags Details

  None (edit)
Description Dominik Pospisil 2012-06-13 05:10:36 EDT
Description of problem:
Speedlink Black Widow USB joystick does not work. This is a regression, it used to work in F16.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Plug-in joystick
  
Actual results:
No associted input device created.

Expected results:
Input devices created.

Additional info:

Jun 13 10:04:14 localhost kernel: [ 6226.765035] usb 1-1.5.1: new low-speed USB device number 8 using ehci_hcd
Jun 13 10:04:14 localhost kernel: [ 6226.860269] usb 1-1.5.1: New USB device found, idVendor=07b5, idProduct=0317
Jun 13 10:04:14 localhost kernel: [ 6226.860279] usb 1-1.5.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jun 13 10:04:14 localhost kernel: [ 6226.860285] usb 1-1.5.1: Product: USB Game Controllers
Jun 13 10:04:14 localhost kernel: [ 6226.860290] usb 1-1.5.1: Manufacturer: Mega World
Jun 13 10:04:14 localhost kernel: [ 6226.868478] input: Mega World USB Game Controllers as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1/1-1.5.1:1.0/input/input19
Jun 13 10:04:14 localhost kernel: [ 6226.868950] generic-usb 0003:07B5:0317.0004: input,hidraw0: USB HID v1.10 Joystick [Mega World USB Game Controllers] on usb-0000:00:1a.0-1.5.1/input0
Jun 13 10:04:14 localhost mtp-probe: checking bus 1, device 8: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1"
Jun 13 10:04:14 localhost mtp-probe: bus: 1, device: 8 was not an MTP device
Comment 1 Linus Walleij 2012-06-14 17:36:47 EDT
Can you please provide lsusb -v for this device so I can see if I can avoid probing it from libmtp?
Comment 2 Dominik Pospisil 2012-06-15 03:08:21 EDT
I found out that this was caused by missing joydev module which is now in kernel-modules-extra package which is not installed by default.
Comment 3 Linus Walleij 2012-06-19 02:35:27 EDT
But I shouldn't be probing this device anyway, so lsusb -v would still be appreciated...
Comment 4 Dominik Pospisil 2012-06-19 03:42:18 EDT
Created attachment 592854 [details]
lsusb

Sure, adding lsusb -v output.
Comment 5 Linus Walleij 2012-06-21 20:20:50 EDT
Thanks! I'll study this..

Note You need to log in before you can comment on or make changes to this bug.