Bug 831548 - g++ 4.7 and armadilo 3.2.2: operator() is inaccessible
g++ 4.7 and armadilo 3.2.2: operator() is inaccessible
Status: CLOSED DUPLICATE of bug 831550
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 05:39 EDT by C Sand
Modified: 2012-06-13 05:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 05:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
arma.ii.gz (273.44 KB, application/x-gzip)
2012-06-13 05:39 EDT, C Sand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 53549 None None None Never

  None (edit)
Description C Sand 2012-06-13 05:39:38 EDT
Created attachment 591418 [details]
arma.ii.gz

Description of problem:
g++ refuses to compile seemingly valid C++ code from Armadillo library

Version-Release number of selected component (if applicable):
gcc version 4.7.0 20120507 (Red Hat 4.7.0-5)

How reproducible:
use g++ to compile code using "ivec3" class from Armadillo

Steps to Reproduce:
1. install Armadillo 3.2.2 from http://arma.sourceforge.net/download.html
2. try to compile code using "ivec3" class from Armadillo
3. look bewildered

Actual results:
refuses to compile, stating that various forms of operator() are inaccessible.

Expected results:
should compile; known to compile with gcc 4.4.6 (RHEL 6.2).
also known to compile with clang 3.0

Additional info:
See attached file, "arma.ii.gz", generated using
g++ -v -save-temps -O2 -o arma arma.cpp


Upstream GCC bug:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53549


Code that fails to compile:

#include <iostream>
#include "armadillo"

using namespace arma;
using namespace std;

int main(int argc, char** argv)
  {
  cout << "Armadillo version: " << arma_version::as_string() << endl;
  
  ivec3 x;
  x.ones();
  x.print("x:");
  
  return 0;
  }
Comment 1 C Sand 2012-06-13 05:45:48 EDT

*** This bug has been marked as a duplicate of bug 831550 ***

Note You need to log in before you can comment on or make changes to this bug.