Bug 831587 - Ticket Monster: Second deletion of booking doesn't work
Ticket Monster: Second deletion of booking doesn't work
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.0.0.ER7
Unspecified Unspecified
medium Severity low
: CR1
: 2.1.0
Assigned To: Marius Bogoevici
Karel Piwko
ticket-monster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 07:27 EDT by Tomas Repel
Modified: 2013-02-01 10:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:35:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JDF-117 Major Resolved Second delection of booking does not work 2013-06-28 03:38:32 EDT

  None (edit)
Description Tomas Repel 2012-06-13 07:27:39 EDT
Description of problem:

If there are two or more bookings already done and you try to delete one after another, the second deletion fails.

Version-Release number of selected component (if applicable):

WFK2 ER8
EAP6 CR1
FF 10.0.3 or Google Chrome 17.0

How reproducible:

Always.

Steps to Reproduce:
1. package and deploy Ticket Monster example
2. create at least two bookings
3. click on Bookings menu item
4. click on 'tray' icon to delete one booking
5. click on 'tray' icon to delete another booking
  
Actual results:

Nothing happens, the deletion of booking is not triggered.

Expected results:

The booking should be deleted.
Comment 1 Vaclav Dedik 2012-10-11 07:44:13 EDT
This bug is still present in ticket-monster 2.0.0.M3. The booking is deleted, though, the problem is that the list of bookings is not refreshed when two consecutive deletion take place.
Comment 3 Marek Novotny 2012-10-24 04:32:37 EDT
the fix back ported from JDF TicketMonster - http://git.app.eng.bos.redhat.com/?p=wfk/ticket-monster.git;a=commitdiff;h=f8e97fe5648fa6d9119db801f0018ec337179585
Comment 5 Tomas Repel 2012-11-07 11:08:19 EST
Verified in WFK 2.1.0.CR1.
Comment 6 Karel Piwko 2012-11-30 10:35:11 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.