Bug 831619 - Inaccuracy in Fedora 17 “Power Management Guide”
Inaccuracy in Fedora 17 “Power Management Guide”
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: power-management-guide (Show other bugs)
devel
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Yoana Ruseva
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 08:59 EDT by Vasil Draganov
Modified: 2013-11-12 04:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 04:53:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The problem description in .pdf format - easy to follow (32.09 KB, application/pdf)
2012-06-13 08:59 EDT, Vasil Draganov
no flags Details

  None (edit)
Description Vasil Draganov 2012-06-13 08:59:53 EDT
Created attachment 591487 [details]
The problem description in .pdf format - easy to follow

Hi,
  First I want to notice I am a Linux newbie and my English is not that good.

  Now straight to the point! (The same description is available in the attached pdf file and is more easy to follow)
  
  I've noticed some inaccuracy in Fedora 17 “Power Management Guide” (Fedora Documentation), particularly in section “2.5. Tuned and ktune” including “2.5.1. The tuned.conf file” and “2.5.2 Tuned-adm”.

  In section “2.5. Tuned and ktune” right bellow the “yum install tuned” command it's written:

“Installing the tuned package also sets up a sample configuration file at /etc/tuned.conf and activates the default profile.” 
There is no such file in /etc. I found a /etc/tuned/active_profile file containing the following: “/usr/lib/tuned/balanced/tuned.conf”. I'm not sure this file (/etc/tuned.conf) is missing only on my system or it has a new location by default for each profile - /usr/lib/tuned/profileX/tuned.conf.
Bellow in this section and in  “2.5.1. The tuned.conf file” it is pointed again that the default location for the tuned.conf file is /etc/tuned.conf.

In section “2.5.2 Tuned-adm” in the first paragraph it is written “Fedora 17 includes a number of predefined profiles for typical use cases...”. Just to be precise it is good to be mentioned that these profiles are not installed by default with “yum install tuned” command (tuned-2.0.1-1.fc17 package), but can be found in tuned-profile-compat-2.0.1-1.fc17 package (I found it in Gnome Package Manager). 
Another thing in this section is in the last third of the page where it is written:
“All the profiles are stored in separate subdirectories under /etc/tune-profiles. So /etc/tune-profiles/desktop-powersave contains all the necessary files and settings for that profile. Each of these directories contains up to four files:”
There /etc/tune-profiles directory does not exist. Instead I found the profiles stored in /run/lib/tuned.
Each directory for the corresponding profile typically contains only 2 files - script.sh and tuned.conf. The presence of script.sh is not mentioned in the directories contains description – it is mentioned ktune.sh insetad.  


That's all. I hope this is helpful.

Best regards

Vasil Draganov

Fedora 17   3.4.0-1.fc17.x86_64

P.S. “Power Management Guide” is great. It's really useful. The moment i run tuned service i noticed how quieter my laptop became (less heat – less fan needed :) ). The first thing I noticed about new Fedora installation was that the laptop was noisier in comparison to Win7 (I dual-boot with Win7). Tuned just fixed that :)
Many thanks to the creators of Fedora Documentation!!!
Comment 1 Jack Reed 2012-11-01 01:17:28 EDT
Hi Vasil,

Thanks for reporting these issues with the tuned documentation and for your praise of the PMG. Much appreciated. :)

I'll respond point by point, and consult Jaroslav Skarvada for technical assistance on a few of them.

>   In section “2.5. Tuned and ktune” right bellow the “yum install tuned”
> command it's written:
> 
> “Installing the tuned package also sets up a sample configuration file at
> /etc/tuned.conf and activates the default profile.” 
> There is no such file in /etc. I found a /etc/tuned/active_profile file
> containing the following: “/usr/lib/tuned/balanced/tuned.conf”. I'm not sure
> this file (/etc/tuned.conf) is missing only on my system or it has a new
> location by default for each profile - /usr/lib/tuned/profileX/tuned.conf.
> Bellow in this section and in  “2.5.1. The tuned.conf file” it is pointed
> again that the default location for the tuned.conf file is /etc/tuned.conf.

The current man page for tuned.conf says "Profile is stored in /etc/tuned/<profile_name>/tuned.conf or in /usr/lib/tuned/<profile_name>/tuned.conf file where the  /etc/tuned/  directory has higher priority."

On my machine, tuned.conf is in /usr/lib/... . 

Jaroslav, what does "where the  /etc/tuned/  directory has higher priority" mean? Does this mean both paths will need to be documented? That's fine, but I would like a better idea of why there are two paths, because that wording is unclear.


> In section “2.5.2 Tuned-adm” in the first paragraph it is written “Fedora 17
> includes a number of predefined profiles for typical use cases...”. Just to
> be precise it is good to be mentioned that these profiles are not installed
> by default with “yum install tuned” command (tuned-2.0.1-1.fc17 package),
> but can be found in tuned-profile-compat-2.0.1-1.fc17 package (I found it in
> Gnome Package Manager). 

No problem, Vasil. I will list which profiles are available in which package, and document the new ones.


> Another thing in this section is in the last third of the page where it is
> written:
> “All the profiles are stored in separate subdirectories under
> /etc/tune-profiles. So /etc/tune-profiles/desktop-powersave contains all the
> necessary files and settings for that profile. Each of these directories
> contains up to four files:”
> There /etc/tune-profiles directory does not exist. Instead I found the
> profiles stored in /run/lib/tuned.
> Each directory for the corresponding profile typically contains only 2 files
> - script.sh and tuned.conf. The presence of script.sh is not mentioned in
> the directories contains description – it is mentioned ktune.sh insetad.

Jaroslav, I've confirmed this on my own machine. (See the end of section 2.5.2.) 

Has script.sh replaced ktune.sh? If not, can you describe this file's purpose? 

And will sysctl.ktune and ktune.sysconfig never be present and no longer need to be documented?


Also, Jaroslav, I'm trying to update the documentation of tuned.conf (section 2.5.1). The man page suggests that the options available for the [main] and plugin sections have changed.

For [main], the man page only lists include= . For plugins, the man page lists:
- type=
- devices=
- replace=1

Currently the PMG lists the following for [main]: interval, verbose, logging, and logging_disable.

For plugins, it lists: enabled, verbose, and logging

My question is, are the options the PMG currently lists still available and have just been joined by those in the man page? Or have they been deprecated?

My tuned.conf files are fairly minimal so I can't tell if any of these options remain available.

Thanks in advance.
Comment 2 Jaroslav Škarvada 2012-11-05 18:30:24 EST
Hi Jack and Vasil,

thanks for reporting this. The tuned-2.X is complete rewrite of original tuned that brings many new features. There are many changes and we will need to modify/extend the tuned section in the guides. The tuned-2.0 is there since F17. In F18 there is (will be) tuned-2.1 (actually AFAIK there is tuned-2.0.2 in F18, but it's practically 2.1 codebase and it will be renamed to 2.1 very soon).

Currently I am @ LinuxCon and the drafting of the new tuned section will take some time. I will take a look and respond later, feel free to ping me in approx. 2 weeks.
Comment 3 Jack Reed 2012-11-07 01:18:32 EST
Thanks Jaroslav - no problem.

I've already made some changes to tuned, adding the new profiles as described in the tuned-adm man page.

You can check them out if need be at http://git.fedorahosted.org/cgit/docs/power-management-guide.git/commit/?id=4fee5984bacb51835b21d6ccf8af0d12ab163cb9
Comment 4 Jack Reed 2013-03-18 00:39:09 EDT
Quoted from related bug 833291, directed to Jaroslav Škarvada, reproduced here for tracking purposes:

"Since documentation for the overhauled tuned still needs to be added to the Fedora Power Management Guide, are you able to send that to me soon so I can get a headstart on incorporating it for F19? Would this be possible by the end of April?"
Comment 6 Jaroslav Škarvada 2013-07-04 07:53:03 EDT
This will be resolved in the F19 Power Management Guide, the draft is available here:
https://git.fedorahosted.org/cgit/docs/power-management-guide.git/tree/?h=private-jskarvad-f19

For F17 it is probably too late now, but the guide could be merged to F18 - the tuned and powertop packages are the same as in F19 (i.e. the latest versions). Petr, what do you think?
Comment 7 Jaromir Hradilek 2013-07-04 16:16:47 EDT
Thank you very much for your draft, Jaroslav. I already started working on it and I will publish the Fedora 19 version later this week.
Comment 8 Jaroslav Škarvada 2013-11-12 04:53:36 EST
I think this is resolved in F19 and up, thus closing. Feel free to reopen if the problem persists.
Comment 9 Jaroslav Škarvada 2013-11-12 04:54:22 EST
Changing the resolution to current release, because this bug was no more filled against f17, but devel.

Note You need to log in before you can comment on or make changes to this bug.