Bug 831624 - Alt + F4 key at SLA selection window should terminate Registration process.
Alt + F4 key at SLA selection window should terminate Registration process.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: beta
: 7.0
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-06-13 09:04 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-17 13:30:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-06-13 09:04:39 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites:
Rhel5.9 with following rpm.
subscription-manager-gui-1.0.3-1.git.30.db0f648.el5
subscription-manager-migration-1.0.3-1.git.30.db0f648.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-firstboot-1.0.3-1.git.30.db0f648.el5
subscription-manager-1.0.3-1.git.30.db0f648.el5

Steps to Repro : 
1) launch subscription-manager-gui.
2) Register client to candlepin using autosubscribe  option with 37060.pem and 88888.pem product cert.
3) At SlA selection Window , close window using alt + f4 key .

Expected Result : 
Alt + F4 key at SLA selection window should terminate Registration process

Actual Result : 
Registration process got successfully completed.
Comment 4 Alex Wood 2013-01-17 13:30:48 EST
Enabling Alt+F4 can be done by setting the deletable property (under the General tab in Glade) for the dialog to true.  However, we don't actually want to do that because making the window deletable would allow users to close the window during the registration and auto-bind portions of the flow.  Closing the window during those portions would cause the registration or auto-bind to continue in the background and would confuse the user since the processes would complete despite the user believing he had canceled.

Note You need to log in before you can comment on or make changes to this bug.