Bug 831638 - thin_check not found
thin_check not found
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.0
All Linux
high Severity high
: beta
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 09:42 EDT by Xiaowei Li
Modified: 2012-10-19 06:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.97-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 06:22:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-06-13 09:42:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.#lvchange -ay vg/thin_pool
2.
3.
  
Actual results:
#libdm-deptree.c:2362     Suppressed tsvg-pool2_tdata identical table reload.
#libdm-config.c:767       global/thin_check_executable not found in config: defaulting to /sbin/thin_check -q
#misc/lvm-exec.c:65     Executing: /sbin/thin_check -q /dev/mapper/tsvg-pool2_tmeta
#locking/file_locking.c:51         _undo_flock /var/lock/lvm/V_tsvg
#mm/memlock.c:462         memlock reset.
#device/dev-io.c:577         Closed /dev/loop1
#device/dev-io.c:577         Closed /dev/loop2
#device/dev-io.c:577         Closed /dev/loop3
#device/dev-io.c:577         Closed /dev/loop0
#misc/lvm-exec.c:80   /sbin/thin_check: execvp failed: No such file or directory
#misc/lvm-exec.c:99     /sbin/thin_check failed: 2



Expected results:


Additional info:
Comment 1 Xiaowei Li 2012-06-13 09:47:10 EDT
lvm2-2.02.95-6.el7.x86_64
Comment 2 Xiaowei Li 2012-06-13 09:49:22 EDT
where can I get the thin_check and thin_dump?
Comment 3 Zdenek Kabelac 2012-06-13 09:51:35 EDT
lvm2 currently does not have dependency on

device-mapper-persistent-data

which must be installed separately

Since not all users are going to use thin - dependency here is tricky - we need to came with some better solution - i.e. check before  lvcreate if tools are avaialble)
Comment 6 Alasdair Kergon 2012-06-13 10:19:07 EDT
We'll have a dependency when this becomes supported, but not while it's tech preview (as we shouldn't install a pure tech preview package for everyone by default).
Comment 7 Xiaowei Li 2012-06-13 10:31:49 EDT
Thanks all for the clarification.

I am putting thin_check_executable = "" to the global{} in lvm.conf to skip this check.
Comment 8 Bill Nottingham 2012-06-13 14:14:52 EDT
Is it expected to be TP still in RHEL 7 GA?
Comment 9 Mike Snitzer 2012-06-13 15:09:08 EDT
(In reply to comment #8)
> Is it expected to be TP still in RHEL 7 GA?

No, should be fully supported.
Comment 10 Bill Nottingham 2012-06-13 16:41:09 EDT
In that case, I don't see any reason not to add the dep in the RHEL 7 packages.
Comment 12 Peter Rajnoha 2012-10-19 06:22:16 EDT
lvm2 build that requires device-mapper-persistent-data has already been automatically imported from Fedora to RHEL7 as lvm2-2.02.97-1.el7.

Note You need to log in before you can comment on or make changes to this bug.