Bug 831664 - Repository sync failures not displaying detailed error in Notices
Repository sync failures not displaying detailed error in Notices
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:31 EDT by Og Maciel
Modified: 2015-05-04 21:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A checksum mismatch for certain items while syncing a repository left these items improperly synced. The page where synchronization takes place showed a generic "sync error" message but the Notices item stated that the sync process was successful. This fix matches the Notices page to the status on the sync page and displays the correct error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:21:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-06-13 10:31:48 EDT
Description of problem:

While syncing a RHEL 6Server repository (dist/rhel/server/6/6Server/x86_64) there was a checksum mismatch and certains items were not properly synced. The page where synchronizations take place showed a generic "sync error" message but the Notices item stated that the sync process was successful.

Version-Release number of selected component (if applicable):

* candlepin-0.6.5-1.el6_2.noarch
* candlepin-tomcat6-0.6.5-1.el6_2.noarch
* katello-0.1.313-1.el6_3.noarch
* katello-all-0.1.313-1.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.7-1.el6_3.noarch
* katello-cli-0.1.108-1.el6_3.noarch
* katello-cli-common-0.1.108-1.el6_3.noarch
* katello-common-0.1.313-1.el6_3.noarch
* katello-configure-0.1.109-1.el6_3.noarch
* katello-glue-candlepin-0.1.313-1.el6_3.noarch
* katello-glue-foreman-0.1.313-1.el6_3.noarch
* katello-glue-pulp-0.1.313-1.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.10-1.el6.noarch
* pulp-1.0.4-1.el6.noarch
* pulp-admin-1.0.4-1.el6.noarch
* pulp-client-lib-1.0.4-1.el6.noarch
* pulp-common-1.0.4-1.el6.noarch
* pulp-selinux-server-1.0.4-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. Add the following repository to an existing product: http://inecas.fedorapeople.org/fakerepos
2. Synchronize it
3. 
  
Actual results:

The Synchronization page should show a generic "sync error" message but the Notices page says that the sync was successful

Expected results:

Notices page should match the status of the Synch page and display what the actual errors are

Additional info:
Comment 1 Petr Chalupa 2012-08-31 03:28:36 EDT
fixed in c9c30e629048fd9a9fce7b838b9f832837437e4f
Comment 3 Og Maciel 2012-09-21 16:43:10 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-7.el6cf.noarch
* katello-all-1.1.12-7.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-4.el6cf.noarch
* katello-cli-common-1.1.8-4.el6cf.noarch
* katello-common-1.1.12-7.el6cf.noarch
* katello-configure-1.1.9-3.el6cf.noarch
* katello-glue-candlepin-1.1.12-7.el6cf.noarch
* katello-glue-pulp-1.1.12-7.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 4 Mike McCune 2012-10-24 10:21:58 EDT
closing, currentrelease since these seemingly got missed in the 1.0.1 errata

Note You need to log in before you can comment on or make changes to this bug.