Bug 831672 - Incomaptible versions of rubygem-cucumber and rubygem-cucumber-rails in F17 repos
Incomaptible versions of rubygem-cucumber and rubygem-cucumber-rails in F17 r...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-cucumber-rails (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:42 EDT by Imre Farkas
Modified: 2016-09-20 01:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:16:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Imre Farkas 2012-06-13 10:42:46 EDT
Description of problem:
Cucumber fails to start in rails applications if used in conjunction with cucumber-rails due to incompatible dependencies.

It would be great if cucumber-rails would be updated to version 1.3.0

Version-Release number of selected component (if applicable):
$ rpm -qa | grep cucumber
rubygem-cucumber-1.1.9-1.fc17.noarch
rubygem-cucumber-rails-1.0.2-9.fc17.noarch

How reproducible:
Install both rpms and running cucumber in any rails app will output:
$ cucumber
Using the default profile...
Unable to activate cucumber-rails-1.0.2, because cucumber-1.1.9 conflicts with cucumber (~> 1.0.0) (Gem::LoadError)
/usr/share/rubygems/rubygems/specification.rb:1655:in `raise_if_conflicts'
/usr/share/rubygems/rubygems/specification.rb:746:in `activate'
/usr/share/rubygems/rubygems.rb:212:in `rescue in try_activate'
/usr/share/rubygems/rubygems.rb:209:in `try_activate'
...

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vít Ondruch 2012-07-27 02:58:11 EDT
So this is actually rubygem-cucumber-rails issue => assign to correct component.
Comment 2 Fedora Update System 2012-07-27 05:40:18 EDT
rubygem-cucumber-rails-1.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-cucumber-rails-1.3.0-1.fc17
Comment 3 Fedora Update System 2012-07-27 21:19:01 EDT
Package rubygem-cucumber-rails-1.3.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-cucumber-rails-1.3.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11194/rubygem-cucumber-rails-1.3.0-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-08-09 19:16:57 EDT
rubygem-cucumber-rails-1.3.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.