Bug 831687 - Warning symbol displayed in flash message when it shouldn't be
Warning symbol displayed in flash message when it shouldn't be
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jozef Zigmund
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:54 EDT by Justin Clift
Modified: 2015-07-13 00:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Successful application creation displayed a flash message with a warning symbol followed by a blank warning. This bug fix checks if the warnings array is empty before rendering the flash message. The warning symbol no longer displays if there are no warnings.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing incorrect flash message. (172.82 KB, image/png)
2012-06-13 10:54 EDT, Justin Clift
no flags Details
Screenshot showing incorrect flash message still happening. (161.67 KB, image/png)
2012-07-24 11:08 EDT, Justin Clift
no flags Details
blueprint_added (90.89 KB, image/png)
2012-09-17 09:49 EDT, pushpesh sharma
no flags Details

  None (edit)
Description Justin Clift 2012-06-13 10:54:35 EDT
Created attachment 591534 [details]
Screenshot showing incorrect flash message.

Description of problem:

  Upon creation of a deployable through the Conductor web interface, the "success" flash message is displayed... however, it also contains an out of place "warning" symbol.  (screenshot attached)


Version-Release number of selected component (if applicable):

  $ rpm -qa|grep -i aeolus|sort
  aeolus-all-0.10.1-1.fc16.noarch
  aeolus-conductor-0.10.1-1.fc16.noarch
  aeolus-conductor-daemons-0.10.1-1.fc16.noarch
  aeolus-conductor-devel-0.10.1-1.fc16.noarch
  aeolus-conductor-doc-0.10.1-1.fc16.noarch
  aeolus-configure-2.6.0-1.fc16.noarch
  rubygem-aeolus-cli-0.5.0-1.fc16.noarch
  rubygem-aeolus-image-0.5.0-1.fc16.noarch


How reproducible:

  Every time, regardless of catalog.


Steps to Reproduce:

  1. Create an image in Conductor, build and push it.
  2. Go through the "New Deployable from Image" process, to create the deployable.
  3. The bug occurs in the flash message at the end of this process.
  
Actual results:

  Incorrect flash message displayed. (as per screenshot)


Expected results:

  No warning icon to be displayed.


Additional info:
Comment 1 Justin Clift 2012-06-13 11:07:59 EDT
Forgot to say, this is for upstream 0.10.0-1 release rpms, not the CE product rpms.
Comment 2 Justin Clift 2012-07-16 04:41:39 EDT
Raising priority of this, as it breaks screencasting.
Comment 3 Jozef Zigmund 2012-07-24 05:08:20 EDT
Fixing patch was pushed to the master branch with commit # ca1d9e185e80fc894093a514ba25c185d413bdc6 please verify it.
Comment 4 Justin Clift 2012-07-24 11:08:35 EDT
Created attachment 600053 [details]
Screenshot showing incorrect flash message still happening.

In testing, the patch helps, but doesn't fix everything. :(

The incorrect flash warning has been removed from some pages, but not from all of them.

It's still appearing on (at least) the launch page for multi-instance deployments.

Screenshot attached.
Comment 5 Justin Clift 2012-07-24 12:37:14 EDT
The updated patch on list here works well too:

  https://fedorahosted.org/pipermail/aeolus-devel/2012-July/011566.html

Thanks. :)
Comment 8 pushpesh sharma 2012-09-17 09:48:43 EDT
Verified on:-

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
[root@dhcp201-113 ~]# 


No such Flash message/icon observed.
Comment 9 pushpesh sharma 2012-09-17 09:49:09 EDT
Created attachment 613664 [details]
blueprint_added
Comment 11 errata-xmlrpc 2012-12-04 10:10:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.