Bug 831700 - Seam2.3 remoting/gwt example gwt-web.war missing gwt-generated files
Seam2.3 remoting/gwt example gwt-web.war missing gwt-generated files
Status: CLOSED DEFERRED
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.0.0.ER8
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 11:38 EDT by Marek Schmidt
Modified: 2012-06-19 04:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 04:18:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-06-13 11:38:32 EDT
Description of problem:

The gwt Seam2.3 example is broken in jboss-seam-2.3.0.Beta2-redhat-1, as the generated GWT files are not copied into the gwt-web.war module.

The problem seems to be that the gwt-web build tries to copy the files from non existing

${basedir}/../gwt-ejb/target/gwt-ejb/org.jboss.seam.example.remoting.gwt.HelloWorld

while the files are in

${basedir}/../gwt-ejb-2.3.0.Beta2-redhat-1/target/gwt-ejb/org.jboss.seam.example.remoting.gwt.HelloWorld

Note You need to log in before you can comment on or make changes to this bug.