Bug 831701 - end of IPA mod_wsgi request causing core dump
end of IPA mod_wsgi request causing core dump
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mod_wsgi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 11:39 EDT by Rob Crittenden
Modified: 2012-11-23 02:30 EST (History)
5 users (show)

See Also:
Fixed In Version: mod_wsgi-3.3-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:30:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2012-06-13 11:39:09 EDT
Description of problem:

IPA built from master branch installed in F-18/rawhide.

At the end of every request the Apache process is dropping core:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f6cd39bd700 (LWP 21281)]
0x00007f6cf5f2d047 in update_child_status_internal (child_num=-1, 
    thread_num=0, status=8, c=0x0, r=0x0) at scoreboard.c:460
460         ws = &ap_scoreboard_image->servers[child_num][thread_num];
Missing separate debuginfos, use: debuginfo-install cyrus-sasl-gssapi-2.1.23-32.fc18.x86_64 cyrus-sasl-md5-2.1.23-32.fc18.x86_64
(gdb) where
#0  0x00007f6cf5f2d047 in update_child_status_internal (child_num=-1, 
    thread_num=0, status=8, c=0x0, r=0x0) at scoreboard.c:460
#1  0x00007f6cf5f4d4ab in ap_start_lingering_close (c=c@entry=0x7f6cf8214e00)
    at connection.c:106
#2  0x00007f6cf5f4d531 in ap_lingering_close (c=c@entry=0x7f6cf8214e00)
    at connection.c:147
#3  0x00007f6ce74c4c34 in wsgi_process_socket (bucket_alloc=<optimized out>, 
    sock=<optimized out>, p=<optimized out>, daemon=<optimized out>)
    at mod_wsgi.c:10149
#4  wsgi_daemon_worker (thread=0x7f6cf80a6560, p=0x7f6cf8212a38)
    at mod_wsgi.c:10470
#5  wsgi_daemon_thread (thd=0x7f6cf80a6640, data=0x7f6cf80a6560)
    at mod_wsgi.c:10503
#6  0x00007f6cf49e4ef5 in start_thread (arg=0x7f6cd39bd700)
    at pthread_create.c:308
#7  0x00007f6cf450ee4d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Version-Release number of selected component (if applicable):

httpd-2.4.2-18.fc18.x86_64
mod_wsgi-3.3-5.fc18.x86_64
mod_auth_kerb-5.4-16.fc18.x86_64

How reproducible:

Every time

Steps to Reproduce:
Complex. I can add steps to get IPA installed if needed. Right now there are several other bugs in other packages preventing easy install.
Comment 1 Joe Orton 2012-06-13 11:52:53 EDT
Could you try -6, just committed?  It looks like mod_wsgi is destroying the scoreboard which is probably wrong.
Comment 3 Rob Crittenden 2012-06-13 12:21:12 EDT
Seeing the same stack trace with -6.
Comment 4 Rob Crittenden 2012-10-11 11:18:17 EDT
I'm now seeing this on Fedora 18 as well.
Comment 5 Fedora Update System 2012-10-16 10:06:33 EDT
mod_wsgi-3.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-1.fc18
Comment 6 Rob Crittenden 2012-10-16 13:37:17 EDT
With mod_wsgi 3.4-1.fc18.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ff13786c700 (LWP 26902)]
0x00007ff1631eb037 in update_child_status_internal (child_num=-1, 
    thread_num=0, status=8, c=0x0, r=0x0) at scoreboard.c:460
460         ws = &ap_scoreboard_image->servers[child_num][thread_num];
(gdb) where
#0  0x00007ff1631eb037 in update_child_status_internal (child_num=-1, 
    thread_num=0, status=8, c=0x0, r=0x0) at scoreboard.c:460
#1  0x00007ff16320b49b in ap_start_lingering_close (c=c@entry=0x7ff164376f70)
    at connection.c:106
#2  0x00007ff16320b521 in ap_lingering_close (c=0x7ff164376f70)
    at connection.c:147
#3  0x00007ff152512e54 in wsgi_daemon_thread ()
   from /etc/httpd/modules/mod_wsgi.so
#4  0x00007ff161ca3d15 in start_thread (arg=0x7ff13786c700)
    at pthread_create.c:308
#5  0x00007ff1617d22cd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114
Comment 7 Fedora Update System 2012-10-16 13:42:04 EDT
Package mod_wsgi-3.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mod_wsgi-3.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16222/mod_wsgi-3.4-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-10-17 03:26:56 EDT
mod_wsgi-3.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-2.fc18
Comment 9 Fedora Update System 2012-11-14 02:28:18 EST
mod_wsgi-3.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-4.fc18
Comment 10 Fedora Update System 2012-11-23 02:30:38 EST
mod_wsgi-3.4-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.