Bug 831712 - Adding a BPEL process file to a BPEL project always warns that "the selected location is not a BPEL project" (non-fatal warning message)
Adding a BPEL process file to a BPEL project always warns that "the selected ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity high
: CR2
: 5.3.0 GA
Assigned To: Robert (Bob) Brodt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 12:00 EDT by Len DiMaggio
Modified: 2012-07-16 15:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When a user attempted to add a BPEL process file to a BPEL project, an error would occur. A non-fatal warning message would be displayed reading "the selected location is not a BPEL project". This problem has now been patched. As a result, the error no longer occurs wen adding the process.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 15:45:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshots (1.79 MB, application/zip)
2012-06-21 23:55 EDT, Len DiMaggio
no flags Details
Screenshot of the - no longer present - bug (222.01 KB, image/png)
2012-07-16 15:43 EDT, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBDS-2209 Blocker Resolved Adding a BPEL process file to a BPEL project always warns that "the selected location is not a BPEL project" (non-fatal... 2015-09-02 10:45:24 EDT

  None (edit)
Description Len DiMaggio 2012-06-13 12:00:31 EDT
Description of problem:

Line to: JBDS-2209

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2012-06-13 12:12:08 EDT
Link to: JBDS-2209
Comment 2 JBoss JIRA Server 2012-06-20 04:54:25 EDT
Douglas Palmer <dpalmer@redhat.com> updated the status of jira JBDS-2209 to Resolved
Comment 3 JBoss JIRA Server 2012-06-20 04:54:25 EDT
Douglas Palmer <dpalmer@redhat.com> made a comment on jira JBDS-2209

Fixed in org.eclipse.bpel and incorporated into the CR1 build.
Comment 4 Len DiMaggio 2012-06-21 13:29:13 EDT
Still a bug here:

http://www.qa.jboss.com/binaries/RHDS/updates/development/5.0.0.CR1.soa-tooling/

Version: 5.0.0.GA
Build id: v20120615-1714-H213-GA
Build date: 20120615-1714
Comment 5 JBoss JIRA Server 2012-06-21 13:30:43 EDT
Len DiMaggio <ldimaggi@redhat.com> updated the status of jira JBDS-2209 to Reopened
Comment 6 JBoss JIRA Server 2012-06-21 14:09:46 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBDS-2209

Right. It looks like the most recent bpel bits haven't been pulled in to this build. The org.eclipse.bpel features are still from 5/18/2012.
Comment 7 JBoss JIRA Server 2012-06-21 15:58:53 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBDS-2209

Sorry, my mistake - was looking at the wrong build.

I'm able to repro this, but only the first time after the first BPEL project is created. If the project is closed and reopened, the problem goes away for that project. If the workbench is restarted, the problem goes away permanently. This may be a bug in the project facet plugins somewhere...investigating.
Comment 8 Douglas Palmer 2012-06-21 16:13:37 EDT
It doesn't go away permanently. Creating a new workspace brings it back.
Comment 9 Len DiMaggio 2012-06-21 23:55:50 EDT
Created attachment 593643 [details]
Screenshots

I was just able to (once) create a new workspace (after a clean install) and then create a new BPEL project and process file and not see the bug. See attached screenshots. This was after seeing the problem repeatedly earlier in the day.
Comment 10 Len DiMaggio 2012-06-22 10:13:37 EDT
The issue is caused by the bpel.facet.core code being duplicated in the org.eclipse.bpel.runtimes and org.jboss.tools.bpel.runtimes
Comment 11 JBoss JIRA Server 2012-06-25 13:03:46 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBDS-2209

Looks like you're right Len :) The solution is to simply remove the bpel.facet.core definition from the org.jboss.tools.bpel.runtimes plugin - this facet is already defined in org.eclipse.bpel.runtimes.

Fixed in trunk, patch for 3.3.x branch attached here for review.
Comment 12 JBoss JIRA Server 2012-06-25 13:04:42 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBDS-2209

Patch for org.jboss.tools.bpel.runtimes/plugin.xml
Comment 13 JBoss JIRA Server 2012-06-25 14:13:47 EDT
Douglas Palmer <dpalmer@redhat.com> made a comment on jira JBDS-2209

Patch looks good. Is it worth deleting the offending source code at the same time?

-- Posted from Bugbox for iPhone
Comment 14 JBoss JIRA Server 2012-06-26 10:35:23 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBDS-2209

Committed the patch.
Comment 15 Suz 2012-07-02 01:03:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When a user attempted to add a BPEL process file to a BPEL project, an error would occur. A non-fatal warning message would be displayed reading "the selected location is not a BPEL project". This problem has now been patched. As a result, the error no longer occurs wen adding the process.
Comment 16 JBoss JIRA Server 2012-07-02 04:47:44 EDT
Douglas Palmer <dpalmer@redhat.com> updated the status of jira JBDS-2209 to Resolved
Comment 17 Len DiMaggio 2012-07-16 15:40:22 EDT
The problem is not seen with the CR2 build.
Comment 18 Len DiMaggio 2012-07-16 15:43:56 EDT
Created attachment 598518 [details]
Screenshot of the - no longer present - bug

Note You need to log in before you can comment on or make changes to this bug.