Bug 831829 - SELinux is preventing /usr/libexec/mysqld from read, write access on the file /var/lib/mysql/ibdata1.
SELinux is preventing /usr/libexec/mysqld from read, write access on the file...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6457ad9857b1bc965d6dacf378e...
:
: 831830 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 16:44 EDT by lnhaig
Modified: 2012-06-13 17:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 17:22:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lnhaig 2012-06-13 16:44:41 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           Wed 13 Jun 2012 09:43:50 PM BST

description:
:SELinux is preventing /usr/libexec/mysqld from read, write access on the file /var/lib/mysql/ibdata1.
:
:*****  Plugin restorecon (94.8 confidence) suggests  *************************
:
:If you want to fix the label. 
:/var/lib/mysql/ibdata1 default label should be mysqld_db_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /var/lib/mysql/ibdata1
:
:*****  Plugin catchall_labels (5.21 confidence) suggests  ********************
:
:If you want to allow mysqld to have read write access on the ibdata1 file
:Then you need to change the label on /var/lib/mysql/ibdata1
:Do
:# semanage fcontext -a -t FILE_TYPE '/var/lib/mysql/ibdata1'
:where FILE_TYPE is one of the following: mysqld_t, puppet_tmp_t, afs_cache_t, hugetlbfs_t, mysqld_log_t, mysqld_tmp_t, user_cron_spool_t, mysqld_var_run_t, mysqld_db_t, root_t. 
:Then execute: 
:restorecon -v '/var/lib/mysql/ibdata1'
:
:
:*****  Plugin catchall (1.44 confidence) suggests  ***************************
:
:If you believe that mysqld should be allowed read write access on the ibdata1 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mysqld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:mysqld_t:s0
:Target Context                unconfined_u:object_r:var_lib_t:s0
:Target Objects                /var/lib/mysql/ibdata1 [ file ]
:Source                        mysqld
:Source Path                   /usr/libexec/mysqld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mysql-server-5.5.23-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux lancenb.haigmail.com 3.4.0-1.fc17.x86_64 #1
:                              SMP Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 13 Jun 2012 09:20:48 PM BST
:Last Seen                     Wed 13 Jun 2012 09:25:42 PM BST
:Local ID                      07d64d8a-a27c-4040-8c85-b81449d11f86
:
:Raw Audit Messages
:type=AVC msg=audit(1339619142.861:120): avc:  denied  { read write } for  pid=4946 comm="mysqld" name="ibdata1" dev="dm-1" ino=524391 scontext=system_u:system_r:mysqld_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1339619142.861:120): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff2eab4570 a1=2 a2=1b0 a3=7f0d20cf99d0 items=0 ppid=1 pid=4946 auid=4294967295 uid=27 gid=27 euid=27 suid=27 fsuid=27 egid=27 sgid=27 fsgid=27 tty=(none) ses=4294967295 comm=mysqld exe=/usr/libexec/mysqld subj=system_u:system_r:mysqld_t:s0 key=(null)
:
:Hash: mysqld,mysqld_t,var_lib_t,file,read,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-13 17:22:17 EDT
restroecon -R -v /var/lib  Just like the setroubleshoot told you
Comment 2 Daniel Walsh 2012-06-13 17:23:15 EDT
*** Bug 831830 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.