Bug 831843 - dependency error during "yum -y install katello-all"
dependency error during "yum -y install katello-all"
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 17:33 EDT by marc skinner
Modified: 2014-11-05 21:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 16:04:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marc skinner 2012-06-13 17:33:37 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Free install of RHEL6.2
2.Register to Satellite
3.Update to current errata
4.Join
5.yum -y install katello-all
  
Actual results:

Install all packages and dependencies for Katello
Processing Dependency: rubygem(polyglot) >= 0 for package: rubygem-treetop-1.4.9-3.el6.noarch
--> Running transaction check
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package rubygem-polyglot.noarch 0:0.3.1-2.el6 will be installed
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 (rhel-x86_64-server-6)
           Requires: /usr/bin/rebuild-gcj-db


Expected results:

Install all packages and dependencies for Katello

Additional info:

[root@se ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
repo id                                               repo name                                                                       status
rhel-x86_64-server-6                                  Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)                        7,248
rhel-x86_64-server-6-cf-se-1                          Red Hat CloudForms System Engine                                                  196
rhn-tools-rhel-x86_64-server-6                        RHN Tools for RHEL (v. 6 for 64-bit x86_64)                                        64
repolist: 7,508

---------------


system built with following packages:
%packages
@base
@client-mgmt-tools
@console-internet
@core
@debugging
@directory-client
@hardware-monitoring
@java-platform
@large-systems
@network-file-system-client
@performance
@perl-runtime
@server-platform
@server-policy
@virtualization
@virtualization-client
@virtualization-platform
pax
python-dmidecode
oddjob
sgpio
certmonger
pam_krb5
krb5-workstation
perl-DBD-SQLite
Comment 1 marc skinner 2012-06-14 15:26:49 EDT
I built another server running 6.2 - same issue.  It looks like its an issue with the java-1.5.0-gcj package?


yum -y install java-1.5.0-gcj
Loaded plugins: product-id, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: sinjdoc for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Running transaction check
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package sinjdoc.x86_64 0:0.5-9.1.el6 will be installed
--> Processing Dependency: java_cup >= 0.10 for package: sinjdoc-0.5-9.1.el6.x86_64
--> Running transaction check
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package java_cup.x86_64 1:0.10k-5.el6 will be installed
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 (rhel-x86_64-server-6)
           Requires: /usr/bin/rebuild-gcj-db
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 2 marc skinner 2012-06-15 16:04:44 EDT
NEVERMIND!

I built a new system, registered it to RHN directly and it worked.  I'm guessing my rhel-x86_64-server-6-cf-se-1 channel that I synced to my Satellite server is corrupt.  

Thanks!

Note You need to log in before you can comment on or make changes to this bug.