This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 831882 - [abrt] gnucash-2.4.10-1.fc17: __GI_raise: Process /usr/bin/gnucash was killed by signal 6 (SIGABRT)
[abrt] gnucash-2.4.10-1.fc17: __GI_raise: Process /usr/bin/gnucash was killed...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
abrt_hash:ae834f5d7343b6e9e6fb8fbebf1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 21:38 EDT by Miloslav Trmač
Modified: 2014-03-16 23:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 23:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.86 KB, text/plain)
2012-06-13 21:38 EDT, Miloslav Trmač
no flags Details
File: dso_list (17.96 KB, text/plain)
2012-06-13 21:38 EDT, Miloslav Trmač
no flags Details
File: maps (84.23 KB, text/plain)
2012-06-13 21:38 EDT, Miloslav Trmač
no flags Details

  None (edit)
Description Miloslav Trmač 2012-06-13 21:38:36 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gnucash
comment:        Trying to open a vendor's bill (an existing one, but creating a new one crashes similarly)
crash_function: __GI_raise
executable:     /usr/bin/gnucash
kernel:         3.3.7-1.fc17.x86_64
pid:            17475
pwd:            /home/mitr
time:           Čt 14. červen 2012, 03:18:27 CEST
uid:            1000
username:       mitr
var_log_messages: Jun 14 03:18:28 kulicka abrt[18028]: Saved core dump of pid 17475 (/usr/bin/gnucash) to /var/spool/abrt/ccpp-2012-06-14-03:18:27-17475 (101322752 bytes)

backtrace:      Text file, 35699 bytes
dso_list:       Text file, 18387 bytes
maps:           Text file, 86250 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mitr/2

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x68867 g_assertion_message libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x68d84 g_assertion_message_expr libglib-2.0.so.0 -
:61843617966f8d15d795acdbce2a7709c5da29cf 0x786e gnc_quickfill_cell_use_quickfill_cache libgncmod-register-core.so -
:3cba731f8713f792728fdc1a0afc93b050403b73 0xb2a8 gnc_entry_ledger_load libgnc-business-ledger.so.0 -
:3cba731f8713f792728fdc1a0afc93b050403b73 0xa517 gnc_entry_ledger_display_refresh libgnc-business-ledger.so.0 -
:950ce1090c22187d7eb1a8e336dd3d96efebfb01 0x22bd0 gnc_invoice_create_page libgncmod-business-gnome.so -
:950ce1090c22187d7eb1a8e336dd3d96efebfb01 0x2c450 - libgncmod-business-gnome.so -
:5e4a0601612d38d3ed67d4fc982b08a98f567531 0x76931 gnc_plugin_page_create_widget libgncmod-gnome-utils.so -
:5e4a0601612d38d3ed67d4fc982b08a98f567531 0x70791 gnc_main_window_open_page libgncmod-gnome-utils.so -
:950ce1090c22187d7eb1a8e336dd3d96efebfb01 0x1fdfa - libgncmod-business-gnome.so -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x206d8 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x2ead45 gtk_signal_emit libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x2be22a - libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x14cc3c - libgtk-x11-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x20450 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x27f20e - libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x14aa04 gtk_propagate_event libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x14ad6b gtk_main_do_event libgtk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x611cc - libgdk-x11-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x149d67 gtk_main libgtk-x11-2.0.so.0 -
:5e4a0601612d38d3ed67d4fc982b08a98f567531 0x68769 gnc_ui_start_event_loop libgncmod-gnome-utils.so -
:dbfbad0235815345a2f8b1d156b539bdda7dca03 0x3962 _start [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=kulicka
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/mitr/keyring-YWZKHj
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=mitr
:USERNAME=mitr
:MAIL=/var/spool/mail/mitr
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mitr/.local/bin:/home/mitr/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mitr
:XMODIFIERS=@im=none
:EDITOR=vim
:GNOME_KEYRING_PID=1120
:LANG=cs_CZ.utf8
:GDM_LANG=cs_CZ.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoreboth
:XDG_SEAT=seat0
:HOME=/home/mitr
:SHLVL=1
:LOGNAME=mitr
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-CDpDrl5Qaq,guid=10b26a202f90929ba7f7506300000033
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mitr
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-mitr-s4GgGo/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1125,unix/unix:/tmp/.ICE-unix/1125
:SSH_AUTH_SOCK=/run/user/mitr/keyring-YWZKHj/ssh
:GPG_AGENT_INFO=/run/user/mitr/keyring-YWZKHj/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 62812                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       62812                62812                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mitr/.xsession-errors
:pos:	13890203
:flags:	0102002
:2:/home/mitr/.xsession-errors
:pos:	13890203
:flags:	0102002
:3:/tmp/gnucash.trace
:pos:	4556
:flags:	0100002
:4:socket:[196892]
:pos:	0
:flags:	02004002
:5:/dev/urandom
:pos:	0
:flags:	02100000
:6:socket:[196891]
:pos:	0
:flags:	02000002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:pipe:[196015]
:pos:	0
:flags:	00
:10:pipe:[196015]
:pos:	0
:flags:	04001
:11:socket:[196016]
:pos:	0
:flags:	02000002
:12:socket:[196893]
:pos:	0
:flags:	02004002
:13:pipe:[194372]
:pos:	0
:flags:	00
:14:pipe:[194372]
:pos:	0
:flags:	01
:15:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:16:/home/REDACTED_BY_mitr.LCK
:pos:	0
:flags:	0100002
:17:socket:[196979]
:pos:	0
:flags:	02004002
:18:/home/REDACTED_BY_mitr.log
:pos:	170
:flags:	0102001

xsession_errors:
:abrt-applet: repeated problem in gnucash-2.4.10-1.fc17, not showing the notification
:abrt-applet: repeated problem in gnucash-2.4.10-1.fc17, not showing the notification
Comment 1 Miloslav Trmač 2012-06-13 21:38:41 EDT
Created attachment 591705 [details]
File: backtrace
Comment 2 Miloslav Trmač 2012-06-13 21:38:46 EDT
Created attachment 591706 [details]
File: dso_list
Comment 3 Miloslav Trmač 2012-06-13 21:38:48 EDT
Created attachment 591707 [details]
File: maps
Comment 4 Miloslav Trmač 2012-06-13 21:41:21 EDT
This makes it impossible to both enter new bills and access old bills.  (Some of the data from old bills is visible in the general ledger.)
Comment 5 Bill Nottingham 2012-06-15 23:01:29 EDT

*** This bug has been marked as a duplicate of bug 824189 ***
Comment 6 Fedora Update System 2012-06-16 00:40:50 EDT
gnucash-2.4.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnucash-2.4.10-2.fc17
Comment 7 Fedora Update System 2012-06-22 14:53:52 EDT
gnucash-2.4.10-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.