Bug 831915 - "[Fatal Error]" message is misleading
"[Fatal Error]" message is misleading
Status: CLOSED CANTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 00:56 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 01:02:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-06-14 00:56:26 EDT
During a csprocessor build, if a topic contains invalid xml the csprocessor reports a "Fatal Error", e.g.:


Starting to validate...
INFO:  The Content Specification is valid.

Starting to build...
[Fatal Error] :6:3: The element type "para" must be terminated by the matching end-tag "</para>".



Suggested message:


INFO: Topic __ could not be built: :6:3 The element type "para" must be terminated by the matching end-tag "</para>"


==============================
Generated Details:

Package: cspclient-0.24.7-1.noarch
Comment 1 Lee Newson 2012-06-14 01:02:49 EDT
Unfortunately there is not much I can do about this since the library prints the error message straight to stderr. In other words this isn't an error I'm printing myself. In the final build though it does show that type of error in the "Compiler Output" chapter.

Note You need to log in before you can comment on or make changes to this bug.