Bug 831921 - vdsm service startup fails because of start libvirtd timeout
vdsm service startup fails because of start libvirtd timeout
Status: CLOSED DUPLICATE of bug 832199
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Douglas Schilling Landgraf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 01:09 EDT by Royce Lv
Modified: 2012-08-17 14:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 14:18:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Royce Lv 2012-06-14 01:09:17 EDT
Description of problem:
vdsm service timeout and get killed because it takes too long to start libvirt service.
log:
Jun 14 12:44:56 lvroyce-pc systemd-vdsmd[1183]: vdsm: libvirt already configured for vdsm [  OK  ]
Jun 14 12:44:56 lvroyce-pc systemd-vdsmd[1183]: Starting wdmd...
Jun 14 12:44:56 lvroyce-pc systemd-vdsmd[1183]: Starting sanlock...
Jun 14 12:44:57 lvroyce-pc systemd-vdsmd[1183]: Starting iscsid:
Jun 14 12:46:25 lvroyce-pc systemd[1]: vdsmd.service operation timed out. Terminating.
Jun 14 12:46:25 lvroyce-pc systemd[1]: Unit vdsmd.service entered failed state.
Jun 14 12:46:45 lvroyce-pc systemd[1]: Reloading.
Jun 14 12:46:45 lvroyce-pc systemd-vdsmd[2782]: vdsm: libvirt already configured for vdsm [  OK  ]
Jun 14 12:46:46 lvroyce-pc systemd-vdsmd[2782]: Starting iscsid:
Jun 14 12:48:15 lvroyce-pc systemd[1]: vdsmd.service operation timed out. Terminating.
Jun 14 12:48:15 lvroyce-pc systemd[1]: Unit vdsmd.service entered failed state.

Version-Release number of selected component (if applicable):
libvirt-0.9.12-1.fc16.x86_64
vdsm-4.10.0-0.19.fc16.x86_64

How reproducible:
sometimes,restart machine and start vdsmd

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[lvroyce@lvroyce-pc ~]$ sudo service vdsmd status
Redirecting to /bin/systemctl  status vdsmd.service
vdsmd.service - Virtual Desktop Server Manager
	  Loaded: loaded (/lib/systemd/system/vdsmd.service; enabled)
	  Active: failed since Thu, 14 Jun 2012 12:48:15 +0800; 978ms ago
	 Process: 2782 ExecStart=/lib/systemd/systemd-vdsmd start (code=killed, signal=TERM)
	  CGroup: name=systemd:/system/vdsmd.service

Expected results:
vdsmd start normally

Additional info:
Comment 1 Dan Kenigsberg 2012-06-18 12:09:08 EDT
there is no real reason why libvirt is restarted every time vdsmd is. any taker to fix that?
Comment 2 Douglas Schilling Landgraf 2012-07-09 16:36:18 EDT
Hello Royce,

       Can you please confirm if this report is affected from this bug:

vdsmd init script times out due to lengthy semanage operation
https://bugzilla.redhat.com/show_bug.cgi?id=832199 ? 

At this point, we should be fine.

Thanks
Comment 3 Douglas Schilling Landgraf 2012-08-17 14:18:05 EDT
No response here, closing this BZ as duplicate of 832199.
Fell free to reopen it in case it's wrong state.

Thanks
Douglas

*** This bug has been marked as a duplicate of bug 832199 ***

Note You need to log in before you can comment on or make changes to this bug.