Bug 831947 - 5 gears can be created as normal user.
5 gears can be created as normal user.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 03:15 EDT by Yujie Zhang
Modified: 2015-05-14 21:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Create 5 applications as a normal user. (121.48 KB, image/png)
2012-06-14 03:15 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2012-06-14 03:15:32 EDT
Created attachment 591754 [details]
Create 5 applications as a normal user.

Description of problem:

I created a scalable application of jbosseap-6.0 type and I can scale this application to 5 gears as a normal user, my account is "yujzhang+9989@redhat.com", and after I delete the jbosseap application, I can create 5 simple applications. I can not reproduce when I changed another account,but the above condition did happened.

Version-Release number of selected component (if applicable):

int.openshift.redhat.com

How reproducible:randomly


Steps to Reproduce:
1.Create a scalable applicaiton of jbosseap-6.0 type 
2.scale up this application
3.Delete the jbosseap-6.0 application and create more than 3 simple application
  
Actual results:

I can create 5 gears using "yujzhang+9989@redhat.com" account.Details see in attachment.

Expected results:

The number of gears should be limited to 3.

Additional info:
Comment 1 Xiaoli Tian 2012-06-14 09:16:34 EDT
This can not be always reproduced, just happened by chance.
Comment 2 Ravi Sankar 2012-06-19 12:56:38 EDT
Unable to reproduce this issue.
Comment 3 Dan McPherson 2012-06-19 13:54:52 EDT
Can you delete some of the users current gears and try to recreate now?  I think the issue has been resolved.
Comment 4 Yujie Zhang 2012-06-20 02:43:39 EDT
(In reply to comment #3)
I deleted all the applicaiton then tried to create again, but it will say I reach the limit of gears, strangly, but anyway I can not reproduce the above issue. And only the account "yujzhang+9989@redhat.com" will has this issue, it is ok when u sing other accout, so verify this bug.

Note You need to log in before you can comment on or make changes to this bug.